WineHQ
Wine Forums

Board index » WineHQ » Wine Help » macOS




 Page 1 of 1 [ 6 posts ] 



 
Author Message
 Post Posted: Wed Nov 29, 2017 6:05 am 
Offline
Newbie
Newbie

Joined: Wed Nov 29, 2017 5:57 am
Posts: 4
I have an application that uses a windowless ("lightweight") UserControl, consisting of a couple of Labels, an Image, and which draws its own border.

This works fine under Windows -- with different screen resolutions -- but isn't fully working on a Mac. The problem is that Click operations on instances of the UserControl have to be well within the border -- up to several millimetres inside. Since those instances are relatively small then this is a usability issue.

Is this a known problem? I am not a Mac user myself and so I am relaying information from my clients.


Top 
 Post Posted: Wed Nov 29, 2017 10:01 am 
Offline
Newbie
Newbie

Joined: Wed Nov 29, 2017 5:57 am
Posts: 4
If there's a problem with this post, please state them explicitly here. The automatically-generated "disapproval" I have received does not make any sense.


Top 
 Post Posted: Wed Nov 29, 2017 11:11 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12130
ACProctor wrote:
If there's a problem with this post, please state them explicitly here. The automatically-generated "disapproval" I have received does not make any sense.

You submitted your original post twice. The first one was approved, the second was disapproved as a duplicate.


Top 
 Post Posted: Wed Nov 29, 2017 12:35 pm 
Offline
Newbie
Newbie

Joined: Wed Nov 29, 2017 5:57 am
Posts: 4
That sounds very likely, but the email actually said:

"The following reason was given for the disapproval:

The reported message does not fit into any other category, please use the
further information field."


Top 
 Post Posted: Wed Nov 29, 2017 11:19 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12130
It should have said "Duplicate post" after that.


Top 
 Post Posted: Thu Nov 30, 2017 4:40 am 
Offline
Newbie
Newbie

Joined: Wed Nov 29, 2017 5:57 am
Posts: 4
Additional to the problem of failing mouse clicks if they're too close to the UserControl's border concerns drag-and-drop. If client's drag-and-drop one instance of this UserControl to another then the ghost image of the border -- the default Windows indication that the operation is being performed -- does not show on the Mac. The operation completes OK but there's no visual indication of what the user is doing.

I have a feeling that these might both be related to fact that the UserControl is a windowless ("lightweight") one as I'm sure such issues would have been reported otherwise.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 6 posts ] 




Board index » WineHQ » Wine Help » macOS


Who is online

Users browsing this forum: No registered users and 4 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: