I'm lost (GP500)

Questions about Wine on macOS.
Locked
Lincot
Level 1
Level 1
Posts: 9
Joined: Sat Apr 26, 2014 11:34 am

I'm lost (GP500)

Post by Lincot » Mon Apr 28, 2014 4:00 pm

Hi guys, I want to run this old game, GP500 by Microprose, it seems it worked very well, but I dont know where to start. I have Wine 1.7.16 and a OS X 10.9.2.

Btw I have the game installer, but I would like to use the folder with all the files.

https://appdb.winehq.org/objectManager. ... &iId=12807

Someone want to help me please?

Many thanks.

Lincot
Level 1
Level 1
Posts: 9
Joined: Sat Apr 26, 2014 11:34 am

Re: I'm lost (GP500)

Post by Lincot » Fri May 23, 2014 4:31 pm

Bump, anyone want to to help me to try the game on his own Mac, please?

Lincot
Level 1
Level 1
Posts: 9
Joined: Sat Apr 26, 2014 11:34 am

Re: I'm lost (GP500)

Post by Lincot » Fri May 23, 2014 9:36 pm

Look the log file

fixme:file:get_default_com_device no known default for device com1
fixme:file:get_default_com_device no known default for device com2
fixme:file:get_default_com_device no known default for device com3
fixme:file:get_default_com_device no known default for device com4
fixme:file:get_default_com_device no known default for device com5
fixme:file:get_default_com_device no known default for device com6
fixme:file:get_default_com_device no known default for device com7
fixme:file:get_default_com_device no known default for device com8
err:dplay:IDirectPlay4Impl_InitializeConnection Unable to load service provider {44eaa760-cb68-11cf-9c4e-00a0c905425e}
err:dplay:DirectPlayCreate Failed to Initialize SP: DPERR_UNAVAILABLE
fixme:win:EnumDisplayDevicesW ((null),0,0x32eafc,0x00000000), stub!
fixme:d3d:wined3d_device_decref Device released with resources still bound, acceptable but unexpected.
fixme:d3d:wined3d_device_decref Leftover resource 0x190d58 with type WINED3D_RTYPE_SURFACE (0x1).
fixme:d3d:wined3d_device_decref Leftover resource 0x190c08 with type WINED3D_RTYPE_TEXTURE (0x3).
err:ole:CoGetClassObject class {d8f1eee0-f634-11cf-8700-00a0245d918b} not registered
err:ole:CoGetClassObject no class object {d8f1eee0-f634-11cf-8700-00a0245d918b} could be created for context 0x1
fixme:win:EnumDisplayDevicesW ((null),0,0x32d25c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32e7dc,0x00000000), stub!
fixme:ddraw:DirectDrawEnumerateExA flags 0x00000006 not handled
fixme:win:EnumDisplayDevicesW ((null),0,0x32e5bc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32dddc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32dddc,0x00000000), stub!
fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e5ac,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32e88c,0x00000000), stub!
err:ddraw:d3d_device3_GetRenderState Unexpected texture stage state setup, returning D3DTBLEND_MODULATE - likely erroneous.
fixme:ddraw:ddraw_surface7_Flip Ignoring flags 0x1.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e56c,0x00000000), stub!
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x173228) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:state_subpixel Render state WINED3D_RS_SUBPIXEL not implemented yet.
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x1573a0) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x21f3f0) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x21f8d8) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x21fd00) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x21ad370) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:amstream:IAMMultiMediaStreamImpl_AddMediaStream Specifying a stream object in params is not yet supported
err:quartz:GetClassMediaFile Media class not found
fixme:amstream:IDirectDrawStreamSampleImpl_GetSurface (0x157450)->(0x5955a4,0x595010): stub
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x2197898) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x21fe68) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x218ffd0) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x2190368) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x2190700) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x21f578) WINED3DFMT_DXT1 256x256 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT (0x8cd6)
fixme:d3d:context_check_fbo_status Location WINED3D_LOCATION_TEXTURE_RGB (0x20).
fixme:d3d:context_check_fbo_status Color attachment 0: (0x218f520) WINED3DFMT_DXT1 128x128 0 samples.
err:d3d:context_bind_texture >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBindTexture @ context.c / 2150
err:d3d:wined3d_event_query_finish glClientWaitSync returned 0x911b.
err:d3d:buffer_sync_apple wined3d_event_query_finish returned 4, dropping async buffer locks
fixme:ddraw:d3d_device_inner_Release Material handle 0x1 (0x18ebf0) not unset properly.
wine: Unhandled page fault on read access to 0x00000129 at address 0x423f6771 (thread 0009), starting debugger...
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}

Lincot
Level 1
Level 1
Posts: 9
Joined: Sat Apr 26, 2014 11:34 am

Re: I'm lost (GP500)

Post by Lincot » Fri May 23, 2014 10:54 pm

the game have visual problems and crashes due to this.

Lincot
Level 1
Level 1
Posts: 9
Joined: Sat Apr 26, 2014 11:34 am

Re: I'm lost (GP500)

Post by Lincot » Sat May 24, 2014 1:24 pm

this is what've talking about

Image

terry
Newbie
Newbie
Posts: 1
Joined: Fri Jun 27, 2014 5:21 am

Re: I'm lost (GP500)

Post by terry » Fri Jun 27, 2014 6:20 am

I'm a beginner at dealing with problems running things in Wine, but since no one else has, I guess I'll give it a shot.

I could suggest a few winetricks you might try based on the err lines, but given that the AppDB rating for that game is platinum (based on 2 reports though that may be), your trouble may well stem from not running the game's installer. Would it be that much trouble to try using it instead of copying the files?

Otherwise, in an isolated wine prefix...
To tackle the graphical issues and those "err:d3d" lines, I'd try `winetricks d3dx9_36`. If that doesn't work, try `winetricks d3dx9`.

hrik2001
Level 2
Level 2
Posts: 31
Joined: Tue Jun 03, 2014 10:43 am

Re: I'm lost (GP500)

Post by hrik2001 » Sun Jun 29, 2014 2:10 am

you guys talk too much and dont talk about the question i am telling you what to do. I use winebottler and wine. both are pretty same so this should work. There is a option saying that "this is only the installer. take only the .exe file" or some thing like that. then there is a optiuon saying this is installer copy all the files with it

hrik2001
Level 2
Level 2
Posts: 31
Joined: Tue Jun 03, 2014 10:43 am

Re: I'm lost (GP500)

Post by hrik2001 » Sun Jun 29, 2014 2:11 am

you guys talk too much and dont talk about the question i am telling you what to do. I use winebottler and wine. both are pretty same so this should work. There is a option saying that "this is only the installer. take only the .exe file" or some thing like that. then there is a optiuon saying this is installer copy all the files with it

doh123
Level 8
Level 8
Posts: 1227
Joined: Tue Jul 14, 2009 1:21 pm

Re: I'm lost (GP500)

Post by doh123 » Sun Jun 29, 2014 9:55 am

hrik2001 wrote:you guys talk too much and dont talk about the question i am telling you what to do. I use winebottler and wine. both are pretty same so this should work. There is a option saying that "this is only the installer. take only the .exe file" or some thing like that. then there is a optiuon saying this is installer copy all the files with it
What you are talking about has nothing to do with the problem, and also has nothing to do with plain normal Wine, just WineBottler's Wine app, which is not normal plain Wine.

The log files look like D3D issues, and since there are graphics issues, Terry's suggestions are worth a shot. I'd also check to see if it worked better in a virtual desktop, or maybe try some of the D3D registry settings.

Lincot
Level 1
Level 1
Posts: 9
Joined: Sat Apr 26, 2014 11:34 am

Re: I'm lost (GP500)

Post by Lincot » Wed Aug 20, 2014 4:10 pm

Any help?

Locked