Winetricks: Wineserver Not Found

Questions about Wine on macOS.
Locked
TheMacGeek
Newbie
Newbie
Posts: 1
Joined: Fri Jan 24, 2014 11:21 pm

Winetricks: Wineserver Not Found

Post by TheMacGeek » Fri Jan 24, 2014 11:41 pm

Hey guys, I am relatively new to wine but I'm not completely hopeless so I did a lot of research and looked on several websites. None of them helped, so I have no option but to ask here.

Here is my problem explained:

I am trying to install a Setup.exe file with Wineskin and this problem shows up:

Runtime Error (at - 1:0):
Cannot Import dll:C:\users\xxx\Temp\is-36740.tmp\isskin.dll


Now, before you go off at me saying that this problem has already been resolved I'm gonna say, I know. After researching, I found this link with a solution:
http://forum.winehq.org/viewtopic.php?t=8896

When I saw the listed solution, and the terrifying website for Winetricks, I persevered and managed to install Winetricks. Somehow. I found a much more "n00b Friendly" tutorial about installing Winetricks on Mac here:
http://community.linuxmint.com/tutorial/view/547

Even though this code did not work for me:
wget http://winetricks.org/winetricks
I researched more and found this one which did work:
curl http://winetricks.org/winetricks > winetricks

So I finally got Winetricks installed, and all I had to do was run this command from Terminal, right?
sh winetricks directx9
(Not sure what this was for but I assume it's necessary?)
And then this one:
sh winetricks vcrun6sp6
(This seemed to be the magic code listed on all forums and websites I found)

Wrong. After trying both codes the following error comes up in Terminal:
------------------------------------------------------
wineserver not found!
------------------------------------------------------


So I did more research and tried several methods but eventually got lost. I am now stuck in a loop and even though this method has "Supposedly" been resolved, nothing I tried worked.

After exploring this location:
/usr/local/bin

I found the Wineserver and the Winetricks file but the Wineserver file was an alias. Double-clicking it, my Mac tells me this:

The operation can’t be completed because the original item for “wineserver” can’t be found.

Which I take to mean that somehow I installed an alias of Wineserver, without the original item existing...?

If I could get some clear and precise instructions on how to fix this "Winserver not found" issue, that would be wonderful. If you have any more questions for me just post it in the comments and I will try to answer them. Just remember that I am not 100% code-savvy.

Other Info:
I am using Mac OSX 10.8.5 and I use Wineskin Winery 1.7 with the Latest Package (1.7.10)

I am currently attempting to Install refx Nexus 2 VST Plugin to use for FL Studio 11 (which I installed fine with Wine) It's the Nexus 2 Setup file located in the drive that comes from the .iso file which is giving me trouble.

Thanks!

Farid13
Newbie
Newbie
Posts: 1
Joined: Tue Feb 04, 2014 4:33 pm

Re: Winetricks: Wineserver Not Found

Post by Farid13 » Tue Feb 04, 2014 4:37 pm

Hey, any luck with this? I'm having the same exact problem right up to "Wineserver not found!"

doh123
Level 8
Level 8
Posts: 1227
Joined: Tue Jul 14, 2009 1:21 pm

Re: Winetricks: Wineserver Not Found

Post by doh123 » Wed Feb 05, 2014 7:05 pm

While Wineskin isn't supported here... let me give you some info.

normal Winetricks you get by yourself will not recognize Wineskin, or the wineserver in your wrapper's engine.

You do not need to do that if you use Wineskin though, as Winetricks is already built into Wineskin. Just run Wineskin.app and go to Advanced, and on the Tools tab is a Winetricks button, with a full GUI front end to use Winetricks.

RTB84
Newbie
Newbie
Posts: 1
Joined: Sun Jan 11, 2015 1:17 am

Re: Winetricks: Wineserver Not Found

Post by RTB84 » Sun Jan 11, 2015 1:33 am

I have exactly the same problem of "The Mac Geek"
did anyone managed to fix this?

robotspierre
Newbie
Newbie
Posts: 1
Joined: Sat Nov 28, 2015 1:27 pm

Re: Winetricks: Wineserver Not Found

Post by robotspierre » Sat Nov 28, 2015 1:38 pm

Here is what you have to do:

1) Create the wrapper, Show Package Contents, run Wineskin
2) Click Advanced
3) Click Tools, then Winetricks
4) Search for vcrun6sp6 (or find it in dlls) and check the box next to it
5) Click Run
6) Wait for it to do its thing
7) Done!

Locked