X11 help on OS X 10.6

Questions about Wine on macOS.
Locked
jwong
Level 2
Level 2
Posts: 25
Joined: Thu Feb 17, 2011 4:58 pm
Location: US

X11 help on OS X 10.6

Post by jwong » Fri Nov 04, 2011 10:06 pm

I know this is an X11 question but the only time I use X11 is via Wine.

I dont know what happened but now whenever I start x11.app (this includes any wine apps) I always get 3 xterms and xclock starts. I know the reason for the 3 xterms and xclock. /usr/X11/lib/X11/xinitrc has instructions to do so. I did not change the file.

The other strange thing is the windows look very old. The frames are turqoise in color and look like a X window from the old monochrome days.

How can I switch back to default behavior (only 1 xterm window) with the more modern window? What changed?

doh123
Level 8
Level 8
Posts: 1227
Joined: Tue Jul 14, 2009 1:21 pm

Post by doh123 » Sat Nov 05, 2011 7:36 am

Does this happen only with X11.app and not XQuartz.app or all?

Do you have the hidden file in your home folder called .xinitrc ? it may be doing some different things... if you have that file you could trash it. Did you install any X11 stuff with Fink or Macports or any other apps recently that try to use X11 that might have changed this for you?

jwong
Level 2
Level 2
Posts: 25
Joined: Thu Feb 17, 2011 4:58 pm
Location: US

Post by jwong » Sat Nov 05, 2011 2:30 pm

I have not tried xquartz.app. Is there such a thing? See below.

I don't have ~/ .xinitrc. The stock xinitrc in /usr/X11 is telling to start the 3 xterms and xclock. My other computer which does not have the problem has the same xinitrc. What this means is there is some other setup file instructing X11 to not use xinitrc.

The only thing I installed was wine , wineskin and the freetype library. I suspect one of these changed a setting somewhere. When I start x11.app and then check 'About X11' it says I am using xquartz 2.3.6. This is what the system came with.

I tried another user account and the same problem was there.

Starting 'terminal' looks fine.

doh123
Level 8
Level 8
Posts: 1227
Joined: Tue Jul 14, 2009 1:21 pm

Post by doh123 » Sat Nov 05, 2011 4:01 pm

Well I'm not sure on your specific problem, but XQuartz is always a better bet than Apple's X11.app.

http://xquartz.macosforge.org/

jwong
Level 2
Level 2
Posts: 25
Joined: Thu Feb 17, 2011 4:58 pm
Location: US

Post by jwong » Sat Nov 05, 2011 5:16 pm

I tried restoring from Time Machine my /usr and /opt directories but that didnt help. Fortunately I was able to get hold of an OS X installation disk. I just reinstalled X11 and I'm back in business.

Thanks for your help.

Locked