Installing Wine 6.3 on MacOS Big Sur with Apple Silicon

Questions about Wine on macOS.
Post Reply
KingRetracted
Newbie
Newbie
Posts: 2
Joined: Fri Jul 30, 2021 10:24 pm

Installing Wine 6.3 on MacOS Big Sur with Apple Silicon

Post by KingRetracted » Fri Jul 30, 2021 10:27 pm

Hello! I am trying to install wine on my M1 Mac with the MacOS Big Sur operating system. I have looked into articles but they have been outdated (before wine supported m1). From what I have seen, 6.1 is when M1 support was added. The default packages are still outdated (version under 6.1) and I have not been able to compile from the source code. It always results in errors. If anyone here could possibly help me out, I would appreciate it.

Gcenx
Level 6
Level 6
Posts: 622
Joined: Mon Dec 25, 2017 12:11 pm

Re: Installing Wine 6.3 on MacOS Big Sur with Apple Silicon

Post by Gcenx » Sat Jul 31, 2021 7:02 am

Winehq macOS packages have been depreciated as the builtbot was taken offline by the owners. Compiling modern wine has at more requirements than it did previously.

The M1 support in recent wine versions is wine64 running via Rosetta2, this mean no 64Bit support. If that’s all you require you could simple install one of the packages I provide.

Use my brew tap to install wine-stable-6.0.1

Code: Select all

brew tap gcenx/wine
brew install --cask --no-quarantine gcenx-wine-stable
If you do require 32Bit support you should purchase CrossOver but don’t upgrade past macOS Big Sur currently as macOS Monterey beta versions have completely broken wine.

KingRetracted
Newbie
Newbie
Posts: 2
Joined: Fri Jul 30, 2021 10:24 pm

Re: Installing Wine 6.3 on MacOS Big Sur with Apple Silicon

Post by KingRetracted » Sat Jul 31, 2021 6:17 pm

I have ran the commands you have provided and I get a "zsh: bad CPU type in executable: wine" when I run the command "wine --version"

Gcenx
Level 6
Level 6
Posts: 622
Joined: Mon Dec 25, 2017 12:11 pm

Re: Installing Wine 6.3 on MacOS Big Sur with Apple Silicon

Post by Gcenx » Sun Aug 01, 2021 10:15 am

KingRetracted wrote:
Sat Jul 31, 2021 6:17 pm
I have ran the commands you have provided and I get a "zsh: bad CPU type in executable: wine" when I run the command "wine --version"
Naturally as I’d said above 32Bit is not supported in upstream wine you can use wine64.

If you need 32Bit support purchase a CrossOver license for the best experience or use my wine-crossover packages that’s also available from my homebrew tap. The wine-crossover package doesn’t provide support for macOS DXVK unlike CrossOver.

Post Reply