Wine 6.6 not opening anything

Questions about Wine on Linux
Post Reply
Iammethe24
Newbie
Newbie
Posts: 3
Joined: Thu Apr 22, 2021 3:15 am

Wine 6.6 not opening anything

Post by Iammethe24 » Thu Apr 22, 2021 3:32 am

I recently changed from winehq-stable (6.0) to winehq-devel (6.6) and something weird happened, nothing ever launches anymore. I've decided to see what's happening via System Monitor, and I can see Wine processes opening and immidiately closing afterwards when I open a .exe from Nautilus. I would like to know why this is happening and how to fix this. I'm using Ubuntu 20.10. I have not made any library or DLL Overrides in winecfg nor have used winetricks.

spoon0042
Level 6
Level 6
Posts: 516
Joined: Thu Dec 24, 2009 11:00 am

Re: Wine 6.6 not opening anything

Post by spoon0042 » Thu Apr 22, 2021 11:21 am

Can you run wine from a terminal and post the output? Like 'cd' to the directory of something that doesn't work then 'wine program.exe'

There is a bug or two currently causing issues, you may have to downgrade temporarily.

Iammethe24
Newbie
Newbie
Posts: 3
Joined: Thu Apr 22, 2021 3:15 am

Re: Wine 6.6 not opening anything

Post by Iammethe24 » Thu Apr 22, 2021 8:00 pm

I just tested it, I can open programs using the command line interface. I still can't launch it successfully using Nautilus though. :D

abraxa
Level 2
Level 2
Posts: 27
Joined: Sat Feb 13, 2016 5:48 am

Re: Wine 6.6 not opening anything

Post by abraxa » Fri Apr 23, 2021 3:46 am

Thank you for bringing this up.

I have had the same experience with Winetricks/Wine 6.6-1 and Dolphin. EXEs do not launch anymore, except when started from within the Konsole.

spoon0042
Level 6
Level 6
Posts: 516
Joined: Thu Dec 24, 2009 11:00 am

Re: Wine 6.6 not opening anything

Post by spoon0042 » Fri Apr 23, 2021 4:56 pm

6.7 released today, once packages are available can you check that things are working again?

Iammethe24
Newbie
Newbie
Posts: 3
Joined: Thu Apr 22, 2021 3:15 am

Re: Wine 6.6 not opening anything

Post by Iammethe24 » Sun Apr 25, 2021 10:04 pm

Nope, it's exactly the same on 6.7

lorn10
Newbie
Newbie
Posts: 3
Joined: Wed Jul 24, 2019 9:48 am

Re: Wine 6.6 not opening anything

Post by lorn10 » Mon Apr 26, 2021 8:45 am

I had the same weird problem, - when I upgraded to Wine 6.6 devel I was also not able to start a Windows application with a double-click. It ran only from console. After upgrading to Wine 6.7 devel the problem was still present. Then I proceed a reboot and now everything works as it should! As far as I can remember I had to wait the first time a while until the Windows app has started. But this was really only the first time after the reboot the case. Now I can launch the Windows programs normally.

This is really strange. Whatever, I am on latest Kubuntu 20.04 LTS.

Post Reply