BF1942 (SW Demo) doesn't run despite clean install.

Questions about Wine on Linux
Post Reply
HMaccount
Newbie
Newbie
Posts: 3
Joined: Mon Apr 19, 2021 11:21 am

BF1942 (SW Demo) doesn't run despite clean install.

Post by HMaccount » Mon Apr 19, 2021 11:37 am

Hello!

I'm trying to run a demo of Battlefield 1942: Secret Weapons on my computer through wine. I'm currently on Linux 5.10.26-1 (although I tried multiple times running the game on Linux 5.4, without success aswell), running Manjaro 21.0 on XFCE.

Whenever I run the .exe for the game, be either the Blackscreen.exe or the BF1942.exe, it won't do a thing. Whenever I run it on console, the only lines are "found keys" from game related stuff and:

Code: Select all

0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0024:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0021F2EC 1 C) semi-stub
0024:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0021F25C 1 C) semi-stub
0024:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0021EA3C 1 C) semi-stub
I tried running other versions of Battlefield 1942 readily available on the internet, such as the Singleplayer Demo (which runs flawlessly, as intended) and the Multiplayer Demo (which renders an old error), but this specific version of the game won't run.

On my previous machine, the game would run perfectly on Wine on default settings after the install, without the need to set up anything or change any settings. The biggest difference between the previous computer I was using to this one is that the previous one had a nVidia GFX board, while this one is an AMD onboard one. Both OSs had 64bit architecture, running Manjaro on XFCE.

I have no idea how to start to solve this problem, if it's even solveable. If someone have the time to spare and help me, I'd greatly appreciate it.

Thank you!

User avatar
Bob Wya
Level 12
Level 12
Posts: 3022
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: BF1942 (SW Demo) doesn't run despite clean install.

Post by Bob Wya » Wed Apr 21, 2021 3:00 pm

HMaccount wrote:
Mon Apr 19, 2021 11:37 am
...
On my previous machine, the game would run perfectly on Wine on default settings after the install, without the need to set up anything or change any settings. The biggest difference between the previous computer I was using to this one is that the previous one had a nVidia GFX board, while this one is an AMD onboard one. Both OSs had 64bit architecture, running Manjaro on XFCE.
...
@HMaccount

This might indicate an issue with graphics support.

The output from:

Code: Select all

inxi -CG
- for the onboard AMD iGPU.

Also a Wine terminal log with:

Code: Select all

WINEDEBUG=+timestamp,+tid,+wgl wine BF1942.EXE &>~/wine_bf1942_log.txt
could be helpful.

Ta
Bob

HMaccount
Newbie
Newbie
Posts: 3
Joined: Mon Apr 19, 2021 11:21 am

Re: BF1942 (SW Demo) doesn't run despite clean install.

Post by HMaccount » Wed Apr 21, 2021 4:52 pm

Thanks for the reply, Bob Wya!

The output from inxi -GC was:

Code: Select all

CPU:       Info: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 
           type: MT MCP cache: L2: 2 MiB 
           Speed: 1364 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1364 2: 3017 3: 1655 
           4: 1369 5: 1363 6: 3033 7: 1534 8: 1363 
Graphics:  Device-1: AMD Picasso driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting 
           resolution: 1920x1080~60Hz 
           OpenGL: 
           renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.10.30-1-MANJARO LLVM 11.1.0) 
           v: 4.6 Mesa 21.0.2 
The debug file for the wine application was too big for this post, so I posted it on this Pastebin (https://pastebin.ubuntu.com/p/qq2zXDzrBG/).

Thanks for the hasty reply!

User avatar
Bob Wya
Level 12
Level 12
Posts: 3022
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: BF1942 (SW Demo) doesn't run despite clean install.

Post by Bob Wya » Thu Apr 22, 2021 11:08 am

HMaccount wrote:
Wed Apr 21, 2021 4:52 pm
...
The debug file for the wine application was too big for this post, so I posted it on this Pastebin (https://pastebin.ubuntu.com/p/qq2zXDzrBG/).
...
Right, so Wine isn't even loading the libraries for OpenGL graphics rendering support... :cry:

Could you perhaps retest with wine-staging 6.6 ... ?
Or even wine-tkg-git? If you can be bothered to build this from source - since this has a Arch PKGBUILD script.

If you could post a Wine terminal log, with the following debug channels enabled:

Code: Select all

WINEDEBUG=+timestamp,+tid,+seh,+loaddll wine BF1942.EXE &>~/wine_bf1942_log.txt
- this might help enlighten us, what is going wrong! :lol:

Your issue may need to move over to a WineHQ Bugzilla bug report...

Ta
Bob

HMaccount
Newbie
Newbie
Posts: 3
Joined: Mon Apr 19, 2021 11:21 am

Re: BF1942 (SW Demo) doesn't run despite clean install.

Post by HMaccount » Thu Apr 22, 2021 1:17 pm

I installed wine-staging 6.6.1, available on Manjaro's official repos.

The full log is in this pastebin (https://pastebin.ubuntu.com/p/r8b639bwVf/) but the first lines from the debug changed a bit. Long story short:

Code: Select all

9757.922:002c:fixme:winediag:LdrInitializeThunk wine-staging  is a testing version containing experimental patches.
9757.922:002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
9758.066:0058:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\win32k.sys"
9758.271:0094:err:winedevice:ServiceMain Failed to load L"C:\\windows\\system32\\win32k.sys"
9758.556:0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
9758.563:0024:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0021F2EC 1 C) semi-stub
9758.563:0024:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0021F25C 1 C) semi-stub
9758.575:0024:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0021EA3C 1 C) semi-stub
And, as it happened previously, the .exe didn't run.

Post Reply