Error installing mfc42.dll - strange directory in message

Questions about Wine on Linux
Post Reply
Posts: 2
Joined: Mon Mar 09, 2020 4:43 pm

Error installing mfc42.dll - strange directory in message

Post by Pudding4brains » Sun Apr 11, 2021 3:44 am


I´ve been using IrfanView through Wine on Manjaro Linux for some time on various new installs now and usually all works just fine "out of the box". I can usually just download the newest installers and run them with Wine to get everything installed and running dandy (even being able to open a file from say Gwenview by selecting "open with IrfanView"). Very impressed with how that works and integrates these days, so thanks to all for that!!

Now I´m sitting behind a machine (Lenovo T400) that ran thus fine before, but I did a new install of Manjaro due to other issues.

Trying to install IrfanView again, as usual, without result (wine hourglass mouse cursor comes alive and first time round the "configuration being updated" pop-up appears but then it dies quietly.

Next I tried installing through winetricks and now, eventually, I get an error message:

Code: Select all

Note: command wine /home/myname/.cache/winetricks/vcrun6/vc6redistsetup.exe /T:C:windowsTemp /c returned status 53. Aborting
In Windows the error status 53 seems to concern a network path not found or some such, but not at all sure if that applies here.

Nevertheless note the strange temp directory: C:windowsTemp (as opposed to C:windows/temp or C:windows\temp or whatever.

So I tried manually creating that directory but to no avail.

Is there something amiss in the current scripts that prevents the various processes from creating/using a proper temp directory and hence failing?

Thanks in advance for any pointers as to solving this!
Cheers, Pudsy

User avatar
Bob Wya
Level 12
Level 12
Posts: 3019
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland

Re: Error installing mfc42.dll - strange directory in message

Post by Bob Wya » Sun Apr 11, 2021 3:39 pm


What version of Wine are you testing with? If it's version 6.5 - then this is very buggy...
I'd recommending re-testing with (the newly released) Wine version 6.6


Post Reply