Error: "Unhandled page fault on write access" on all games

Questions about Wine on Linux
Post Reply
Posts: 1
Joined: Tue Apr 06, 2021 2:06 pm

Error: "Unhandled page fault on write access" on all games

Post by EpicNoob » Tue Apr 06, 2021 2:29 pm

Hi i am kind new to wine, but i used it with few of my old PCs, but they had amd/ati or intel igpu on their motherboards. The error is on the PC have GT 8500 with nvidia driver 340 installed from ubuntu repo. I've tried to install xwing alliance and heroes 3, they've installed corectly and i can launch xwing launcher or heroes 3 updater, but when i trying to launch proper game i get this error.
I've found heroes 3 source port so i don't neet wine for that game, but i want to play xwing. This game worked on my mentioned above PC's so i am thinking it's problem on nvidia driver side. I am not sure, but i think i've played on this PC CoD 2, but on Linux Mint

What i've tried:
Installing and running from both my owned CD's and GOG installers: same error.
Replacing gamemode from ubuntu repo to debian .deb: removed gamemode errors about not including 32bit libs from log
Reinstalling nvidia driver: same error.
Installing from lutris script instead of my PnP (run wine without variables): same error
Changing wine versions (tested winehq staging, stable, devel, lutris wine 5.0 and lutris wine 6.4): same error

System info:
CPU: Core 2 Duo E7200 2,6 GHz (slight OC from default 2,53 GHz)
GPU: GT 8500 512 MB with nvidia 340.108 driver from ubuntu repo
Disks: 2 SATA 2 HDD on gigabyte software RAID
OS: Ubuntu 20.04 LTS

What works:
Wine preinstalled programs (winecfg, wine uninstaller, wine notepad)
Games launchers/updaters (heroes 3 updater, Xwing launcher (create profile, check hardware etc.) )

What doesn't works:
Launching proper game (heroes3.exe, Alliance.exe)

How to reproduce:
install wine from winehq guide, install and launch game without winetricks, but with installed wine-mono when wine asks.

Error log from Lutris:

Code: Select all

Running gamemoderun /opt/wine-staging/bin/wine /home/intelpc/Gry/star-wars-x-wing-alliance/drive_c/GOG Games/Star Wars - X-Wing Alliance/XWINGALLIANCE.EXE
Initial process has started with pid 2706
Start monitoring process.
wine: Unhandled page fault on write access to 7D003F9C at address 7D1862EA (thread 0024), starting debugger...
Process of pid=0020 has terminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process  tid      prio (all id:s are in hex)
00000038 services.exe
	0000003c    0
	00000040    0
	00000054    0
	00000058    0
	00000064    0
	00000074    0
	0000008c    0
	000000b0    0
	000000d8    0
	000000dc    0
00000044 winedevice.exe
	00000048    0
	0000005c    0
	00000060    0
	00000068    0
0000004c explorer.exe
	[C:\windows\system32\explorer.exe /desktop]
	00000050    0
	000000c4    0
	000000c8    0
0000006c plugplay.exe
	00000070    0
	00000078    0
	0000007c    0
	00000080    0
	0000009c    0
00000084 winedevice.exe
	00000088    0
	00000090    0
	00000094    0
	00000098    0
	000000a4    0
000000a8 svchost.exe
	[C:\windows\system32\svchost.exe -k LocalServiceNetworkRestricted]
	000000ac    0
	000000b4    0
	000000b8    0
000000d0 rpcss.exe
	000000d4    0
	000000e0    0
	000000e4    0
	000000e8    0
	000000ec    0
	000000f0    0
	000000f4    0
winedbg: Internal crash at 0x7ed6a732
Monitored process exited.
Initial process has exited (return code: 133)
All monitored processes have exited.
Exit with returncode 133

Post Reply