Can't launch my Wine games because of driver loading issue

Questions about Wine on Linux
Post Reply
byjove01
Level 2
Level 2
Posts: 14
Joined: Tue Jan 12, 2021 10:00 am

Can't launch my Wine games because of driver loading issue

Post by byjove01 » Mon Feb 15, 2021 3:57 pm

Heya. Everything is in the title.

Since I updated my computer and my graphical drivers by the way, I realzed I couldn't longer launch my Wine games with Lutris because it doesn't longer detect my drivers. I think this bit of a report will be more helpful than a long message:

Code: Select all

lutris-wrapper: Star Wars Battlefront II
Running /home/byjove/.local/share/lutris/runners/wine/wine-5.15-staging-tkg-amd64/bin/wine /media/gaming_ssd/LucasArts/Star Wars Battlefront 2/GameData/BattlefrontII.exe
Initial process has started with pid 65172
Start monitoring process.
002c:fixme:winediag:__wine_start_process Wine TkG 5.15 is a testing version containing experimental patches.
002c:fixme:winediag:__wine_start_process Please don't report bugs about it on winehq.org and use https://github.com/Frogging-Family/wine-tkg-git/issues instead.
0060:fixme:heap:RtlSetHeapInformation 0xc60000 0 0x21f960 4 stub
006c:fixme:service:I_ScRegisterDeviceNotification Notification filters are not yet implemented.
0070:err:service:device_notify_proc failed to open RPC handle, error 1722
00ec:fixme:ntoskrnl:IoAllocateErrorLogEntry stub: 00000000006F5560, 48
0100:fixme:ntoskrnl:ExCreateCallback (0000000000A9F8F8, 0000000000A9F920, 0, 1): stub
0114:fixme:ntdll:NtQuerySystemInformation returning fake driver list
0114:fixme:ntoskrnl:IoAllocateErrorLogEntry stub: 00000000006F5550, 48
0114:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\sfsync04": c0000135
003c:fixme:service:scmdatabase_autostart_services Auto-start service L"sfsync04" failed to start: 126
0130:fixme:ntoskrnl:MmQuerySystemSize stub
libGL error: MESA-LOADER: failed to open radeonsi: libLLVM-11.so: mauvaise classe ELF : ELFCLASS64 (search paths /usr/lib32/dri)
libGL error: failed to load driver: radeonsi
libGL error: MESA-LOADER: failed to open radeonsi: libLLVM-11.so: mauvaise classe ELF : ELFCLASS64 (search paths /usr/lib32/dri)
libGL error: failed to load driver: radeonsi
libGL error: MESA-LOADER: failed to open swrast: libLLVM-11.so: mauvaise classe ELF : ELFCLASS64 (search paths /usr/lib32/dri)
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  268
  Current serial number in output stream:  267
Initial process has exited (return code: 256)
Monitored process exited.
All monitored processes have exited.
Exit with returncode 256
I'm on AMD (Radeon RX 5700 XT) and my Arch is still evidenty up-to-date, including my graphic drivers.
What am I supposed to do ? Please help, thanks in advance.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2987
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Can't launch my Wine games because of driver loading issue

Post by Bob Wya » Wed Feb 17, 2021 4:32 pm

@byjove01

You would probably be better off building the wine-tkg package manually.
See: Tk-Glitch / wine-tkg or Tk-Glitch / wine-proton-tkg ...
This ensures the correct dependencies are installed and that the resulting package will be built against your system packages.

Probably the Lutris wine-tkg build doesn't match the current Mesa LLVM version (perhaps 11.0.0 vs 11.0.1) or you don't have the necessary dependencies installed.

Bob

byjove01
Level 2
Level 2
Posts: 14
Joined: Tue Jan 12, 2021 10:00 am

Re: Can't launch my Wine games because of driver loading issue

Post by byjove01 » Thu Feb 18, 2021 2:11 pm

Bob Wya wrote:
Wed Feb 17, 2021 4:32 pm
@byjove01

You would probably be better off building the wine-tkg package manually.
See: Tk-Glitch / wine-tkg or Tk-Glitch / wine-proton-tkg ...
This ensures the correct dependencies are installed and that the resulting package will be built against your system packages.

Probably the Lutris wine-tkg build doesn't match the current Mesa LLVM version (perhaps 11.0.0 vs 11.0.1) or you don't have the necessary dependencies installed.

Bob
Well, even when I use my own build (I installed it both times from Lutris and AUR) it doesn't work for the same reasons, and even Lutris' Wine standard build doesn't work.

SetantaLP
Level 2
Level 2
Posts: 48
Joined: Mon Jul 31, 2017 3:55 am

Re: Can't launch my Wine games because of driver loading issue

Post by SetantaLP » Thu Feb 18, 2021 6:31 pm

Do you have 32bit and 64bit drivers installed? Because if I understand the log correctly, the Mesa-Loader is complaining that it cannot load the driver binary because libLLVM-11.so (to which the driver links) is 64bit instead of (probably) 32bit as the loader expects it. If you have, it might help to reinstall the drivers because maybe the update broke them.

adupuis
Newbie
Newbie
Posts: 4
Joined: Fri Jan 29, 2021 7:44 pm

Re: Can't launch my Wine games because of driver loading issue

Post by adupuis » Thu Feb 18, 2021 8:54 pm

Yes you are right it's complaining about the wrong ELF class.
@byjove01, as SetantaLP said: it looks like you are missing the 32 bits version of the libraries.

byjove01
Level 2
Level 2
Posts: 14
Joined: Tue Jan 12, 2021 10:00 am

Re: Can't launch my Wine games because of driver loading issue

Post by byjove01 » Fri Feb 19, 2021 8:53 am

I installed correctly my drivers yet, so normally 32bit and 64bit versions should be installed.
But well maybe there's something missing do you guys have something that could help me to locate it ? I'll see on the Arch wiki but a shortcut wouldn't be too much. :)

EDIT: Well, nope, nothing. I even installed some drivers I was lacking for video acceleration, but nothing of what I found on the wiki solved the problem.
EDIT2: FOUND IT! I just forgot to install the

Code: Select all

lib32-llvm-libs
package, because I didn't know it does exist haha. Thanks for your help people.

SetantaLP
Level 2
Level 2
Posts: 48
Joined: Mon Jul 31, 2017 3:55 am

Re: Can't launch my Wine games because of driver loading issue

Post by SetantaLP » Fri Feb 19, 2021 9:58 am

No problem.
But usually the lib32-llvm-libs package should be installed automatically since the driver seems to depend on it, but maybe that broke during the update or it was never listed as a dependency of the driver but has previously been installed as a dependency of a different package, that has been uninstalled or where it is no longer a dependency.

Post Reply