start ADE

Questions about Wine on Linux
Post Reply
danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

start ADE

Post by danidani » Tue Jan 12, 2021 1:46 am

Hello everybody!
I installed ADE (adobe Digital Editions) last version (4.5.1 or something like that) on my Ubuntu 20 and on my Linux Mint 19.3, then updated to Linux Mint 20. In any SO this does not work. I am not expert of Wine, so please tell me what could I do to make ADE start on my computer.
Thank everybody.

Dani

jkfloris
Level 9
Level 9
Posts: 1281
Joined: Thu Aug 14, 2014 10:10 am

Re: start ADE

Post by jkfloris » Tue Jan 12, 2021 11:06 am

Did you try the workarounds from the AppDB?

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Tue Jan 12, 2021 9:23 pm

Yes, I did, except Dot net 4.0 that cannot be installed (microsoft software installation do an error)...

jkfloris
Level 9
Level 9
Posts: 1281
Joined: Thu Aug 14, 2014 10:10 am

Re: start ADE

Post by jkfloris » Wed Jan 13, 2021 3:45 pm

Did you use (an up to date version of) winetricks?

Code: Select all

winetricks -q dotnet40

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Wed Jan 13, 2021 7:35 pm

I tried your command, but it does not work. It gave me an error.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2926
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: start ADE

Post by Bob Wya » Thu Jan 14, 2021 7:27 am

danidani wrote:
Wed Jan 13, 2021 7:35 pm
I tried your command, but it does not work. It gave me an error.
@danidani

What's the output from:

Code: Select all

wine --version
winetricks --version
- to check that both Wine and Winetricks are up-to-date.

Bob

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Thu Jan 14, 2021 9:12 pm

wine version: 4.0
winetricks version:
20201206-next - sha256sum: df61d998a52758d6070e1a32030901d2308f642d5edbbb3558c717bc3b1e2e7c

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Fri Jan 15, 2021 7:58 am

I managed to do it on Ubuntu!
But I want it on Mint, I don't know what I did wrong.
The command I wrote was Mint.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2926
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: start ADE

Post by Bob Wya » Fri Jan 15, 2021 3:27 pm

danidani wrote:
Thu Jan 14, 2021 9:12 pm
wine version: 4.0
winetricks version:
20201206-next - sha256sum: df61d998a52758d6070e1a32030901d2308f642d5edbbb3558c717bc3b1e2e7c
We can't really support Wine version: 4.0, as the current Wine stable release version is: 6.0 ...
See: WineHQ Wiki: Ubuntu.

Bob

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Sat Jan 16, 2021 5:25 am

"Error: there are some damaged package"
I always have this message, also when I update Mint from 19 to 20 and from 20 to 20.1
do you know what is?
In another forum a guy talked about pulseaudio
now I'm searching the answer...

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Sun Jan 17, 2021 5:47 am

I resolve it, I installed Wine 6.0 on my Linux Mint.
But ADE still doesn't work...

jkfloris
Level 9
Level 9
Posts: 1281
Joined: Thu Aug 14, 2014 10:10 am

Re: start ADE

Post by jkfloris » Sun Jan 17, 2021 7:15 am

You can try to use winetricks to install Adobe Digital Editions

Code: Select all

# Make sure winetricks is up to date
sudo winetricks --self-update

# Install ADE 4.5
winetricks -q adobe_diged4

danidani
Level 1
Level 1
Posts: 8
Joined: Tue Jan 12, 2021 1:30 am

Re: start ADE

Post by danidani » Sun Jan 17, 2021 8:43 am

How could you do that?!
It give on my terminal an infinite processing, but now it works!!!
Evviva!!
Thank you!!! :D :D :D

Post Reply