Latest dotnet(Net Framework) installation via x64 winetrick

Questions about Wine on Linux
Post Reply
maxemilian
Level 1
Level 1
Posts: 5
Joined: Wed Dec 23, 2020 3:48 am

Latest dotnet(Net Framework) installation via x64 winetrick

Post by maxemilian » Fri Jan 01, 2021 3:28 am

I need to install latest Dot Net because of this error occurs a program running.

Code: Select all

To run this application, you first must install one of thefollowing versions of the .NET Framework: v4.0.30319
Contact your application publisher for instructions about obtaining the appropriate version of the .Net Framework.
So I need at least this version but I can't install it in the wine 64 version.
If I select (via winetrick)
Install a Windows DLL or component
then
selecting
dotnet48 MS .NET 4.8
winetrick gives an notification

Code: Select all

You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
That good because this is right, I must install x86 things but Dot NET 2.0 already installed under
Install a Windows DLL or component


I can't install v4.8 but the default installation came with 2.0 how this happens.

How can I install latest Dot NET in X64-wine without x86-wine?
Can I use x86 component in x64-wine for this job?

User avatar
Bob Wya
Level 12
Level 12
Posts: 2926
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Latest dotnet(Net Framework) installation via x64 winetrick

Post by Bob Wya » Fri Jan 01, 2021 3:21 pm

@maxemilian

You can install the required dotnet40 verb to a 32-bit WINEPREFIX (equivalent of a 32-bit MS Windows installation) with:

Code: Select all

export WINEPREFIX=~/.wine32
WINEARCH=win32 wineboot -u
winetricks dotnet40
winetricks dotnet40_kb2468871
Which will create a 32-bit WINEPREFIX, with it's root directory at "${HOME}/.wine32" ...

See: WineHQ FAQ: 6.5.3 How do I create a 32 bit wineprefix on a 64 bit system?

Hope that helps! 8)

Bob

Post Reply