How to install python 3.6/3.7?

Questions about Wine on Linux
Post Reply
fancyerii
Newbie
Newbie
Posts: 3
Joined: Fri Nov 20, 2020 11:10 pm

How to install python 3.6/3.7?

Post by fancyerii » Fri Nov 20, 2020 11:59 pm

I want to install python 3.6/3.7, and I run with "WINEARCH=win32 WINEPREFIX=/home/lili19/wine/wechat wine python-3.7.4.exe".
But the python installer says "Windows Server 2008 SP2 or later is required".

Here is important information of my setup.
OS: Ubuntu 18.04
wine: wine-5.0.3 stable
winetricks with win10

SetantaLP
Level 2
Level 2
Posts: 41
Joined: Mon Jul 31, 2017 3:55 am

Re: How to install python 3.6/3.7?

Post by SetantaLP » Sat Nov 21, 2020 9:33 am

That means that the installer thinks that your prefix is on windows XP or earlier, which python doesn't support. And that happens either because there is a bug in wine or because the windows version is not set correctly. To rule out the latter you should run winecfg and see if shows a version above Windows XP.
By the way, is there a reason why you are using a 32bit instead of a 64bit prefix?

fancyerii
Newbie
Newbie
Posts: 3
Joined: Fri Nov 20, 2020 11:10 pm

Re: How to install python 3.6/3.7?

Post by fancyerii » Sun Nov 22, 2020 10:56 pm

I chose the wrong windows version. After I use winecfg to modify from windows xp to win10, it works. Thank you.

SetantaLP
Level 2
Level 2
Posts: 41
Joined: Mon Jul 31, 2017 3:55 am

Re: How to install python 3.6/3.7?

Post by SetantaLP » Mon Nov 23, 2020 8:38 am

No problem. Sometimes problems are appear because of incorrect configurations, but sometimes they appear because of bugs.

Post Reply