Sketchup2020 black window when launching

Questions about Wine on Linux
Post Reply
trondert
Newbie
Newbie
Posts: 2
Joined: Tue Nov 17, 2020 8:34 am

Sketchup2020 black window when launching

Post by trondert » Tue Nov 17, 2020 8:55 am

Installed using /silent and a .msi version of the download, with corefonts and vcrun2019.
First time i launched, i got a window with EULA accepting, checked the box and clicked "next". New window is black, but my pointer changes when i hover certain areas(guessing its buttons after finding img of the process online).
Wine 5.21
Ubuntu 20.04
Tried launching with win8, win 8.1 and win10 with same black screen. The Eula screen only came on first launch.

Tried finding alternatives for Linux, but need this as a start. Simply for following a course i'm taking, and hopefully i cant find a native app in a few years :)

Been using only native apps for years now, so i'm really rusty in all things wine.....
Found several "black screen" problems online, but seems it was not relevant for my problem.

fargodwe
Level 5
Level 5
Posts: 272
Joined: Mon Oct 02, 2017 7:08 am

Re: Sketchup2020 black window when launching

Post by fargodwe » Wed Nov 18, 2020 3:37 am

I downloaded Sketchup2020 Pro (the free version wasn't titled Sketchup) to try. I used the default wine architecture, the default wine prefix, vcrun2019 and allfonts in case for some reason corefonts weren't enough. When I tried to run the installer (a .exe - didn't see a .msi) I got an error during the install fairly quickly with the following error:

Code: Select all

IDS_ERROR_NO_WIZARD_PAGES
corefonts, vcrun and .net 4,5 are shown as the requirements. did you also add .net 4.5 via winetricks?

Tried the 2021 version as well and it at least shows a Sketchup installation screen but it fails right at the end of the file copies with the same error.

If you can tell me where to download the msi version of this I can try it to see if i can duplicate the problem. I may not be of any help but i'd like to try at least.

fargodwe
Level 5
Level 5
Posts: 272
Joined: Mon Oct 02, 2017 7:08 am

Re: Sketchup2020 black window when launching

Post by fargodwe » Wed Nov 18, 2020 5:01 am

Wouldn't let me edit the above - apparently too many minutes went by.

I had to do some searching on the net to find a post that had a link to the 2020 msi file.

I used the default prefix (.wine) and the default architecture (win64). I then used winetricks to install corefonts, vcrun2019 and the latest .net that showed in winetricks.

I was able to install the msi after that. I started Sketchup2020. I got to a screen requesting I so I logged and when it said I was logged on I closed the browser windows as it said I could. Sketchup had a button for start trial. I clicked that and got to a screen with an open file button and some images across the top. I opened one of those and yes, as soon as I clicked in the picture and yes the screen goes black and only shows the image again when I release the mouse button. I am able to use the middle mouse button to zoom and rotate. When I tried to draw what seemed to me not to be right started. The screen was flash as I moved around, even after what i thought was finishing the draw. I had to press esc to get out of that.

So, if you are not getting that far try using winetricks to install the latest version of .net that shows. i don't have a clue if it matters or not, but since it said to restart windows I did wineboot in a terminal window.

So, this also sound vaguely familiar to something I posted prior, so I looked and found this:

Code: Select all

https://forum.winehq.org/viewtopic.php?f=8&t=34449&p=129943&hilit=sketchup#p129943
This was in regards to Sketchup 2017.

I don't know if any of this helps or not - perhaps it's .net if you hadn't installed it yet.

trondert
Newbie
Newbie
Posts: 2
Joined: Tue Nov 17, 2020 8:34 am

Re: Sketchup2020 black window when launching

Post by trondert » Sun Nov 22, 2020 8:08 am

Thank you for your reply.
Made new prefix, and started fresh install of .net vcrun2019 and corefonts.
No luck yet, but ill keep trying :)

Post Reply