ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Questions about Wine on Linux
Post Reply
goober99
Newbie
Newbie
Posts: 4
Joined: Fri Sep 11, 2020 3:34 pm

ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by goober99 » Fri Sep 11, 2020 4:20 pm

I'm trying to install ProPresenter 7.2. The installer fails with the message: "ProPresenter is not compatible with the installed version of Windows. Windows 10 Version 1809 or later is required."

Image

I selected Windows 10 in winecfg and still get the above message. Is there some way to specify Windows 10 1809 as the version in Wine?

I'm using Wine 5.16 from the winehq.org repos on Debian Sid. I've also tried Wine Stable (5.0) and Wine Development (5.5) from the Debian Sid repos. The same result with all three. ProPresenter can be downloaded from here.

Gcenx
Level 6
Level 6
Posts: 564
Joined: Mon Dec 25, 2017 12:11 pm

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by Gcenx » Sat Sep 12, 2020 5:17 pm

Valves Proton-5.0-next has a patch for this https://github.com/ValveSoftware/wine/c ... 94a7.patch

The following patch is also useful for updating an already created wineprefix https://github.com/ValveSoftware/wine/c ... 290ad43615

jkfloris
Level 9
Level 9
Posts: 1427
Joined: Thu Aug 14, 2014 10:10 am

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by jkfloris » Mon Sep 14, 2020 10:40 am

The patch only change some numbers in the registry. You can also change these numbers with wine regedit
Search for "17134" and replace this with "17763"
You can probably find this numbers in:
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

goober99
Newbie
Newbie
Posts: 4
Joined: Fri Sep 11, 2020 3:34 pm

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by goober99 » Mon Sep 14, 2020 11:18 am

Thanks. Changing the values with regedit got the installer to launch.

devind
Newbie
Newbie
Posts: 2
Joined: Thu Apr 01, 2021 8:23 am

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by devind » Thu Apr 01, 2021 11:29 am

How does ProPresenter 7 run in WINE?

goober99
Newbie
Newbie
Posts: 4
Joined: Fri Sep 11, 2020 3:34 pm

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by goober99 » Thu Apr 01, 2021 12:17 pm

It doesn't. I finally got the installer to launch, but then ran into additional errors. I even bought a license to CodeWeavers CrossOver and opened a support ticket with them. They weren't able to get it working either.

My church finally went with Big Screen (https://bigscreen.show/). It did what we wanted that I initially thought only ProPresenter supported (different templates to different outputs, e.g. we want the lyrics in the center on a motion background for the main projector but on the bottom with a green background that can be keyed out to the video switcher for the livestream). It's cloud-based and runs in a browser, so it works on Linux without the need for Wine. We haven't run into any performance issues with it being cloud-based yet, and we're able to continue using Linux.

devind
Newbie
Newbie
Posts: 2
Joined: Thu Apr 01, 2021 8:23 am

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by devind » Thu Apr 01, 2021 4:06 pm

That's a bummer. My church's iMac is too old to update in order to use ProPresenter 7, so I was hoping to just go with Linux to eliminate the cost of buying a new machine.

We'll likely go with a Windows desktop with the next one so we have more control. I wish RenewedVision made a Linux version. :(

Thanks for the update! :)

fargodwe
Level 5
Level 5
Posts: 433
Joined: Mon Oct 02, 2017 7:08 am

Re: ProPresenter 7.2 installation fails with message that Windows 10 Version 1809 or later is required

Post by fargodwe » Sat Apr 03, 2021 5:46 am

You may want to check out openlp - it's a linux counterpart to propresenter. Depending on what version of linux you can install on the iMac it might be worth checking out. It's free.
https://openlp.org/

it's cross-platform so there are versions for multiple platforms (Windows, Mac, linux, etc).

It looks like it supports imports from propresenter 4.

Post Reply