libncurses:i386 vs. libncurses6:i386 vs. libncurses5:i386

Questions about Wine on Linux
Post Reply
Opako
Level 2
Level 2
Posts: 42
Joined: Mon Jun 08, 2020 9:23 am

libncurses:i386 vs. libncurses6:i386 vs. libncurses5:i386

Post by Opako » Thu Sep 10, 2020 3:46 pm

I stumbled upon the following packages:
libncurses:i386, libncurses6:i386, libncurses5:i386

Which of the following statements are true, which are wrong:

A) All these packages are the same package, but in different versions. You only need one. That means, if you have installed libncurses6:i386, you don't need libncurses:i386 and libncurses5:i386.

B) The names of the packages only look similar, but they are totally different, so you might need all 3.

C) Only one of these packages should be installed, if all 3 are installed, they will interfere with each other and Wine will not run properly.

D) You can have all 3 packages installed. This is of no use, but it does not hurt.

Thank you.

jkfloris
Level 8
Level 8
Posts: 1132
Joined: Thu Aug 14, 2014 10:10 am

Re: libncurses:i386 vs. libncurses6:i386 vs. libncurses5:i386

Post by jkfloris » Thu Sep 10, 2020 5:30 pm

libncurses is a virtual package. Currently no package with this name exists.
libncurses5 is the legacy version, some packages/ programs still depends on this version.
libncurses6 is the default version

You can have libncurses5 and libncurses6 installed on your system together.

Wine-stable/devel/staging-i386 depends on libncurses6:i386. If that package isn't available, libncurses5:i386 will be installed.
There is a third fall back on libncurses:i386, but as long as this package doesn't exist it can be ignored.
C) Only one of these packages should be installed, if all 3 are installed, they will interfere with each other and Wine will not run properly.
I assume that Wine uses libncurses6 if both are present

Opako
Level 2
Level 2
Posts: 42
Joined: Mon Jun 08, 2020 9:23 am

Re: libncurses:i386 vs. libncurses6:i386 vs. libncurses5:i386

Post by Opako » Fri Sep 11, 2020 6:42 am

OK. No need to install libncurses:i386. Thank you @jkfloris.

Post Reply