xiloader.exe on devuan ascii

Questions about Wine on Linux
Post Reply
sleepingkirby
Newbie
Newbie
Posts: 1
Joined: Wed Jul 29, 2020 10:23 pm

xiloader.exe on devuan ascii

Post by sleepingkirby » Thu Jul 30, 2020 3:20 am

Hi. Normally, I've been able to solve most of my wine problems with grit, determination and a lot of searching. This one has me on the ropes and I would appreciate any help.

For context, xiloader.exe is the private server loader for Final Fantasy XI.

When I run it, I can log in, it starts the game, it loads the characters info (i.e. no models yet) and then it dies before the opening screen.

Console output:
[07/30/20 15:49:23] Sending account id..
[07/30/20 15:49:23] Receiving character list..
wine: Unhandled page fault on write access to 00000014 at address 7E2CAE6F (thread 003d), starting debugger...
0047:fixme:dbghelp:elf_search_auxv can't find symbol in module
<snip repeat messages>
0047:fixme:dbghelp:elf_search_auxv can't find symbol in module
0047:err:dbghelp_msc:pe_load_debug_directory Got a page fault while loading symbols


Backtracelog is here:
https://pastebin.com/D48VNhCu

For the life of me, I can't figure out why it would die on this function (from backtrace log) :
Backtrace:
=>0 0x7e2cae6f X11DRV_SetWindowText+0x9f() in winex11 (0x0334fdf8)


Things I've tried:
  • 32 bit and 64 bit wine installs. Both have the same result.
  • installed all the directx, VC, dotnet, etc for it to work.
  • Upgrade wine.
  • Blown away the prefix folder completely and starting over.
OS and hardware info:
Linux SpearKirby 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64 GNU/Linux
Devuan Ascii (equivalent to debian 9 stretch )
01:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 840M] [10de:1341] (rev a2)

ii bumblebee 3.2.1-14 amd64 NVIDIA Optimus support for Linux
ii bumblebee-nvidia 3.2.1-14 amd64 NVIDIA Optimus support using the proprietary NVIDIA driver
ii nvidia-driver 390.116-1 amd64 NVIDIA metapackage


Thank you in advance.

Post Reply