Unable to launch Blizzard Games w/ Specific Error

Questions about Wine on Linux
Post Reply
Seda
Level 2
Level 2
Posts: 16
Joined: Tue Jan 07, 2014 9:47 am

Unable to launch Blizzard Games w/ Specific Error

Post by Seda » Mon Jul 06, 2020 1:35 am

Greetings,

After updating my system (including Wine), I now encounter this;

StarCraft II;

Code: Select all

085c:err:seh:setup_exception stack overflow 2592 bytes in thread 085c eip 00007f438933948d esp 000000000a5f0c10 stack 0xa5f0000-0xa5f1000-0xadf0000
Diablo III:

Code: Select all

08ac:err:seh:setup_exception stack overflow 2432 bytes in thread 08ac eip 000000007bc5c7e2 esp 0000000000120cb0 stack 0x120000-0x121000-0x220000
The Battle.Net launcher itself works normally now (under 5.11 it wasn't able to update games). I have created a fresh prefix. I have tried this with and without dxvk (same result). I have tried this with and without ACO enabled (it was my first suspect).

For the record, I actually suspect this may be something else (I performed an apt upgrade of Debian Bullseye at the same time as Wine, so it wasn't the only thing updated). But, I've hit a brick wall. Before I file a bug, I'd like to know if it's potentially something else on my system.

Are there other Debian users here able to run SC2 or D3 on an up-to-date Debian testing (Bullseye) install w/ Wine 5.12 (staging or devel doesn't matter, I've tried both)?

Or does anyone have any suggestions as to what I might try next?

Thanks.

Seda
Level 2
Level 2
Posts: 16
Joined: Tue Jan 07, 2014 9:47 am

Re: Unable to launch Blizzard Games w/ Specific Error

Post by Seda » Mon Jul 06, 2020 2:28 am

For anyone else running into this, I'm pretty sure I've run into this;
https://bugs.winehq.org/show_bug.cgi?id=49436

garpu
Level 2
Level 2
Posts: 43
Joined: Fri Oct 08, 2010 12:05 pm

Re: Unable to launch Blizzard Games w/ Specific Error

Post by garpu » Thu Sep 03, 2020 10:30 am

I'm getting this one, too. (Wine-staging 5.15.) Regression?
c:err:virtual:virtual_setup_exception stack overflow 1840 bytes in thread 074c addr 0x7ffbbed17b5c stack 0x1208d0 (0x120000-0x121000-0x220000)

User avatar
Bob Wya
Level 12
Level 12
Posts: 2884
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Unable to launch Blizzard Games w/ Specific Error

Post by Bob Wya » Fri Sep 04, 2020 6:11 am

garpu wrote:
Thu Sep 03, 2020 10:30 am
I'm getting this one, too. (Wine-staging 5.15.) Regression?
c:err:virtual:virtual_setup_exception stack overflow 1840 bytes in thread 074c addr 0x7ffbbed17b5c stack 0x1208d0 (0x120000-0x121000-0x220000)
Wine Staging 5.15 was completely broken and shouldn't really have been packaged by your Linux Distribution.
You'd want to update to Wine Staging 5.15.2 or Wine Staging 5.16 ...

Bob

garpu
Level 2
Level 2
Posts: 43
Joined: Fri Oct 08, 2010 12:05 pm

Re: Unable to launch Blizzard Games w/ Specific Error

Post by garpu » Fri Sep 04, 2020 9:33 am

Sorry, I take that back. I am on wine-staging 5.16. Like the bug thread says, I can launch Diablo III without battle.net, and it's fine.

garpu
Level 2
Level 2
Posts: 43
Joined: Fri Oct 08, 2010 12:05 pm

Re: Unable to launch Blizzard Games w/ Specific Error

Post by garpu » Sat Sep 05, 2020 6:48 pm

And in more testing, this is with wine-staging 5.16, and only with the 64-bit client that crashes with the stack overflow. Different issue?

Post Reply