Cannot install Wine32 in Ubuntu 20.04

Questions about Wine on Linux
Post Reply
James Gryphon
Newbie
Newbie
Posts: 2
Joined: Tue May 19, 2020 2:06 am

Cannot install Wine32 in Ubuntu 20.04

Post by James Gryphon » Tue May 19, 2020 3:04 am

Apparently this sort of problem is common, but comes in as many flavors as there are users, as it keeps recurring and none of the answers anyone posts seem to work.

I've tried installing Wine, from both the Focal repository and WineHQ, and done every update, upgrade, add-architecture that anyone suggests, but Wine32 (wine32:i386) is always MIA and it never is able to resolve any of its dependencies.

Here's an example of a typical failed attempt to install, first trying Focal's repositories, then following the Wine install guide's recommendations (starting with 'print foreign architectures'). I'm afraid this log is very long, but hopefully this will help answer any questions anyone might have. Repeated descriptive text (Reading package lists..., Some packages could not be installed) and particularly lengthy package listings have been cropped.

Code: Select all

$ sudo nano /etc/apt/sources.list

  GNU nano 4.8                  /etc/apt/sources.list                             
deb [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal main restricted uni>
deb-src [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal main restricted>

deb [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal-updates main restri>
deb-src [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal-updates main re>

deb [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal-security main restr>
deb-src [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal-security main r>

deb [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal-backports main rest>
deb-src [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ focal-backports main >

deb http://archive.canonical.com/ubuntu focal partner
deb-src http://archive.canonical.com/ubuntu focal partner

$ sudo apt-get install wine32
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 5.0-3ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libwine:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 libwine:i386 : Depends: libfaudio0:i386 (>= 19.06.07) but it is not going to be installed
                Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                Recommends: libgnutls30:i386 (>= 3.6.5) but it is not going to be installed
                Recommends: libsane:i386 (>= 1.0.24) but it is not going to be installed
                Recommends: libasound2-plugins:i386 but it is not going to be installed
                Recommends: gstreamer1.0-plugins-good:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libfaudio0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 libfaudio0:i386 : Depends: libavcodec58:i386 (>= 7:4.2)
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libavcodec58:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 libavcodec58:i386 : Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                     Depends: librsvg2-2:i386 (>= 2.14.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libglib2.0.0:i386
Note, selecting 'libglib2.0-0:i386' for regex 'libglib2.0.0'

The following packages have unmet dependencies:
 libglib2.0-0:i386 : Depends: libmount1:i386 (>= 2.28) but it is not going to be installed
                     Depends: libpcre3:i386 but it is not going to be installed
                     Depends: libselinux1:i386 (>= 1.32) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libmount1:i386

The following packages have unmet dependencies:
 libmount1:i386 : Depends: libselinux1:i386 (>= 2.6-3~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libselinux1:i386

The following packages have unmet dependencies:
 libselinux1:i386 : Depends: libpcre2-8-0:i386 (>= 10.22) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libpcre2-8-0:i386

[i]... and then it wants to erase the entire system!!![/i]

The following packages were automatically installed and are no longer required:
  acl amb-plugins amd64-microcode apg apport-symptoms aptdaemon-data
  audacious-plugins-data audacity-data autopoint autotalent binfmt-support
  blepvco blop breeze-icon-theme busybox-initramfs calf-ladspa caps cdrdao cmt
  colord-data cracklib-runtime cups-common cups-server-common dc
  distro-info-data dns-root-data dotnet-host dotnet-hostfxr-3.1 dvd+rw-tools dwz
  efibootmgr  ... (and more)
The following packages will be REMOVED:
  accountsservice accountsservice-ubuntu-schemas acpi-support acpid
  activity-log-manager adduser adwaita-icon-theme alacarte alsa-base alsa-utils
  apache2-utils apparmor apport apport-gtk appstream apt apt-config-icons
 ... (and more)
The following NEW packages will be installed:
  libpcre2-8-0:i386
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt adduser (due to apt) coreutils libselinux1 (due to coreutils) dash
  dpkg (due to dash) debconf (due to dash) tar (due to dpkg) fdisk
  libmount1 (due to fdisk) findutils grep install-info (due to grep) gzip init
  systemd-sysv (due to init) init-system-helpers (due to init)
  perl-base (due to init-system-helpers) login libpam0g (due to login)
  libpam-runtime (due to login) libpam-modules (due to login) mount
  util-linux (due to mount) sed sysvinit-utils
0 upgraded, 1 newly installed, 1461 to remove and 0 not upgraded.
Need to get 197 kB of archives.
After this operation, 4,747 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] n
Abort.

$ sudo aptitude install wine32
Note: selecting "wine32:i386" instead of the virtual package "wine32"
The following NEW packages will be installed:
  glib-networking:i386{a} gstreamer1.0-plugins-base:i386{a} 
  gstreamer1.0-plugins-good:i386{a} gstreamer1.0-x:i386{a} 
  i965-va-driver:i386{a} intel-media-va-driver:i386{a} libaa1:i386{a} 
  libaom0:i386{a} libaribb24-0:i386{a} libasn1-8-heimdal:i386{a} 
  libasound2:i386{a} libasound2-plugins:i386{a} libasyncns0:i386{a} 
  libavahi-client3:i386{a} libavahi-common-data:i386{a} 
  libavahi-common3:i386{a} libavc1394-0:i386{a} libavcodec-extra58:i386{a} 
  libavutil56:i386{a} libblkid1:i386{a} libbrotli1:i386{a} libbz2-1.0:i386{a} 
  libcaca0:i386{a} libcairo-gobject2:i386{a} libcairo2:i386{a} 
  libcap2:i386{a} libcapi20-3:i386{a} libcdparanoia0:i386{a} 
  libcodec2-0.9:i386{a} libcom-err2:i386{a} libcups2:i386{a} 
  libcurl3-gnutls:i386{a} libdatrie1:i386{a} libdb5.3:i386{a} 
  libdbus-1-3:i386{a} libdrm-intel1:i386{a} libdv4:i386{a} libexif12:i386{a} 
  libfaudio0:i386{a} libflac8:i386{a} libfontconfig1:i386{a} 
  libfreetype6:i386{a} libfribidi0:i386{a} libgcrypt20:i386{a} 
  libgd3:i386{ab} libgdbm-compat4:i386{a} libgdbm6:i386{a} 
  libgdk-pixbuf2.0-0:i386{a} libgl1:i386{a} libgl1-mesa-dri:i386{a} 
  libglapi-mesa:i386{a} libglib2.0-0:i386{a} libglu1-mesa:i386{a} 
  libglvnd0:i386{a} libglx-mesa0:i386{a} libglx0:i386{a} libgmp10:i386{a} 
  libgnutls30:i386{a} libgomp1:i386{a} libgpg-error0:i386{a} 
  libgphoto2-6:i386{a} libgphoto2-port12:i386{a} libgpm2:i386{a} 
  libgraphite2-3:i386{a} libgsm1:i386{a} libgssapi-krb5-2:i386{a} 
  libgssapi3-heimdal:i386{a} libgstreamer-plugins-base1.0-0:i386{a} 
  libgstreamer-plugins-good1.0-0:i386{a} libgstreamer1.0-0:i386{a} 
  libgudev-1.0-0:i386{a} libharfbuzz0b:i386{a} libhcrypto4-heimdal:i386{a} 
  libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} 
  libhogweed5:i386{a} libhx509-5-heimdal:i386{a} libicu66:i386{a} 
  libidn2-0:i386{ab} libiec61883-0:i386{a} libieee1284-3:i386{a} 
  libigdgmm11:i386{a} libjack-jackd2-0:i386{ab} libjbig0:i386{a} 
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a} 
  libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a} 
  libkrb5support0:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a} 
  libltdl7:i386{a} liblz4-1:i386{a} liblzma5:i386{a} libmount1:i386{a} 
  libmp3lame0:i386{a} libmpg123-0:i386{a} libmysqlclient21:i386{a} 
  libncurses6:i386{a} libncursesw6:i386{a} libnettle7:i386{a} 
  libnghttp2-14:i386{a} libnuma1:i386{a} libodbc1:i386{a} libogg0:i386{a} 
  libopenal1:i386{a} libopencore-amrnb0:i386{a} libopencore-amrwb0:i386{a} 
  libopenjp2-7:i386{a} libopus0:i386{a} liborc-0.4-0:i386{a} 
  libosmesa6:i386{a} libp11-kit0:i386{a} libpango-1.0-0:i386{a} 
  libpangocairo-1.0-0:i386{a} libpangoft2-1.0-0:i386{a} libpcap0.8:i386{a} 
  libpci3:i386{a} libpciaccess0:i386{a} libpcre2-8-0:i386{ab} 
  libpcre3:i386{ab} libperl5.30:i386{a} libpixman-1-0:i386{a} 
  libpng16-16:i386{a} libproxy1v5:i386{a} libpsl5:i386{a} libpulse0:i386{a} 
  libraw1394-11:i386{a} libroken18-heimdal:i386{a} librsvg2-2:i386{a} 
  librsvg2-common:i386{a} librtmp1:i386{a} libsamplerate0:i386{a} 
  libsane:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} 
  libsasl2-modules-db:i386{a} libsdl2-2.0-0:i386{a} libselinux1:i386{a} 
  libsensors5:i386{a} libshine3:i386{a} libshout3:i386{a} libslang2:i386{a} 
  libsnappy1v5:i386{a} libsndfile1:i386{a} libsndio7.0:i386{a} 
  libsnmp35:i386{a} libsoup2.4-1:i386{a} libsoxr0:i386{a} libspeex1:i386{a} 
  libsqlite3-0:i386{a} libssh-4:i386{a} libssl1.1:i386{a} libstb0:i386{a} 
  libswresample3:i386{a} libsystemd0:i386{a} libtag1v5:i386{a} 
  libtag1v5-vanilla:i386{a} libtasn1-6:i386{a} libthai0:i386{a} 
  libtheora0:i386{a} libtiff5:i386{a} libtwolame0:i386{a} libudev1:i386{a} 
  libunistring2:i386{a} libusb-1.0-0:i386{a} libuuid1:i386{a} 
  libv4l-0:i386{a} libv4lconvert0:i386{a} libva-drm2:i386{a} 
  libva-x11-2:i386{a} libva2:i386{a} libvisual-0.4-0:i386{a} 
  libvkd3d1:i386{a} libvo-amrwbenc0:i386{a} libvorbis0a:i386{a} 
  libvorbisenc2:i386{a} libvpx6:i386{a} libvulkan1:i386{a} 
  libwavpack1:i386{a} libwayland-client0:i386{a} libwayland-cursor0:i386{a} 
  libwayland-egl1:i386{a} libwebp6:i386{a} libwebpmux3:i386{a} 
  libwind0-heimdal:i386{a} libwine:i386{a} libwrap0:i386{a} 
  libx264-155:i386{a} libx265-179:i386{a} libxcb-glx0:i386{a} 
  libxcb-randr0:i386{a} libxcb-render0:i386{a} libxcb-shm0:i386{a} 
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a} 
  libxfixes3:i386{a} libxi6:i386{a} libxinerama1:i386{a} 
  libxkbcommon0:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a} 
  libxrender1:i386{a} libxslt1.1:i386{a} libxss1:i386{a} libxv1:i386{a} 
  libxvidcore4:i386{a} libxxf86vm1:i386{a} libzvbi0:i386{a} 
  mesa-va-drivers:i386{a} mesa-vulkan-drivers:i386{a} 
  ocl-icd-libopencl1:i386{a} va-driver-all:i386{a} wine{a} wine32:i386 
0 packages upgraded, 219 newly installed, 0 to remove and 0 not upgraded.
Need to get 111 MB of archives. After unpacking 830 MB will be used.
The following packages have unmet dependencies:
 libgd3 : Breaks: libgd3:i386 (!= 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1) but 2.2.5-5.2ubuntu2 is to be installed
 libgd3:i386 : Breaks: libgd3 (!= 2.2.5-5.2ubuntu2) but 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1 is installed
 libpcre3 : Breaks: libpcre3:i386 (!= 2:8.43-1+ubuntu18.04.1+deb.sury.org+1) but 2:8.39-12build1 is to be installed
 libpcre3:i386 : Breaks: libpcre3 (!= 2:8.39-12build1) but 2:8.43-1+ubuntu18.04.1+deb.sury.org+1 is installed
 libjack-jackd2-0:i386 : Conflicts: libjack-0.116 which is a virtual package, provided by:
                                    - libjack0 (1:0.125.0-3build2), but 1:0.125.0-3build2 is installed
                                    - libjack-jackd2-0 (1.9.12~dfsg-2ubuntu2), but it is not going to be installed

                         Conflicts: libjack-0.125 which is a virtual package, provided by:
                                    - libjack0 (1:0.125.0-3build2), but 1:0.125.0-3build2 is installed
                                    - libjack-jackd2-0 (1.9.12~dfsg-2ubuntu2), but it is not going to be installed

                         Conflicts: libjack0 but 1:0.125.0-3build2 is installed
 libpcre2-8-0 : Breaks: libpcre2-8-0:i386 (!= 10.34-7+ubuntu18.04.1+deb.sury.org+1) but 10.34-7 is to be installed
 libpcre2-8-0:i386 : Breaks: libpcre2-8-0 (!= 10.34-7) but 10.34-7+ubuntu18.04.1+deb.sury.org+1 is installed
 libjack0 : Conflicts: libjack-0.116:i386 which is a virtual package, provided by:
                       - libjack0:i386 (1:0.125.0-3build2), but it is not going to be installed
                       - libjack-jackd2-0:i386 (1.9.12~dfsg-2ubuntu2), but 1.9.12~dfsg-2ubuntu2 is to be installed

            Conflicts: libjack-0.125:i386 which is a virtual package, provided by:
                       - libjack0:i386 (1:0.125.0-3build2), but it is not going to be installed
                       - libjack-jackd2-0:i386 (1.9.12~dfsg-2ubuntu2), but 1.9.12~dfsg-2ubuntu2 is to be installed

 libidn2-0 : Breaks: libidn2-0:i386 (!= 2.2.0-2+ubuntu18.04.1+deb.sury.org+1) but 2.2.0-2 is to be installed
 libidn2-0:i386 : Breaks: libidn2-0 (!= 2.2.0-2) but 2.2.0-2+ubuntu18.04.1+deb.sury.org+1 is installed
open: 85; closed: 4236; defer: 14; conflict: 16                                  oThe following actions will resolve these dependencies:

      Keep the following packages at their current version:                       
1)      glib-networking:i386 [Not Installed]                                      
2)      gstreamer1.0-plugins-base:i386 [Not Installed]                            
3)      gstreamer1.0-plugins-good:i386 [Not Installed]                            
4)      gstreamer1.0-x:i386 [Not Installed]                                       
5)      libasound2-plugins:i386 [Not Installed]                                   
6)      libavcodec-extra58:i386 [Not Installed]                                   
7)      libcairo-gobject2:i386 [Not Installed]                                    
8)      libcups2:i386 [Not Installed]                                             
9)      libcurl3-gnutls:i386 [Not Installed]                                      
10)     libfaudio0:i386 [Not Installed]                                           
11)     libgd3:i386 [Not Installed]                                               
12)     libgdk-pixbuf2.0-0:i386 [Not Installed]                                   
13)     libglib2.0-0:i386 [Not Installed]                                         
14)     libgnutls30:i386 [Not Installed]                                          
15)     libgphoto2-6:i386 [Not Installed]                                         
16)     libgstreamer-plugins-base1.0-0:i386 [Not Installed]                       
17)     libgstreamer-plugins-good1.0-0:i386 [Not Installed]                       
18)     libgstreamer1.0-0:i386 [Not Installed]                                    
19)     libgudev-1.0-0:i386 [Not Installed]                                       
20)     libharfbuzz0b:i386 [Not Installed]                                        
21)     libidn2-0:i386 [Not Installed]                                            
22)     libjack-jackd2-0:i386 [Not Installed]                                     
23)     libldap-2.4-2:i386 [Not Installed]                                        
24)     libmount1:i386 [Not Installed]                                            
25)     libpango-1.0-0:i386 [Not Installed]                                       
26)     libpangocairo-1.0-0:i386 [Not Installed]                                  
27)     libpangoft2-1.0-0:i386 [Not Installed]                                    
28)     libpcre2-8-0:i386 [Not Installed]                                         
29)     libpcre3:i386 [Not Installed]                                             
30)     libpsl5:i386 [Not Installed]                                              
31)     librsvg2-2:i386 [Not Installed]                                           
32)     librsvg2-common:i386 [Not Installed]                                      
33)     librtmp1:i386 [Not Installed]                                             
34)     libsane:i386 [Not Installed]                                              
35)     libselinux1:i386 [Not Installed]                                          
36)     libsoup2.4-1:i386 [Not Installed]                                         
37)     libwine:i386 [Not Installed]                                              
38)     wine [Not Installed]                                                      
39)     wine32:i386 [Not Installed]                                               

      Leave the following dependencies unresolved:                                
40)     libgstreamer-plugins-base1.0-0:i386 recommends gstreamer1.0-plugins-base:i
41)     libwine:i386 recommends libsane:i386 (>= 1.0.24)                          
42)     libwine:i386 recommends libasound2-plugins:i386                           
43)     libwine:i386 recommends gstreamer1.0-plugins-good:i386                    

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

$ dpkg --print-foreign-architectures
i386

$ wget -O - https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add -
--2020-05-19 02:19:22--  https://dl.winehq.org/wine-builds/winehq.key
Resolving dl.winehq.org (dl.winehq.org)... 151.101.130.217, 151.101.2.217, 151.101.66.217, ...
Connecting to dl.winehq.org (dl.winehq.org)|151.101.130.217|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3220 (3.1K) [application/pgp-keys]
Saving to: ‘STDOUT’

-                    100%[====================>]   3.14K  --.-KB/s    in 0.006s  

2020-05-19 02:19:23 (484 KB/s) - written to stdout [3220/3220]

OK

$ sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main' 
Get:1 https://dl.winehq.org/wine-builds/ubuntu focal InRelease [6,257 B]
Hit:2 http://archive.canonical.com/ubuntu focal InRelease                        
Hit:3 http://archive.ubuntu.com/ubuntu focal InRelease
Get:4 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages [33.2 kB]
Get:5 https://dl.winehq.org/wine-builds/ubuntu focal/main i386 Packages [34.5 kB]
Hit:6 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:7 http://archive.ubuntu.com/ubuntu focal-security InRelease
Get:8 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Fetched 172 kB in 1s (130 kB/s)     
Reading package lists... Done

$ sudo apt update
Hit:1 http://archive.canonical.com/ubuntu focal InRelease
Hit:2 https://dl.winehq.org/wine-builds/ubuntu focal InRelease
Hit:3 http://archive.ubuntu.com/ubuntu focal InRelease
Hit:4 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu focal-security InRelease
Get:6 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Fetched 98.3 kB in 1s (78.1 kB/s)   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

$ sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 4.0.4~focal)
E: Unable to correct problems, you have held broken packages.

$ sudo apt install --install-recommends wine-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-i386 (= 4.0.4~focal)
E: Unable to correct problems, you have held broken packages.

$ sudo apt install --install-recommends wine-stable-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                         Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                         Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                         Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                         Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                         Depends: libasound2-plugins:i386 but it is not going to be installed
                         Recommends: libcups2:i386 but it is not going to be installed
                         Recommends: libgnutls30:i386 but it is not going to be installed or
                                     libgnutls28:i386 but it is not installable or
                                     libgnutls26:i386 but it is not installable
                         Recommends: libsane:i386 but it is not going to be installed or
                                     libsane1:i386
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libsane:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 libsane:i386 : Depends: libcurl3-gnutls:i386 (>= 7.16.2) but it is not going to be installed
                Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo aptitude install libsane:i386
The following NEW packages will be installed:
  libasn1-8-heimdal:i386{a} libavahi-client3:i386{a} 
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libbrotli1:i386{a} 
  libbz2-1.0:i386{a} libcom-err2:i386{a} libcurl3-gnutls:i386{a} 
  libdb5.3:i386{a} libdbus-1-3:i386{a} libexif12:i386{a} 
  libfontconfig1:i386{a} libfreetype6:i386{a} libgcrypt20:i386{a} 
  libgd3:i386{ab} libgdbm-compat4:i386{a} libgdbm6:i386{a} libgmp10:i386{a} 
  libgnutls30:i386{a} libgpg-error0:i386{a} libgphoto2-6:i386{a} 
  libgphoto2-port12:i386{a} libgssapi-krb5-2:i386{a} 
  libgssapi3-heimdal:i386{a} libhcrypto4-heimdal:i386{a} 
  libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} 
  libhogweed5:i386{a} libhx509-5-heimdal:i386{a} libicu66:i386{a} 
  libidn2-0:i386{ab} libieee1284-3:i386{a} libjbig0:i386{a} 
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a} 
  libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a} 
  libkrb5support0:i386{a} libldap-2.4-2:i386{a} libltdl7:i386{a} 
  liblz4-1:i386{a} liblzma5:i386{a} libmysqlclient21:i386{a} 
  libnettle7:i386{a} libnghttp2-14:i386{a} libp11-kit0:i386{a} 
  libpci3:i386{a} libperl5.30:i386{a} libpng16-16:i386{a} libpsl5:i386{a} 
  libroken18-heimdal:i386{a} librtmp1:i386{a} libsane:i386 libsasl2-2:i386{a} 
  libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libsensors5:i386{a} 
  libsnmp35:i386{a} libsqlite3-0:i386{a} libssh-4:i386{a} libssl1.1:i386{a} 
  libsystemd0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a} libudev1:i386{a} 
  libunistring2:i386{a} libusb-1.0-0:i386{a} libuuid1:i386{a} 
  libwebp6:i386{a} libwind0-heimdal:i386{a} libwrap0:i386{a} libxml2:i386{a} 
  libxpm4:i386{a} 
0 packages upgraded, 75 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.7 MB of archives. After unpacking 119 MB will be used.
The following packages have unmet dependencies:
 libgd3 : Breaks: libgd3:i386 (!= 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1) but 2.2.5-5.2ubuntu2 is to be installed
 libgd3:i386 : Breaks: libgd3 (!= 2.2.5-5.2ubuntu2) but 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1 is installed
 libidn2-0 : Breaks: libidn2-0:i386 (!= 2.2.0-2+ubuntu18.04.1+deb.sury.org+1) but 2.2.0-2 is to be installed
 libidn2-0:i386 : Breaks: libidn2-0 (!= 2.2.0-2) but 2.2.0-2+ubuntu18.04.1+deb.sury.org+1 is installed
open: 36; closed: 1901; defer: 6; conflict: 6                                    .The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libcurl3-gnutls:i386 [Not Installed]               
2)     libgd3:i386 [Not Installed]                        
3)     libgnutls30:i386 [Not Installed]                   
4)     libgphoto2-6:i386 [Not Installed]                  
5)     libidn2-0:i386 [Not Installed]                     
6)     libldap-2.4-2:i386 [Not Installed]                 
7)     libpsl5:i386 [Not Installed]                       
8)     librtmp1:i386 [Not Installed]                      
9)     libsane:i386 [Not Installed]                       

Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
So, whatever I do Wine32 never installs. If it just did this for everyone and was a known defect, then I'd know to give up on Wine or Ubuntu (or both), but all of the people offering solutions and posting videos (where it works at a step it fails at here) suggests that it shouldn't be like this.

One point that might be of interest - I upgraded from an earlier version to 20.04 some time back. The upgrade process did not go smoothly and ultimately required manually updating, upgrading, etc. to get it to the place where it would say that everything was shipshape (and where things do indeed appear to be). It's not impossible this might have something to do with the Wine problem, so I thought I'd mention it just in case.

User avatar
dimesio
Moderator
Moderator
Posts: 12810
Joined: Tue Mar 25, 2008 10:30 pm

Re: Cannot install Wine32 in Ubuntu 20.04

Post by dimesio » Tue May 19, 2020 8:02 am

The WineHQ repository isn't in your /etc/apt/sources.list. Try following the instructions on https://wiki.winehq.org/Ubuntu.
One point that might be of interest - I upgraded from an earlier version to 20.04 some time back. The upgrade process did not go smoothly and ultimately required manually updating, upgrading, etc. to get it to the place where it would say that everything was shipshape (and where things do indeed appear to be). It's not impossible this might have something to do with the Wine problem, so I thought I'd mention it just in case.
That could well be the problem. Your console output suggests you are missing the 32 bit side of pretty much everything. Wine will not install without its 32 bit dependencies.

James Gryphon
Newbie
Newbie
Posts: 2
Joined: Tue May 19, 2020 2:06 am

Re: Cannot install Wine32 in Ubuntu 20.04

Post by James Gryphon » Wed May 20, 2020 10:39 pm

Well, a WineHQ install attempt is in the log. It's buried in there, though, so I'll put it here to make it more accessible. It's very similar to the main Ubuntu repository attempt.

Code: Select all

$ dpkg --print-foreign-architectures
i386

$ wget -O - https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add -
--2020-05-19 02:19:22--  https://dl.winehq.org/wine-builds/winehq.key
Resolving dl.winehq.org (dl.winehq.org)... 151.101.130.217, 151.101.2.217, 151.101.66.217, ...
Connecting to dl.winehq.org (dl.winehq.org)|151.101.130.217|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3220 (3.1K) [application/pgp-keys]
Saving to: ‘STDOUT’

-                    100%[====================>]   3.14K  --.-KB/s    in 0.006s  

2020-05-19 02:19:23 (484 KB/s) - written to stdout [3220/3220]

OK

$ sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main' 
Get:1 https://dl.winehq.org/wine-builds/ubuntu focal InRelease [6,257 B]
Hit:2 http://archive.canonical.com/ubuntu focal InRelease                        
Hit:3 http://archive.ubuntu.com/ubuntu focal InRelease
Get:4 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages [33.2 kB]
Get:5 https://dl.winehq.org/wine-builds/ubuntu focal/main i386 Packages [34.5 kB]
Hit:6 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:7 http://archive.ubuntu.com/ubuntu focal-security InRelease
Get:8 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Fetched 172 kB in 1s (130 kB/s)     
Reading package lists... Done

$ sudo apt update
Hit:1 http://archive.canonical.com/ubuntu focal InRelease
Hit:2 https://dl.winehq.org/wine-builds/ubuntu focal InRelease
Hit:3 http://archive.ubuntu.com/ubuntu focal InRelease
Hit:4 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu focal-security InRelease
Get:6 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Fetched 98.3 kB in 1s (78.1 kB/s)   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

$ sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 4.0.4~focal)
E: Unable to correct problems, you have held broken packages.

$ sudo apt install --install-recommends wine-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-i386 (= 4.0.4~focal)
E: Unable to correct problems, you have held broken packages.

$ sudo apt install --install-recommends wine-stable-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                         Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                         Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                         Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                         Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                         Depends: libasound2-plugins:i386 but it is not going to be installed
                         Recommends: libcups2:i386 but it is not going to be installed
                         Recommends: libgnutls30:i386 but it is not going to be installed or
                                     libgnutls28:i386 but it is not installable or
                                     libgnutls26:i386 but it is not installable
                         Recommends: libsane:i386 but it is not going to be installed or
                                     libsane1:i386
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libsane:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following packages have unmet dependencies:
 libsane:i386 : Depends: libcurl3-gnutls:i386 (>= 7.16.2) but it is not going to be installed
                Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo aptitude install libsane:i386
The following NEW packages will be installed:
  libasn1-8-heimdal:i386{a} libavahi-client3:i386{a} 
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libbrotli1:i386{a} 
  libbz2-1.0:i386{a} libcom-err2:i386{a} libcurl3-gnutls:i386{a} 
  libdb5.3:i386{a} libdbus-1-3:i386{a} libexif12:i386{a} 
  libfontconfig1:i386{a} libfreetype6:i386{a} libgcrypt20:i386{a} 
  libgd3:i386{ab} libgdbm-compat4:i386{a} libgdbm6:i386{a} libgmp10:i386{a} 
  libgnutls30:i386{a} libgpg-error0:i386{a} libgphoto2-6:i386{a} 
  libgphoto2-port12:i386{a} libgssapi-krb5-2:i386{a} 
  libgssapi3-heimdal:i386{a} libhcrypto4-heimdal:i386{a} 
  libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} 
  libhogweed5:i386{a} libhx509-5-heimdal:i386{a} libicu66:i386{a} 
  libidn2-0:i386{ab} libieee1284-3:i386{a} libjbig0:i386{a} 
  libjpeg-turbo8:i386{a} libjpeg8:i386{a} libk5crypto3:i386{a} 
  libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} libkrb5-3:i386{a} 
  libkrb5support0:i386{a} libldap-2.4-2:i386{a} libltdl7:i386{a} 
  liblz4-1:i386{a} liblzma5:i386{a} libmysqlclient21:i386{a} 
  libnettle7:i386{a} libnghttp2-14:i386{a} libp11-kit0:i386{a} 
  libpci3:i386{a} libperl5.30:i386{a} libpng16-16:i386{a} libpsl5:i386{a} 
  libroken18-heimdal:i386{a} librtmp1:i386{a} libsane:i386 libsasl2-2:i386{a} 
  libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libsensors5:i386{a} 
  libsnmp35:i386{a} libsqlite3-0:i386{a} libssh-4:i386{a} libssl1.1:i386{a} 
  libsystemd0:i386{a} libtasn1-6:i386{a} libtiff5:i386{a} libudev1:i386{a} 
  libunistring2:i386{a} libusb-1.0-0:i386{a} libuuid1:i386{a} 
  libwebp6:i386{a} libwind0-heimdal:i386{a} libwrap0:i386{a} libxml2:i386{a} 
  libxpm4:i386{a} 
0 packages upgraded, 75 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.7 MB of archives. After unpacking 119 MB will be used.
The following packages have unmet dependencies:
 libgd3 : Breaks: libgd3:i386 (!= 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1) but 2.2.5-5.2ubuntu2 is to be installed
 libgd3:i386 : Breaks: libgd3 (!= 2.2.5-5.2ubuntu2) but 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1 is installed
 libidn2-0 : Breaks: libidn2-0:i386 (!= 2.2.0-2+ubuntu18.04.1+deb.sury.org+1) but 2.2.0-2 is to be installed
 libidn2-0:i386 : Breaks: libidn2-0 (!= 2.2.0-2) but 2.2.0-2+ubuntu18.04.1+deb.sury.org+1 is installed
open: 36; closed: 1901; defer: 6; conflict: 6                                    .The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libcurl3-gnutls:i386 [Not Installed]               
2)     libgd3:i386 [Not Installed]                        
3)     libgnutls30:i386 [Not Installed]                   
4)     libgphoto2-6:i386 [Not Installed]                  
5)     libidn2-0:i386 [Not Installed]                     
6)     libldap-2.4-2:i386 [Not Installed]                 
7)     libpsl5:i386 [Not Installed]                       
8)     librtmp1:i386 [Not Installed]                      
9)     libsane:i386 [Not Installed]                       

Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
The trouble is that attempting to install these dependencies, at least by the most direct route, is broken (incidentally, a problem other people had, at least in Ubuntu 19.10: 1 2).

Based on those kinds of posts it looked like a common issue, so I hoped there'd be an obvious and easy solution, but if not, that's fine. I'll probably reinstall Ubuntu (if a trial run in VirtualBox shows that'll help).

User avatar
dimesio
Moderator
Moderator
Posts: 12810
Joined: Tue Mar 25, 2008 10:30 pm

Re: Cannot install Wine32 in Ubuntu 20.04

Post by dimesio » Thu May 21, 2020 6:08 am

Code: Select all

The following packages have unmet dependencies:
 libgd3 : Breaks: libgd3:i386 (!= 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1) but 2.2.5-5.2ubuntu2 is to be installed
 libgd3:i386 : Breaks: libgd3 (!= 2.2.5-5.2ubuntu2) but 2.2.5-5.2+ubuntu18.04.1+deb.sury.org+1 is installed
 libidn2-0 : Breaks: libidn2-0:i386 (!= 2.2.0-2+ubuntu18.04.1+deb.sury.org+1) but 2.2.0-2 is to be installed
 libidn2-0:i386 : Breaks: libidn2-0 (!= 2.2.0-2) but 2.2.0-2+ubuntu18.04.1+deb.sury.org+1 is installed
Why do you have 18.04 packages installed in 20.04? That's bound to cause problems; apt requires the versions of i386 and amd64 packages to be identical. Change the installed packages to the ones in the Ubuntu 20.04 main (or universe) repository.

Post Reply