Cannot click checkboxes in laboratory application (Wine 4.0)

Questions about Wine on Linux
Post Reply
Hambert
Level 1
Level 1
Posts: 8
Joined: Tue May 05, 2020 4:09 pm

Cannot click checkboxes in laboratory application (Wine 4.0)

Post by Hambert » Sun May 17, 2020 3:43 pm

Hello all! I've recently moved to Wine from a Windows enviroment. I need this control software to operate a clinic autoanalyzer in a laboratory. I'm using Wine 4.0 due to this ptoblemthis bug with OLE databases in 5.0.

Software works great for the most part, after installing all the needed libraries with Winetricks.

Problem is, I cannot activate these checkboxes correctly. They do not respond to my clicks, and after many clicks they may become checked but the program rarely recognizes them as active, as it should display graphics on the right but not always does:

Image

I tried all the windows/mouse/virtual desktop options in the graphics tab of winecfg but none of those setting seems to affect this problem.

Any ideas?

Thank you so much in advance

Hambert
Level 1
Level 1
Posts: 8
Joined: Tue May 05, 2020 4:09 pm

Re: Cannot click checkboxes in laboratory application (Wine 4.0)

Post by Hambert » Sun May 24, 2020 3:05 pm

Any clue about this?

spoon0042
Level 5
Level 5
Posts: 251
Joined: Thu Dec 24, 2009 11:00 am

Re: Cannot click checkboxes in laboratory application (Wine 4.0)

Post by spoon0042 » Sun May 24, 2020 4:20 pm

Is it possible to test that functionality in a current version of wine without the database connection? Because that is the first thing you'd be asked if you file a bug. If not you would probably want to file a bug about your database issue if no one has yet done that.

Hambert
Level 1
Level 1
Posts: 8
Joined: Tue May 05, 2020 4:09 pm

Re: Cannot click checkboxes in laboratory application (Wine 4.0)

Post by Hambert » Sun May 24, 2020 4:27 pm

spoon0042 wrote:
Sun May 24, 2020 4:20 pm
Is it possible to test that functionality in a current version of wine without the database connection? Because that is the first thing you'd be asked if you file a bug. If not you would probably want to file a bug about your database issue if no one has yet done that.
Thanks for your answer! Unfortunately the program would refuse to start without a coneccion to the database, in wine 5.0 it is impossible to get it running in any way. It would complain right after startup and exit with a DB error.
Are you suggesting these checkbox issues have something to do with the databases?

spoon0042
Level 5
Level 5
Posts: 251
Joined: Thu Dec 24, 2009 11:00 am

Re: Cannot click checkboxes in laboratory application (Wine 4.0)

Post by spoon0042 » Sun May 24, 2020 6:58 pm

No, I just wanted to know if you could try the checkboxes in current wine independent of the database issue. If it just doesn't start there's nothing to be done about that though. You can still file a bug for either or both issues, hopefully that will get some attention.

Hambert
Level 1
Level 1
Posts: 8
Joined: Tue May 05, 2020 4:09 pm

Re: Cannot click checkboxes in laboratory application (Wine 4.0)

Post by Hambert » Sun May 24, 2020 7:24 pm

So I guess the way to go here is to first report the database bug and once it gets fixed test the checkboxes in newer versions of wine.

Thanks! I'll do so

Post Reply