setting up wine on new ubuntu 20.04

Questions about Wine on Linux
Post Reply
_stormclouds_
Newbie
Newbie
Posts: 3
Joined: Sat May 09, 2020 9:54 pm

setting up wine on new ubuntu 20.04

Post by _stormclouds_ » Sat May 09, 2020 10:10 pm

I installed a fresh copy of ubuntu 20.04 on my desktop and ran the commands to install it and installed winehq-staging and winetricks, which i have done many times.

after running winetricks in terminal to make the .wine folder and get wine mono, etc setup i get this error

winetricks
Executing mkdir -p /home/my-asus
------------------------------------------------------
You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
grep: /home/my-asus/.wine/*.reg: No such file or directory
------------------------------------------------------
WINEPREFIX INFO:
Drive C: total 12
drwxrwxr-x 3 my-asus my-asus 4096 May 9 20:50 .
drwxrwxr-x 4 my-asus my-asus 4096 May 9 20:50 ..
drwxrwxr-x 4 my-asus my-asus 4096 May 9 20:50 windows

Registry info:
/home/my-asus/.wine/*.reg:
------------------------------------------------------
------------------------------------------------------
wine cmd.exe /c echo '%AppData%' returned empty string, error message ""
------------------------------------------------------
some folders do get created no window pops up saying its creating my .wine folder, i also tried using winecfg to see if that would work.

winecfg
002c:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\wineboot.exe", error c0000018
0024:err:environ:run_wineboot failed to start wineboot c0000018
0024:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0034:err:module:__wine_process_init failed to load L"C:\\windows\\system32\\explorer.exe", error c0000018
0024:fixme:winediag:start_process Wine Staging 5.8 is a testing version containing experimental patches.
0024:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
003c:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
003c:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
003c:err:winediag:nodrv_CreateWindow The explorer process failed to start.

I decided to try it on my laptop that has kubuntu 20.04 and got the same problem, didnt have this problem with winehq-staging 5.7 so i think its a wine-staging 5.8 problem and i don't know what to do.

If anyone knows what i can do I'd appreciate it, I dont know if maby it be better to wait for v5.9 to come out instead.

Eimantas
Level 1
Level 1
Posts: 8
Joined: Wed Jun 24, 2015 6:24 am

Re: setting up wine on new ubuntu 20.04

Post by Eimantas » Sat May 16, 2020 12:02 pm

I recommend you rename or move .wine somehere else and create a new one by running winecfg. Have you tried it with stable wine?

NomisGnos
Newbie
Newbie
Posts: 3
Joined: Sun May 17, 2020 10:28 pm

Re: setting up wine on new ubuntu 20.04

Post by NomisGnos » Mon May 18, 2020 12:57 pm

I have the same issue. It's Wine-staging 5.8, you can see a related bug here:

viewtopic.php?f=8&t=33863

https://bugs.winehq.org/show_bug.cgi?id=49131

_stormclouds_
Newbie
Newbie
Posts: 3
Joined: Sat May 09, 2020 9:54 pm

Re: setting up wine on new ubuntu 20.04

Post by _stormclouds_ » Fri May 22, 2020 9:21 am

I did delete .wine and try the 2 commands again, I didnt try wine stable because the game i play requires wine staging

_stormclouds_
Newbie
Newbie
Posts: 3
Joined: Sat May 09, 2020 9:54 pm

Re: setting up wine on new ubuntu 20.04

Post by _stormclouds_ » Fri May 22, 2020 9:28 am

Thank you for the topics I believe that is my problem, and i cant downgrade because this install didn't have staging older than 5.8 installed to be rolled back to.

It sucks too because v5.7 was making my pc frezze when i loaded the game on my ubuntu mate install.

Post Reply