Problems on trying to compile the Wine64

Questions about Wine on Linux
Post Reply
NatanGameron
Level 1
Level 1
Posts: 6
Joined: Sat Jun 08, 2019 12:22 pm

Problems on trying to compile the Wine64

Post by NatanGameron » Tue Mar 24, 2020 4:27 pm

I'm trying to compile Wine64, but I have the following image problems:

Code: Select all

configure: MinGW compiler not found, cross-compiling PE files won't be supported

configure: libxcursor 64-bit development files not found, the Xcursor extension won't be supported.

configure: libxi 64-bit development files not found, the Xinput extension won't be supported.

configure: libxrandr 64-bit development files not found, Randr won't be supported.

configure: libxinerama 64-bit development files not found, multi-monitor setups won't be supported.

configure: libxcomposite 64-bit development files not found, Xcomposite won't be supported.

configure: libGLU 64-bit development files not found, GLU won't be supported.

configure: libOSMesa 64-bit development files not found (or too old), OpenGL ren dering in bitmaps won't be supported.

configure: OpenCL 64-bit development files not found, OpenCL won't be supported.

configure: pcap 64-bit development files not found, wpcap won't be supported.

configure: libhal 64-bit development files not found, no legacy dynamic device 3 support.

configure: libsane 64-bit development files not found, scanners won't be supported.

configure: libv412 64-bit development files not found.

configure: libgphoto2 64-bit development files not found, digital cameras won't be supported.

configure: libgphoto2_port 64-bit development files not found, digital cameras won't be auto-detected.

configure: liblcms2 64-bit development files not found, Color Management won't be supported.

configure: libpulse 64-bit development files not found or too old, Pulse won't be supported.

configure: gstreamer-l.0 base plugins 64-bit development files not found, GStreamer won't be supported.

configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.

configure: libSDL2 64-bit development files not found, SDL2 won't be supported.

configure: libFAudio 64-bit development files not found, XAudio2 won't be supported.

configure: libcapi20 64-bit development files not found, ISDN won't be supported.

configure: libcups 64-bit development files not found, CUPS won't be supported.

configure: libgsm 64-bit development files not found, gsm 06.10 codec won't be supported.

configure: libmpg123 64-bit development files not found (or too old), mp3 codec won't be supported.

configure: libopenal 64-bit development files not found (or too old), OpenAL won't be supported.

configure: libvulkan and libMoltenVK 64-bit development files not found, Vulkan won't be supported.

configure: vkd3d 64-bit development files not found (or too old), Direct3D 12 won't be supported.
How can I solve this? I'm trying to install on CentOS 7, downloaded the source code, unzipped it and tried to compile it and then install it.

Post Reply