Foobar2000 won't detect/read some of my tracks because of filenames

Questions about Wine on Linux
Post Reply
RelentlesSausage
Newbie
Newbie
Posts: 2
Joined: Thu Mar 19, 2020 12:43 am

Foobar2000 won't detect/read some of my tracks because of filenames

Post by RelentlesSausage » Thu Mar 19, 2020 2:44 am

Some files in my music library, specifically ones with special characters such as Japanese won't show up in my foobar2000 media library. When I add these tracks manually to the playlist view, the tracks metadata isn't there and when I click play a error usually pops up such as:

Code: Select all

Unable to open item for playback (Invalid path syntax):
"Z:\wesley\Music\2814\f0ccf%c.h*g WAV\2814 - f0ccf%c.h*g - 01 f"e$
.wav"
That is not the actual file path, the real one is:

Code: Select all

Z : \wesley\Music\2814\新しい日の誕生 WAV\2814 - 新しい日の誕生 - 01 恢复.wav
This issue seems to also be caused by folder names. I have not had this issue in the past with other Linux distro's running foobar2000 (Ubuntu, Kubuntu and Manjaro). Everything else seems to work perfectly. When I edit the filename of these tracks I can generally get them to show up in my media library/album list on foobar2000. These tracks show up fine in other music players such as DeaDBeeF and VLC (and also foobar2000 on windows). I transferred these tracks from a windows 10 NUC and they are all properly tagged and everything (these exact files would play fine on foobar2000 on that nuc).

Things I have already tried:
1. Installing allfonts with winetricks (a bunch of these font's seemed to not have installed (showing up as selected/cached (will add img)) despite me trying a bunch of things to get them to fully download.

2. Installing another music player via wine (aimp). it had the same issue with not seeing a bunch of files.

3. Changing directory of media library from /Music to /Downloads

Various system specs:
OS: Arch Linux
WINE Version: 5.4
Foobar2000 version: v1.5.2

I might be missing something, I'm still somewhat of a noob when it comes to linux despite using it for 3 years. I've looked all over the web for solutions but I still haven't figured this issue out. Foobar2000 works amazing otherwise, kudos for the WINE team for the absolutely amazing software :D.
Attachments
Screenshot_20200319_003800.png
Screenshot_20200319_003730.png

RelentlesSausage
Newbie
Newbie
Posts: 2
Joined: Thu Mar 19, 2020 12:43 am

Re: Foobar2000 won't detect/read some of my tracks because of filenames

Post by RelentlesSausage » Sat Mar 21, 2020 2:53 am

Update: swapped to openSUSE, this isn't a issue on openSUSE for some reason. I probably set up something wrong on arch.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2832
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Foobar2000 won't detect/read some of my tracks because of filenames

Post by Bob Wya » Sat Mar 21, 2020 2:00 pm

RelentlesSausage wrote:
Sat Mar 21, 2020 2:53 am
Update: swapped to openSUSE, this isn't a issue on openSUSE for some reason. I probably set up something wrong on arch.
Probably a difference in the global locale setup (which Wine will utilise).

Bob

Post Reply