001c:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.

Questions about Wine on Linux
Post Reply
Denton
Level 1
Level 1
Posts: 6
Joined: Sun Apr 21, 2019 8:09 am

001c:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.

Post by Denton » Sat Mar 14, 2020 3:59 pm

Wine is refusing to load for me today. I am the following errors upon trying to run winecfg.

Code: Select all

000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 1053
000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"winebus" failed to start: 1053
0014:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0014:err:winediag:nodrv_CreateWindow The explorer process failed to start.
0014:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0014:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
0014:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
000f:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 1053
001c:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
001c:err:winediag:nodrv_CreateWindow The explorer process failed to start.
001c:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
001c:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
001c:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
001e:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
001e:err:winediag:nodrv_CreateWindow The explorer process failed to start.
now its been a week since I last ran wine, and I did do 2 changes since then

A)renamed the user and the workspace.
B)system update including Kernel (the recent Manjaro update)

originally I figured it must be related to the renaming so I removed the .wine folder and tried to create a new .wine by running winecfg, which you can see the results for above. then I figured maybe its because I was running wine-staging so I downgraded to the normal wine version and now running 5.3 but I am still getting same error.

OS: Manjaro, 64bit arch

Post Reply