libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Questions about Wine on Linux
Post Reply
Logix
Newbie
Newbie
Posts: 3
Joined: Wed Jan 08, 2020 6:21 am

libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Post by Logix » Wed Jan 08, 2020 6:25 am

The libfaudio i386 package is currently missing from this repository for Ubuntu 19.10: https://download.opensuse.org/repositor ... 9.10/i386/ . It's there for Ubuntu 19.04 or 18.04, e.g.: https://download.opensuse.org/repositor ... 9.04/i386/. Due to this, I can't install Wine. Who's maintaining that repository? Is there anywhere I can submit this bug?

User avatar
dimesio
Moderator
Moderator
Posts: 12844
Joined: Tue Mar 25, 2008 10:30 pm

Re: libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Post by dimesio » Wed Jan 08, 2020 8:31 am

FAudio for 19.10 and later is provided by the distro, not us. The packages are definitely in the distro repository, because that's what we use to build the Wine packages for 19.10 with FAudio support. If you're unable to install it from the distro repository, ask for help on the Ubuntu forum.

Logix
Newbie
Newbie
Posts: 3
Joined: Wed Jan 08, 2020 6:21 am

Re: libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Post by Logix » Thu Jan 09, 2020 5:02 am

But only the i386 package is missing. Because of that, libfaudio can't be installed. If there was no 64bit package either, then the distro package would be used.

User avatar
dimesio
Moderator
Moderator
Posts: 12844
Joined: Tue Mar 25, 2008 10:30 pm

Re: libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Post by dimesio » Thu Jan 09, 2020 7:20 am

Looks like the 64 bit ones were built by mistake, probably last weekend when I was trying to sort out problems with the i586 repositories on the OBS.

But why do you have the OBS repository in your sources at all? It's not needed for 19.10. Just remove it, and your package manager will use the distro packages. Or, alternatively, pin it to a lower priority than the distro repository.

Logix
Newbie
Newbie
Posts: 3
Joined: Wed Jan 08, 2020 6:21 am

Re: libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Post by Logix » Thu Jan 09, 2020 7:30 am

I re-enabled it after I upgraded to Ubuntu 19.10, and it has been working until now. Whoever maintains that repository should then at least remove the 64bit libfaudio package, so it doesn't cause issues in case they have that repository enabled. I'm sure there will be quite a few users running into this issue.

User avatar
dimesio
Moderator
Moderator
Posts: 12844
Joined: Tue Mar 25, 2008 10:30 pm

Re: libfaudio0 i386 build missing from repository for Ubuntu 19.10 only

Post by dimesio » Thu Jan 09, 2020 8:05 am

Logix wrote:
Thu Jan 09, 2020 7:30 am
Whoever maintains that repository should then at least remove the 64bit libfaudio package, so it doesn't cause issues in case they have that repository enabled.
Agreed. I've issued a wipebinaries command, which should eventually remove them, but my experience is that that process can be very slow to get to all the mirrors.

Post Reply