Regression test: compiling Wine 2.x on Ubuntu 18.04

Questions about Wine on Linux
Post Reply
davide84
Level 1
Level 1
Posts: 6
Joined: Fri Jan 03, 2020 3:52 am

Regression test: compiling Wine 2.x on Ubuntu 18.04

Post by davide84 » Fri Jan 03, 2020 4:12 am

Hi everybody,

I own a game which does not run on Wine, there's a bug report on it and I am trying to help. Someone reported that the game used to run (he finished it) and became broken at some point before version 2.18 staging. I am therefore trying to do a regression test to find out what happened.

My problem is, 2.x tagged versions of Wine do not compile on my Ubuntu 18.04.
At the moment I am having a font-related issue similar to https://github.com/bobwya/bobwya/issues/17 and I am having the impression that my current system is just too far away in time from 2.x versions.

My question is: has any of you compiled those versions on recent distributions, does it make sense to even try? Is it just one library issue, or that error is just the beginning? Should I maybe get a 2016 OS to do my regression test?

Thanks :)

davide84
Level 1
Level 1
Posts: 6
Joined: Fri Jan 03, 2020 3:52 am

Re: Regression test: compiling Wine 2.x on Ubuntu 18.04

Post by davide84 » Sat Jan 04, 2020 3:56 am

I'll narrow down my question... I am getting this error compiling Wine 2.0:

Code: Select all

Error: Cannot open face courier.ttf
Makefile:174: recipe for target 'coue1255.fon' failed
make[1]: *** [coue1255.fon] Error 1
Makefile:17439: recipe for target 'fonts' failed
This is kind of strange, because:

Code: Select all

~/wine/wine-source$ ls fonts/c*
fonts/courier.sfd  fonts/courier.tt
...any idea :?:

davide84
Level 1
Level 1
Posts: 6
Joined: Fri Jan 03, 2020 3:52 am

Re: Regression test: compiling Wine 2.x on Ubuntu 18.04

Post by davide84 » Sat Jan 04, 2020 5:11 pm

I will reply to myself: something does not match between the font files included in 2.x and the new version of some font tool.

The workaround is to replace the content of the fonts/ folder with font files from a more recent version of Wine (e.g. 5). Literally: checking out version 5, making a backup of the fonts/ folder, checking out version 2.x, replacing the fonts/ folder with the backup version.

This fixes the compiling; running the game creates a series of other errors... I think I will pause my attempt to do a regression test on 2.0.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2853
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Regression test: compiling Wine 2.x on Ubuntu 18.04

Post by Bob Wya » Sat Jan 04, 2020 6:01 pm

@davide84

Have you tried using my Schroot-based multilib build script for Debian / Ubuntu:
Github.com : bobwya / build-multilib-wine
The build script is designed to support building Wine or Wine Staging back to version 1.8 ...

You can use the script to do a Git-based regression test...
Since building against a specified Wine (or Wine Staging) Git commit is supported.

Bob

davide84
Level 1
Level 1
Posts: 6
Joined: Fri Jan 03, 2020 3:52 am

Re: Regression test: compiling Wine 2.x on Ubuntu 18.04

Post by davide84 » Sun Jan 05, 2020 9:19 am

Hi Bob,

thanks for the link, I'll have a look!

bernd_b
Level 1
Level 1
Posts: 8
Joined: Fri May 16, 2008 3:56 am

Re: Regression test: compiling Wine 2.x on Ubuntu 18.04

Post by bernd_b » Sat Feb 01, 2020 2:31 pm

Using the font folder of version 5.0, I got version 4.18 compiled. Without this trick, I ran into the same error described above.

Post Reply