Wine Stable install on Linux Mint 19.3 Gives Error

Questions about Wine on Linux
Post Reply
Wirezfree
Newbie
Newbie
Posts: 3
Joined: Thu Dec 26, 2019 11:39 am

Wine Stable install on Linux Mint 19.3 Gives Error

Post by Wirezfree » Thu Dec 26, 2019 12:14 pm

Hello,

I have tried to install the latest stable version following another thread on the forum

Code: Select all

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt install --install-recommends winehq-stable
The final step gives an error:

Code: Select all

sudo apt-get install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 winehq-stable : Depends: wine-stable (= 4.0.3~bionic)
E: Unable to correct problems, you have held broken packages.
System:

Code: Select all

Kernel: 4.15.0-72-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
Desktop: Cinnamon 4.4.5 Distro: Linux Mint 19.3 Tricia 
base: Ubuntu 18.04 bionic 
Please can anybody provide guidance on this..

Many Thanks & Regards

vyguera
Level 1
Level 1
Posts: 8
Joined: Thu Dec 26, 2019 5:00 am

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by vyguera » Fri Dec 27, 2019 9:48 am


Wirezfree
Newbie
Newbie
Posts: 3
Joined: Thu Dec 26, 2019 11:39 am

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by Wirezfree » Sat Dec 28, 2019 5:05 am

@ vyguera

Thanks... I have seen that.. Does not offer me a solution... Just a series of suggestions


Wirezfree
Newbie
Newbie
Posts: 3
Joined: Thu Dec 26, 2019 11:39 am

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by Wirezfree » Sun Dec 29, 2019 4:16 am

This worked for me...

Code: Select all

sudo dpkg --add-architecture i386 
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt install --install-recommends winehq-stable
winecfg
Thanks

Cookie
Level 2
Level 2
Posts: 15
Joined: Mon Jun 22, 2015 2:09 pm

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by Cookie » Sun Jan 26, 2020 12:22 pm

This is crazy....

No solution yet!

In those days when W7 is dying the best alternative refuses installing wine!

zapper
Level 2
Level 2
Posts: 34
Joined: Wed Jul 27, 2016 7:58 pm

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by zapper » Mon Jan 27, 2020 2:59 am

Have you tried compiling from source? It isn't nearly as hard as people think. Take it from me, I learned how to install wine-staging from source on a distro that has some old libraries.

I should also add, that there are a few more steps for installing wine-staging.

As for wine-stable, unzip,
./configure
make && sudo make install

usually work. But it does take an hour unless... you do make -j2 or make -j3

the more cores you have in your processor the higher the number after j can be. But never make the number higher than the number of cores in your processor. :)

jkfloris
Level 7
Level 7
Posts: 821
Joined: Thu Aug 14, 2014 10:10 am

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by jkfloris » Mon Jan 27, 2020 4:39 am

Building from source like this will give you an almost unusable Wine64 only installation.

@Cookie
Could you confirm you have installed the libfaudio0 packages:

Code: Select all

apt-cache policy libfaudio0 libfaudio0:i386
If you haven't you can download them from:
https://download.opensuse.org/repositor ... _amd64.deb
https://download.opensuse.org/repositor ... c_i386.deb
and install them with dpkg

Code: Select all

sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb libfaudio0_19.07-0~bionic_i386.deb
sudo apt-get update
sudo apt-get install -f
sudo apt install --install-recommends winehq-stable
If you are still unable to install Wine, could you post the output of:

Code: Select all

apt-cache policy
Does the following solution work:

Code: Select all

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

Arius
Newbie
Newbie
Posts: 1
Joined: Wed Feb 05, 2020 9:08 pm

Re: Wine Stable install on Linux Mint 19.3 Gives Error

Post by Arius » Thu Feb 06, 2020 3:59 pm

I was also getting the dependencies error but after installing the libfaudio0 packages posted by jkfloris I ran a Wine 5.0 install with no errors. Before the install I removed all wine references from my several previous attempts to install:

- created a timeshift snapshot
- in software manager removed wine
- sudo apt remove winehq-stable wine-stable wine1.6 wine-mono wine-geco winetricks [just in case]
- in software sources removed cybermax-dexter ppa’s and any wine refs
- deleted all .wine folders

Installed with:

Code: Select all

sudo dpkg --add-architecture i386
sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb
sudo dpkg -i libfaudio0_19.07-0~bionic_i386.deb
sudo apt-get update
apt-cache policy libfaudio0 libfaudio0:i386
libfaudio0:
  Installed: 19.07-0~bionic
  Candidate: 19.07-0~bionic
  Version table:
 *** 19.07-0~bionic 100
        100 /var/lib/dpkg/status
libfaudio0:i386:
  Installed: 19.07-0~bionic
  Candidate: 19.07-0~bionic
  Version table:
 *** 19.07-0~bionic 100
        100 /var/lib/dpkg/status

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-get install -f
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt install --install-recommends winehq-stable
There were some messages not shown here but no errors.

Then ran winecfg which showed a lot of messages that I'm not sure about. I would like to know if I can ignore the following messages or if there is any action to take:

Code: Select all

wine: created the configuration directory '/home/xyz/.wine'
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
0017:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0017:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0017:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
001c:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
001c:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
001c:err:mscoree:LoadLibraryShim error reading registry key for installroot
001c:err:mscoree:LoadLibraryShim error reading registry key for installroot
001c:err:mscoree:LoadLibraryShim error reading registry key for installroot
001c:err:mscoree:LoadLibraryShim error reading registry key for installroot
001c:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 5)
001c:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 5)
0017:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0017:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0022:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0022:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0022:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0022:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0022:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0010:fixme:dwmapi:DwmIsCompositionEnabled 0000000006B80434
0027:fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x2ab306d, context 0x554020, init_notify 0, handle 0x797f9e0): stub
0010:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0043:fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
0043:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0043:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0043:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0043:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0041:fixme:dwmapi:DwmIsCompositionEnabled 0608DD14
0048:fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x280f537, context 0x2a3820, init_notify 0, handle 0x6e6fcd8): stub
0041:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
wine: configuration in L"/home/xyz/.wine" has been updated.
wine: Read access denied for device L"\\??\\Z:\\", FS volume label and serial are not available.
0064:fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
Software that I installed on Wine 4.0.5 installed on Wine 5.0 with just a few less messages and work.

Post Reply