Empire at War installs but won't run

Questions about Wine on Linux
Post Reply
Unifying Theory
Level 2
Level 2
Posts: 10
Joined: Tue Dec 24, 2019 2:56 am

Empire at War installs but won't run

Post by Unifying Theory » Tue Dec 24, 2019 3:16 am

Hey guys,

Anyone out there still playing this game? I have the regular release on disc.
It looks like others have had success getting this to work, so I need your help figuring out how.

It installs and then I can apply the 1.5 update, but it crashes when trying to run.

Wine version: 4.0.3
Linux Mint 19.1

Thanks in advance!

jkfloris
Level 8
Level 8
Posts: 1138
Joined: Thu Aug 14, 2014 10:10 am

Re: Empire at War installs but won't run

Post by jkfloris » Wed Dec 25, 2019 7:32 am

According to a user on the AppDB there is a bug in Empire at War (or in Wine):
My Wine installation uses the french locale, and for some reason the game doesn't properly start when it was installed that way. It will display the splash screen and then exit immediately without even an error message.
WINEDEBUG=warn+all helps you see what's wrong.

In this case, I had several files in the Data/ directory that the game was looking for with a _english name. Sure enough, those files didn't exist, but they did with _french. A symbolic link solved the issue.
Do you have the same problem?

Unifying Theory
Level 2
Level 2
Posts: 10
Joined: Tue Dec 24, 2019 2:56 am

Re: Empire at War installs but won't run

Post by Unifying Theory » Thu Dec 26, 2019 1:56 pm

Everything in my computer is English, so I don't think so.

jkfloris
Level 8
Level 8
Posts: 1138
Joined: Thu Aug 14, 2014 10:10 am

Re: Empire at War installs but won't run

Post by jkfloris » Sun Dec 29, 2019 4:06 pm

Could you post a terminal output?

Unifying Theory
Level 2
Level 2
Posts: 10
Joined: Tue Dec 24, 2019 2:56 am

Re: Empire at War installs but won't run

Post by Unifying Theory » Fri Jan 03, 2020 11:53 pm

Bump. Was my post deleted? I posted terminal output several days ago and the message needed approved by a mod.

User avatar
dimesio
Moderator
Moderator
Posts: 12844
Joined: Tue Mar 25, 2008 10:30 pm

Re: Empire at War installs but won't run

Post by dimesio » Sat Jan 04, 2020 12:18 am

According to the moderator log that post was disapproved because you mentioned using a no-DVD patch. Illegal software is not supported and discussion of it is against forum rules.

Unifying Theory
Level 2
Level 2
Posts: 10
Joined: Tue Dec 24, 2019 2:56 am

Re: Empire at War installs but won't run

Post by Unifying Theory » Thu Jan 23, 2020 1:30 am

All righty, no problem.

I installed wine-5.0-rc6 and created a fresh prefix.
The game installs fine. The 1.05 patch installs fine.
The launcher starts fine. When I click "start game", it crashes and gives an exception:
Screenshot from 2020-01-23 01-25-12.png
Screenshot from 2020-01-23 01-25-12.png (9.26 KiB) Viewed 383 times

Code: Select all

~/.wine-eaw/drive_c/Program Files (x86)/LucasArts/Star Wars Empire at War$ wine LaunchEAW.exe 
0009:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0009:fixme:wbemprox:wbem_services_CreateInstanceEnum unsupported flags 0x00000030
0009:fixme:wbemprox:enum_class_object_Next timeout not supported
0009:fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
0009:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
0051:fixme:ntdll:NtQueryObject Unsupported information class 3
0051:err:rpc:I_RpcGetBuffer no binding
0051:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
wine: Read access denied for device L"\\??\\z:\\", FS volume label and serial are not available.
0051:fixme:file:K32EnumPageFilesA (0xe37b00, 0x1597734) stub
0051:fixme:file:K32EnumPageFilesA (0xe37b00, 0x1565c5c) stub
0051:fixme:cdrom:CDROM_GetMediaType : faking success
0051:fixme:ntdll:server_ioctl_file Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
0051:fixme:cursor:SetSystemCursor (0x2005e,00007f00),stub!
0051:fixme:cursor:SetSystemCursor (0x1007e,00007f00),stub!
0051:fixme:cursor:SetSystemCursor (0x1008c,00007f8a),stub!
0051:fixme:cursor:SetSystemCursor (0x1009a,00007f03),stub!
0051:fixme:cursor:SetSystemCursor (0x100a8,00007f01),stub!
0051:fixme:cursor:SetSystemCursor (0x100b6,00007f88),stub!
0051:fixme:cursor:SetSystemCursor (0x100c4,00007f86),stub!
0051:fixme:cursor:SetSystemCursor (0x100d2,00007f83),stub!
0051:fixme:cursor:SetSystemCursor (0x100e0,00007f82),stub!
0051:fixme:cursor:SetSystemCursor (0x100ee,00007f84),stub!
0051:fixme:cursor:SetSystemCursor (0x100fc,00007f04),stub!
0051:fixme:cursor:SetSystemCursor (0x1010a,00007f02),stub!
0051:fixme:cursor:SetSystemCursor (0x2005e,00007f00),stub!
0051:fixme:cursor:SetSystemCursor (0x50042,00007f8a),stub!
0051:fixme:cursor:SetSystemCursor (0x130058,00007f00),stub!
0051:fixme:cursor:SetSystemCursor (0x20054,00007f03),stub!
0051:fixme:cursor:SetSystemCursor (0x20056,00007f01),stub!
0051:fixme:cursor:SetSystemCursor (0x40062,00007f88),stub!
0051:fixme:cursor:SetSystemCursor (0x30064,00007f86),stub!
0051:fixme:cursor:SetSystemCursor (0x10068,00007f83),stub!
0051:fixme:cursor:SetSystemCursor (0x1006c,00007f85),stub!
0051:fixme:cursor:SetSystemCursor (0x10070,00007f82),stub!
0051:fixme:cursor:SetSystemCursor (0x10074,00007f84),stub!
0051:fixme:cursor:SetSystemCursor (0x10078,00007f04),stub!
0051:fixme:cursor:SetSystemCursor (0x1007c,00007f02),stub!
0051:fixme:ntdll:NtQueryObject Unsupported information class 3
0051:err:rpc:I_RpcGetBuffer no binding
0051:fixme:imm:ImmReleaseContext (0001011E, 01E7AA18): stub
0051:fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"!
0051:fixme:d3d:wined3d_check_device_format_conversion wined3d 0x169e860, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
0051:fixme:d3d:wined3d_check_device_format_conversion wined3d 0x169e860, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_HAL, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
0051:fixme:d3d:wined3d_check_device_format_conversion wined3d 0x169e860, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_SW, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
0051:fixme:d3d:wined3d_check_device_format_conversion wined3d 0x169e860, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_SW, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
0051:fixme:d3d:wined3d_check_device_format_conversion wined3d 0x169e860, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_REF, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B8G8R8X8_UNORM stub!
0051:fixme:d3d:wined3d_check_device_format_conversion wined3d 0x169e860, adapter_idx 0, device_type WINED3D_DEVICE_TYPE_REF, src_format WINED3DFMT_B8G8R8A8_UNORM, dst_format WINED3DFMT_B5G6R5_UNORM stub!
0051:fixme:d3dcompiler:compile_shader Compilation target "fx_2_0" not yet supported

Post Reply