"Waves central" for manage my waves audio plugins problems

Questions about Wine on Linux
Post Reply
Codesound
Level 2
Level 2
Posts: 33
Joined: Sun Sep 01, 2019 7:03 am

"Waves central" for manage my waves audio plugins problems

Post by Codesound » Mon Dec 09, 2019 1:47 pm

Linux Mint 19.2 Cinnamom 4.2.4 - Wine HQ devel 4.21

Hi,
when I open the waves central software for manage my waves audio plugins, taked from:https://www.waves.com/downloads/central

this message appear on my desk:

Image

how I fix it?
I don't have any antivirus installed...

Thanks Guys......

Synbios
Level 1
Level 1
Posts: 5
Joined: Sun Jan 05, 2014 3:35 pm

Re: "Waves central" for manage my waves audio plugins problems

Post by Synbios » Sat Mar 14, 2020 8:58 pm

I have the same problem. I believe we'll need to install PowerShell

qwertymnb
Level 4
Level 4
Posts: 135
Joined: Sun Jan 17, 2016 4:36 pm
Location: Eindhoven de gekste!

Re: "Waves central" for manage my waves audio plugins problems

Post by qwertymnb » Mon Mar 16, 2020 5:23 am

Hi, here`s a winetricks script I made for this a time ago.
You could try it, copy paste somewhere in winetricks, and than do "winetricks powershell20" (do in new fresh prefix)
Regards

Code: Select all

#----------------------------------------------------------------

w_metadata powershell20 dlls \
    title="Windows Powershell 2.0 (builtin in Windows 7)" \
    publisher="Microsoft" \
    media="download" \
    file1="WindowsServer2003-KB968930-x64-ENG.exe" \
    installed_file1="$W_SYSTEM32_DLLS_WIN/WindowsPowerShell/v1.0/powershell.exe"

load_powershell20()
{
    w_warn "Installing Powershell. This requires first installing dotnet20sp1 so might take a while";

    w_call dotnet20sp1

    w_download_to pwsh20  https://download.microsoft.com/download/B/D/9/BD9BB1FF-6609-4B10-9334-6D0C58066AA7/WindowsServer2003-KB968930-x64-ENG.exe 9f5d24517f860837daaac062e5bf7e6978ceb94e4e9e8567798df6777b56e4c8
    w_override_dlls native powershell.exe

#   The installer fails with "Invalid Handle" error if scecli.dll is missing. For now get it from win7sp1 package but if this gives
#   issues (mixing w2k3 / win7 dlls) then we could also extract it from https://download.microsoft.com/download/3/c/5/3c5c6364-27d3-4e18-bd04-244d0ec09dd4/WindowsServer2003.WindowsXP-KB914961-SP2-x64-ENU.exe
    helper_win7sp1_x64 wow64_microsoft-windows-s..urationengineclient_31bf3856ad364e35_6.1.7601.17514_none_a088921d241bbb4e/scecli.dll
    w_try cp "$W_TMP/wow64_microsoft-windows-s..urationengineclient_31bf3856ad364e35_6.1.7601.17514_none_a088921d241bbb4e/scecli.dll" "$W_SYSTEM32_DLLS/scecli.dll"

if [ "$W_ARCH" = "win64" ]; then
    helper_win7sp1_x64 amd64_microsoft-windows-s..urationengineclient_31bf3856ad364e35_6.1.7601.17514_none_9633e7caefbaf953/scecli.dll
    w_try cp "$W_TMP/amd64_microsoft-windows-s..urationengineclient_31bf3856ad364e35_6.1.7601.17514_none_9633e7caefbaf953/scecli.dll" "$W_SYSTEM64_DLLS/scecli.dll"
fi

    w_set_winver win2k3

#   Only supports unattended install because of bug https://bugs.winehq.org/show_bug.cgi?id=16876
    "$WINE" "${W_CACHE_WIN}/pwsh20/WindowsServer2003-KB968930-x64-ENG.exe" /q /passive /nobackup
    w_wineserver -w



#   Aftermath: try fixing wrong registry values due to bug https://bugs.winehq.org/show_bug.cgi?id=25740
    sed -i '/WindowsPowerShell/ s/%SystemRoot%/c:\\\\windows/' "$W_DRIVE_C"/../system.reg # only replace wrong %SystemRoot% in lines containing string "WindowsPOwershell"
#   That leaves three more lines in system.reg with string %SystemRoot% written by the installer; do we have to replace them as well???
#   "EventMessageFile"=str(2):"%SystemRoot%\\System32\\spmsg.dll"
#   "ImagePath"="%SystemRoot%\\system32\\svchost.exe -k WINRM"
#   "ServiceDll"=str(2):"%SystemRoot%\\system32\\WsmSvc.dll"

    w_set_app_winver powershell.exe win2k3

    w_warn "You can start the powershell with "wine start powershell.exe""
}

#----------------------------------------------------------------

Codesound
Level 2
Level 2
Posts: 33
Joined: Sun Sep 01, 2019 7:03 am

Re: "Waves central" for manage my waves audio plugins problems

Post by Codesound » Thu Mar 19, 2020 12:01 pm

Hi,

thanks for this script!
I would to re-try the adventure of install powershell with your script... but please guide me step-by-step on what to do....

Thanks....

qwertymnb
Level 4
Level 4
Posts: 135
Joined: Sun Jan 17, 2016 4:36 pm
Location: Eindhoven de gekste!

Re: "Waves central" for manage my waves audio plugins problems

Post by qwertymnb » Tue Apr 14, 2020 2:24 am

Hi, sorry for late reply...
. but please guide me step-by-step on what to do....
I uploaded whole script here:
https://raw.githubusercontent.com/PietJ ... cks_pwsh20
Just save it in some directory, rename to winetricks and then:

chmod +x ./winetricks
./winetricks powershell20

Regards

Codesound
Level 2
Level 2
Posts: 33
Joined: Sun Sep 01, 2019 7:03 am

Re: "Waves central" for manage my waves audio plugins problems

Post by Codesound » Wed Apr 15, 2020 2:55 am

qwertymnb wrote:
Tue Apr 14, 2020 2:24 am
Hi, sorry for late reply...
. but please guide me step-by-step on what to do....
I uploaded whole script here:
https://raw.githubusercontent.com/PietJ ... cks_pwsh20
Just save it in some directory, rename to winetricks and then:

chmod +x ./winetricks
./winetricks powershell20

Regards
Hi,

first of all: MANY and MANY thanks for your hard work! This script helped me and other neewbie linux users! Thanks again a lot!
Waves Central 11 is successfully installed on my Linux Mint 19.03_ Cinnamon x64 system, but when I open it, the CPU starts working without opening any screens:
in the images below you can see the time when you see the CPU working at empty.

Is there a command to run at the terminal that maybe can help us understand what is blocking the CPU?

Thanks again for all!!!

https://imgur.com/dQD1MDV

https://imgur.com/44FjR0t

qwertymnb
Level 4
Level 4
Posts: 135
Joined: Sun Jan 17, 2016 4:36 pm
Location: Eindhoven de gekste!

Re: "Waves central" for manage my waves audio plugins problems

Post by qwertymnb » Sun Jun 28, 2020 1:10 pm

Again very late reply, apologies; Forgot about this until i found the installer again on my disk. I opened a bugreport here:
https://bugs.winehq.org/show_bug.cgi?id=49460

I was bored and to kill some time I tried if I could get it running with Powershell Core.
Below an ugly wrapper patch that allowed me to get up to the login screen. Though powershell and Powershell Core are really different , a great bunch of commands might just work in Powershell Core, at least enough to get Waves to the login Screen.

After applying patch and compile wine, you`d have to
1. install Powershell Core from https://github.com/PowerShell/PowerShel ... in-x64.msi
2. Copy where.exe from some windows-drive (c;\\windpows\\{system32/syswow64} to wine`s {system32 /syswow64} folder
3. Start installer, let it install. It still errors out with that messagebox when started from the installer (don`t know why), but if i run it from the directory where it`s installed, it starts up to the login screen (if it starts to update to new version you get same error; just try start it again)

Code: Select all

diff --git a/programs/powershell/main.c b/programs/powershell/main.c
index eb9a64ff0e..39432d0657 100644
--- a/programs/powershell/main.c
+++ b/programs/powershell/main.c
@@ -1,5 +1,5 @@
 /*
- * Copyright 2017 Jactry Zeng for CodeWeavers
+ * powershell.exe - this program only calls pwsh.exe
  *
  * This library is free software; you can redistribute it and/or
  * modify it under the terms of the GNU Lesser General Public
@@ -16,18 +16,67 @@
  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA
  */
 
+// Commands that Waves calls, the last one fails but not fatal for Waves
+//powershell.exe Write-Host $PSVersionTable.PSVersion.Major $PSVersionTable.PSVersion.Minor
+//powershell.exe -command &{'{0}.{1}' -f $PSVersionTable.PSVersion.Major, $PSVersionTable.PSVersion.Minor}
+//powershell.exe (Get-PSDrive C).Free
+//powershell.exe -noLogo -noExit  /c Register-WMIEvent -Query 'SELECT * FROM Win32_DeviceChangeEvent WHERE (EventType = 2 OR EventType = 3) GROUP WITHIN 4' -Action { [System.Console]::WriteLine('Devices Changed') }
+
+#define WIN32_LEAN_AND_MEAN
+
+#include <stdarg.h>
+#include <process.h>
+#include <windows.h>
+
 #include "wine/debug.h"
+//#include "resources.h"
 
 WINE_DEFAULT_DEBUG_CHANNEL(powershell);
 
 int __cdecl wmain(int argc, WCHAR *argv[])
 {
-    int i;
+    int i,j;
+    WCHAR commandlineW [MAX_PATH];
+    BOOL contains_command=FALSE;
+    const WCHAR *new_args[3];
+    //https://github.com/PowerShell/PowerShell/releases/download/v6.1.6/PowerShell-6.1.6-win-x64.msi
+    //https://github.com/PowerShell/PowerShell/releases/download/v6.1.6/PowerShell-6.1.6-win-x86.msi
+    //wine msiexec /i /media/louis/aqqa/PowerShell-6.1.6-win-x64.msi INSTALLFOLDER="C:\\Powershell6\\" /q
+    //For now assume it`s installed in default path:
+    const WCHAR pwshW[MAX_PATH] = L"c:\\Program Files\\PowerShell\\6\\pwsh.exe";
+    const WCHAR pwsh_exeW[] = L"pwsh.exe";
 
     WINE_FIXME("stub:");
     for (i = 0; i < argc; i++)
         WINE_FIXME(" %s", wine_dbgstr_w(argv[i]));
     WINE_FIXME("\n");
 
+    if(argc == 1) {ERR("Just run wine pwsh, invoking via this wrapper would crash...\n"); return 0;}
+
+    j = 1;
+    commandlineW[0] = '\0'; 
+     /* pwsh requires a command option "/c" , powershell doesn`t e.g. "powershell -NoLogo echo $env:username" should go
+    into "pwsh -NoLogo /c echo $env:username". This is troublesome initial attempt which needs lots of improvement... */
+
+    if(wcsncmp(L"-", argv[1],1))  wcscat(commandlineW,L"/c ");  /*1st arg is not an option (-.....) nor -c or -command ==> prepend with /c */
+
+    while(j<argc) {
+                   wcscat(commandlineW,argv[j]); wcscat(commandlineW,L" "); /* concatenate all args into one single commandline */
+
+                   if (!wcsnicmp(L"-c", argv[j],2))  {contains_command=TRUE;}
+
+                   if ( !contains_command && !wcsncmp(L"-", argv[j],1) && j+1<argc && wcsncmp(L"-", argv[j+1],1))  {wcscat(commandlineW,L" /c ");}
+
+                   j++;
+                  }
+
+    FIXME("new command is %s\n", wine_dbgstr_w(commandlineW));
+
+    new_args[0] = pwsh_exeW;
+    new_args[1] = commandlineW;
+    new_args[2] = NULL;
+
+    _wspawnv(P_OVERLAY, pwshW, new_args);
+
     return 0;
 }

Post Reply