Can't install wine (wine-staging) Linux Mint 19.2

Questions about Wine on Linux
Post Reply
User avatar
De1m0s
Level 2
Level 2
Posts: 14
Joined: Thu May 10, 2018 1:17 am
Location: Germany

Can't install wine (wine-staging) Linux Mint 19.2

Post by De1m0s » Tue Nov 12, 2019 10:28 am

Hi
I followed the installation-instruction for Ubuntu/Mint from the winehq-wiki. I did this on another pc without problems; but here, i get the message:

Code: Select all

sudo apt install --install-recommends winehq-staging
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 winehq-staging : Hängt ab von: wine-staging (= 4.19~disco)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

winehq-staging depends on wine-staging (?)

tried this:

Code: Select all

sudo apt install wine-staging
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine-staging : Hängt ab von: wine-staging-amd64 (= 4.19~disco) aber 4.18~bionic soll installiert werden
                Hängt ab von: wine-staging-i386 (= 4.19~disco)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

wine-staging depends on wine-staging-amd64 (???)

tried this:

Code: Select all

sudo apt install wine-staging-amd64

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine-staging-amd64 : Hängt ab von: libc6 (>= 2.29) aber 2.27-3ubuntu1 soll installiert werden
                      Hängt ab von: libvkd3d1 (>= 1.0) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
WTF?? where's the problem? Can anyone help, please?

jkfloris
Level 6
Level 6
Posts: 704
Joined: Thu Aug 14, 2014 10:10 am

Re: Can't install wine (wine-staging) Linux Mint 19.2

Post by jkfloris » Tue Nov 12, 2019 11:04 am

wine-staging-amd64 (= 4.19~disco) aber 4.18~bionic soll installiert werden
You are trying to install the Ubuntu Disco packages on a Ubuntu Bionic (Mint 19.2) system.

Replace "disco" with "bionic" in your WineHQ repository and you should be able to install the packages.

User avatar
De1m0s
Level 2
Level 2
Posts: 14
Joined: Thu May 10, 2018 1:17 am
Location: Germany

Re: Can't install wine (wine-staging) Linux Mint 19.2

Post by De1m0s » Tue Nov 12, 2019 12:53 pm

Hi
No, i didn't. That's what i did:

Code: Select all

wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main' 
Result is:

Code: Select all

Paketquelle ist bereits vorhanden.
Then:

Code: Select all

sudo apt update

...
Fehl:5 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease
  Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 76F1A20FF987672F
  ....

jkfloris
Level 6
Level 6
Posts: 704
Joined: Thu Aug 14, 2014 10:10 am

Re: Can't install wine (wine-staging) Linux Mint 19.2

Post by jkfloris » Tue Nov 12, 2019 2:19 pm

Check if the winehq.key is installed:

Code: Select all

apt-key list | grep -B2 -A3 "76F1 A20F F987 672F"
And what is the output of:

Code: Select all

grep -R ^deb /etc/apt/sources.list*

User avatar
De1m0s
Level 2
Level 2
Posts: 14
Joined: Thu May 10, 2018 1:17 am
Location: Germany

Re: Can't install wine (wine-staging) Linux Mint 19.2

Post by De1m0s » Wed Nov 13, 2019 10:03 am

Hi
The result of "apt-key list | grep -B2 -A3 "76F1 A20F F987 672F"" is:

Code: Select all

Warning: apt-key output should not be parsed (stdout is not a terminal)
No difference if i do this as admin.

The result of "grep -R ^deb /etc/apt/sources.list*" is:

Code: Select all

/etc/apt/sources.list.d/additional-repositories.list:deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_19.04 ./
/etc/apt/sources.list.d/additional-repositories.list:deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main
/etc/apt/sources.list.d/cybermax-dexter-sdl2-backport-bionic.list:deb http://ppa.launchpad.net/cybermax-dexter/sdl2-backport/ubuntu bionic main
/etc/apt/sources.list.d/official-package-repositories.list:deb http://packages.linuxmint.com tina main upstream import backport #id:linuxmint_main
/etc/apt/sources.list.d/official-package-repositories.list:deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
/etc/apt/sources.list.d/official-package-repositories.list:deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
/etc/apt/sources.list.d/official-package-repositories.list:deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
/etc/apt/sources.list.d/official-package-repositories.list:deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
/etc/apt/sources.list.d/official-package-repositories.list:deb http://archive.canonical.com/ubuntu/ bionic partner


jkfloris
Level 6
Level 6
Posts: 704
Joined: Thu Aug 14, 2014 10:10 am

Re: Can't install wine (wine-staging) Linux Mint 19.2

Post by jkfloris » Wed Nov 13, 2019 11:46 am

The "apt-key list" command should have returned some output. Try to add the WineHQ key again.

You are mixing two Ubuntu versions 19.04 is Disco 18.04 is Bionic.
Edit the file "/etc/apt/sources.list.d/additional-repositories.list" and replace:

Code: Select all

deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_19.04 ./
with

Code: Select all

deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./

User avatar
De1m0s
Level 2
Level 2
Posts: 14
Joined: Thu May 10, 2018 1:17 am
Location: Germany

Re: Can't install wine (wine-staging) Linux Mint 19.2

Post by De1m0s » Wed Nov 13, 2019 12:12 pm

THAT'S iT!!
Thank you very much. I could install it now.

Post Reply