Wine crashes JACK server

Questions about Wine on Linux
Post Reply
User avatar
Maniaxx
Level 2
Level 2
Posts: 23
Joined: Sun Aug 20, 2017 5:42 pm
Location: DE

Wine crashes JACK server

Post by Maniaxx » Sun Oct 06, 2019 12:54 pm

Hallo,
when i start 'winecfg' and go to the 'audio' tab JACK crashes (massive xruns) and i have to force-kill it. This also happens when i start a game or anything else with wine (that probably uses sound). This doesn't happen when i do 'winetricks sound=disabled'. But 'sound=ALSA' crashes always when i start a game. Neither JACK nor WINE output any error info as if they wouldn't even notice it.

If i start WINE before JACK its ok. I can use an audio environment consisting of an aloop device (virtual sound card) as default alsa device and an ALSA->JACK bridge to route WINE audio to JACK properly. But once i close/restart WINE JACK crashes again. So, this is a one-shot workaround only. Its somehow related to sound initialization, device enumeration or similar.

Is there anything i can do to tackle the problem? Limit the device enumeration in WINE (make only the audio loopback device visible) or get some more verbose audio logs from WINE what its doing exactly with JACK? I'm not aware of any other app crashing JACK in that way. This problem is (at least) more than a year old.

Arch 5.3.4
Wine 4.17
jack2 1.9.12

audio devices:
sb-audigy2
nvidia hdmi
loopback

User avatar
Maniaxx
Level 2
Level 2
Posts: 23
Joined: Sun Aug 20, 2017 5:42 pm
Location: DE

Re: Wine crashes JACK server

Post by Maniaxx » Wed Oct 09, 2019 10:26 am

Never mind... it seems to be related to Audigy2 driver. The 'capture' channels seem to be broken. I have issues with that on other progs like Audacity as well. If i limit Jack to grab 'playback' devices only it works properly.

Post Reply