Issues Installing stable on Debian 10.1

Questions about Wine on Linux
Post Reply
dr1fter
Newbie
Newbie
Posts: 4
Joined: Tue Oct 01, 2019 1:58 am

Issues Installing stable on Debian 10.1

Post by dr1fter » Tue Oct 01, 2019 2:19 am

Hi *,

after a recent upgrade from Debian-9 to Debian 10 (and then 10.1), my Wine Installation (worked fine before..) seems to have broke.

Trying to install it (using apt) yields an error message, w.r.t. dependency resolution errs (first-level: `winehq-stable : Depends: wine-stable (= 4.0.2~buster)`).

Following up through dependencies, I get trough:

`wine-stable : Depends: wine-stable-i386 (= 4.0.2~buster)`
to
`wine-stable-i386:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed`
to
`libldap-2.4-2:i386 : Depends: libgnutls30:i386`
to
`libgnutls30:i386 : Depends: libidn2-0:i386`

to ultimately reach
```WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
apt libgnutls30 (due to apt)
0 upgraded, 11 newly installed, 606 to remove and 0 not upgraded```

Which does not look to me like a sane thing to do.

Next, I tried installing winehq-stable with aptitude, which proposed the following correction:
```
The following actions will resolve these dependencies:

Downgrade the following packages:
1) libidn2-0 [2.2.0-2+0~20190911.2+debian10~1.gbpf85c2e (<NULL>, now) -> 2.0.5-1 (stable)]
```

--> Does winehq-stable have dependencies towards outdated libidn2? I am not sure if downgrading is a good idea. --> Any suggestions on how to resolve this?

Thanks
Christian

jkfloris
Level 6
Level 6
Posts: 658
Joined: Thu Aug 14, 2014 10:10 am

Re: Issues Installing stable on Debian 10.1

Post by jkfloris » Tue Oct 01, 2019 11:09 am

1) libidn2-0 [2.2.0-2+0~20190911.2+debian10~1.gbpf85c2e (<NULL>, now) -> 2.0.5-1 (stable)]
2.0.5 is the version in Debian Stable. If you think this version is outdated, update to Debian Testing or Sid. Both have version 2.2.0.

How did you install version 2.2.0-2+0~20190911.2+debian10~1?

dr1fter
Newbie
Newbie
Posts: 4
Joined: Tue Oct 01, 2019 1:58 am

Re: Issues Installing stable on Debian 10.1

Post by dr1fter » Wed Oct 02, 2019 12:35 am

How did you install version 2.2.0-2+0~20190911.2+debian10~1?
Hmm... Probably, it was implicitly upgraded to the version from buster-backports, when I installed a package from there. I did not upgrade said package explicitly. Will try downgrading, which is probably a good idea, given this is the current version for debian-buster.
--> Thank you so much for your help! Will post an update in case the downgrade fixed my installation issues

dr1fter
Newbie
Newbie
Posts: 4
Joined: Tue Oct 01, 2019 1:58 am

Re: Issues Installing stable on Debian 10.1

Post by dr1fter » Wed Oct 02, 2019 12:48 am

Hi again,

I just performed the downgrade as both aptitude and you suggested (`apt install <package-name>=<version>`). Subsequently, after manually installing the 32bit-version of libidn2-0, the winehq-stable package could be installed w/o any problems.

--> Thanks again for your quick help!

jkfloris
Level 6
Level 6
Posts: 658
Joined: Thu Aug 14, 2014 10:10 am

Re: Issues Installing stable on Debian 10.1

Post by jkfloris » Wed Oct 02, 2019 8:39 am

I think that package has an other origin. Debian packages from backports have a ~bpo suffix.

dr1fter
Newbie
Newbie
Posts: 4
Joined: Tue Oct 01, 2019 1:58 am

Re: Issues Installing stable on Debian 10.1

Post by dr1fter » Sat Oct 05, 2019 3:08 am

you're right. So I must have received said package from another package repository. Interesting. ASAMOF, apt will now suggest me to upgrade libidn2-0 back to the version is was before I downgraded (removing again winehq package in the process). So I suppose the issue at hand was at no point related to winehq package, but is due to me referencing a package repository with an unconveniently new libidn2-0 version (and without offering the 32bit-version of it).

In fact, it seems the package stems from `https://packages.sury.org/php buster/main amd64 Packages`, which I used to add as package repository back on Debian-9, when I needed PHP7.3 (which was not available at the time).

Thank you so so much for pointing this out to me. You did not just help me to install Wine again, but also to cleanup some fully unrelated legacies.

Post Reply