Crash from "wine ./SETUP.EXE".

Questions about Wine on Linux
Post Reply
peasthope
Newbie
Newbie
Posts: 4
Joined: Sat Sep 28, 2019 11:21 am

Crash from "wine ./SETUP.EXE".

Post by peasthope » Sat Sep 28, 2019 11:41 am

Wine in Debian 10 here.

cd aDirectory ; wine ./SETUP.EXE
gave an immediate crash with backtrace http://easthope.ca/backtrace .

Tips?

Thanks, ... Peter E.

jkfloris
Level 6
Level 6
Posts: 658
Joined: Thu Aug 14, 2014 10:10 am

Re: Crash from "wine ./SETUP.EXE".

Post by jkfloris » Sun Sep 29, 2019 4:47 am

Is this a MSDOS application? Did you install dosbox?

Is there a free/ demo version to test the application?

peasthope
Newbie
Newbie
Posts: 4
Joined: Sat Sep 28, 2019 11:21 am

Re: Crash from "wine ./SETUP.EXE".

Post by peasthope » Sun Sep 29, 2019 9:07 am

Thanks for the reply.

The software is for Windows and came with a JVC camera.
I should have given this link also.
http://easthope.ca/JVC.KY-F.TWAINdiskette.jpg

... Peter E.

jkfloris
Level 6
Level 6
Posts: 658
Joined: Thu Aug 14, 2014 10:10 am

Re: Crash from "wine ./SETUP.EXE".

Post by jkfloris » Tue Oct 01, 2019 11:15 am

Windows drivers don't work with Wine. Does Debian recognize the camera?

peasthope
Newbie
Newbie
Posts: 4
Joined: Sat Sep 28, 2019 11:21 am

Re: Crash from "wine ./SETUP.EXE".

Post by peasthope » Fri Oct 11, 2019 3:33 pm

Yes, Debian recognizes the camera. Here is the output from hwinfo --scsi. Is recognition as a "Storage Device" acceptable? If so the next step would be to configure to also be available in Wine? Then try to configure the JVC software to access the pseudo-Windows device. Any further tips before I plow ahead?

Thanks, ... Peter E.

20: SCSI 06.0: 10680 Storage Device
[Created at scsi.1783]
Unique ID: olmp.0cgEuxP19dC
Parent ID: oxTw.8Wc+vtM+OBC
SysFS ID: /class/scsi_generic/sg2
SysFS BusID: 0:0:6:0
Hardware Class: unknown
Model: "JVC KY-F70"
Vendor: "JVC"
Device: "KY-F70"
Revision: "1.00"
Driver: "advansys"
Driver Modules: "advansys", "advansys"
Device File: /dev/sg2
Device Number: char 21:2
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #10 (SCSI storage controller)

== no further output from hwinfo ==

peasthope
Newbie
Newbie
Posts: 4
Joined: Sat Sep 28, 2019 11:21 am

Re: Crash from "wine ./SETUP.EXE".

Post by peasthope » Fri Oct 11, 2019 5:57 pm

A few additional points.

According to hwinfo, the camera is character device /dev/sg2. Must it be mounted in Linux
before Wine can access it? For linux to mount sg2, a driver will be necessary; correct?

Thanks, ... Peter E.

jkfloris
Level 6
Level 6
Posts: 658
Joined: Thu Aug 14, 2014 10:10 am

Re: Crash from "wine ./SETUP.EXE".

Post by jkfloris » Sat Oct 12, 2019 2:47 pm

Must it be mounted in Linux before Wine can access it?
Yes. First try to mount the device on Debian.
Unfortunately, I don't have any experience with SCSI devices.

Post Reply