The 32bit part of the wow64 wine wont build anymore ..:/

Questions about Wine on Linux
Post Reply
User avatar
rawfox
Level 3
Level 3
Posts: 53
Joined: Tue Oct 05, 2010 10:59 am

The 32bit part of the wow64 wine wont build anymore ..:/

Post by rawfox » Sat Sep 21, 2019 4:19 am

Hey^^

Me fears something broke here, since two or three weeks my winebuild is not building the 32bit part correct.
Im getting this error message, when its compiling:

Code: Select all

configure: WARNING: gtk/gtk.h: present but cannot be compiled
configure: WARNING: gtk/gtk.h:     check for missing prerequisite headers?
configure: WARNING: gtk/gtk.h: see the Autoconf documentation
configure: WARNING: gtk/gtk.h:     section "Present But Cannot Be Compiled"
configure: WARNING: gtk/gtk.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to wine-devel@winehq.org ##
configure: WARNING:     ## ------------------------------------ ##
I think i messed up some dependencies, but i can not remember exacly, what i broke.
On a Ubuntu VM i can build the wow64 wine build without errors (using the VM to build Lutris runners), so i assume its my local installation.

Im looking for a concept how to solve that issue.
I could solve a similar issue before by installing missing dependencies, but now i have no idea wich one is missing.

Any idea how i should engange this ?
Ive read the logs and thelike, can not find the thing thats missing ...

User avatar
DarkShadow44
Level 7
Level 7
Posts: 917
Joined: Tue Nov 22, 2016 5:39 pm

Re: The 32bit part of the wow64 wine wont build anymore ..:/

Post by DarkShadow44 » Sat Sep 21, 2019 6:35 am

There should be a config.log with more information.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2762
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: The 32bit part of the wow64 wine wont build anymore ..:/

Post by Bob Wya » Sat Sep 21, 2019 10:26 am

@rawfox

Just pass:

Code: Select all

--without-gtk3
as a Wine configuration parameter.

The Wine Staging Gtk 3 theming support is pretty broken anyway (I usually disable it).

Bob

User avatar
rawfox
Level 3
Level 3
Posts: 53
Joined: Tue Oct 05, 2010 10:59 am

Re: The 32bit part of the wow64 wine wont build anymore ..:/

Post by rawfox » Sat Sep 21, 2019 4:21 pm

Well, thanks for input :)
The config.log aint gave me anything.
Error 2
exit
When i disabled the gtk support, i ran into another issue, there was some error with libavi.dllsomenumber and that was the missing hint, because that was build already.
So i deleted my ~/.ccache/* because there is the precompiled and unchanged stuff waiting, et viola its building again :D
Obviously something broke in the cache, because im building wine pretty often and had a hardware upgrade couple days ago^^

Before i had a fx8150 with 26gb DDR3 @1600 and built a full uncached wine in ~50mins.
Now im on a Ryzon 2700x with 32gb DDR4 @3200 and the buildtime is down to 16mins.

So i can confuse my .ccache even more now :D

Thanks for your support, guys

\m/

Kahenraz
Level 1
Level 1
Posts: 7
Joined: Mon Sep 23, 2019 11:52 pm

Re: The 32bit part of the wow64 wine wont build anymore ..:/

Post by Kahenraz » Tue Sep 24, 2019 12:05 am

If WINE builds with make, try padding -j to parallelize the build and see how fast it goes. ;)

User avatar
rawfox
Level 3
Level 3
Posts: 53
Joined: Tue Oct 05, 2010 10:59 am

Re: The 32bit part of the wow64 wine wont build anymore ..:/

Post by rawfox » Sat Sep 28, 2019 6:07 am

Kahenraz wrote:
Tue Sep 24, 2019 12:05 am
If WINE builds with make, try padding -j to parallelize the build and see how fast it goes. ;)
yeah, doing that since forever :D

My old fx8150 could not compile on all 8 threads due to overheating, even with a watercooler.
The temperature while building was barely over 55°C, using only 6 threads (-j6).

With the new Ryzon 2700x i learned about the teperatures are a bit higher.
While the fx8150 had an idle temp of ~7°C, it was on full load "only" ~55°C.
The Ryzon has a idle temp of ~30°C and is on full load at ~65°C, i found that a lot, but people told me its because the 7nm architecture.

For now i build wine on 8 threads (-j8) with the Ryzon and the temp is at ~55°C with that.
Im just afraid on getting the temp higher. I also never use hardware spanking software like benchmark / performance testwares or overclocking features.
The reason for that is, i once did that on a new rig, i literally saw the hardware aging, i.e. the paste btw CPU and coolerbody got out to the sides and was toned brown ... ugly. The whole thing looked "old" within 10 minutes.

The times mentioned above are valid for a full uncached wine wow64 build, so its 2 builds, one for 32bit and one for 64bit.

But thanks for mentioning the -j option in the make call, more people should use it, i totally agree^^

Post Reply