Could not install wine stable on debian 9

Questions about Wine on Linux
Post Reply
tobasium
Newbie
Newbie
Posts: 4
Joined: Mon Sep 02, 2019 4:44 pm

Could not install wine stable on debian 9

Post by tobasium » Mon Sep 02, 2019 4:50 pm

Hello Team,

I have a problem with wine if i want to install it i get problems:

Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
winehq-stable : Hängt ab von: wine-stable (= 4.0.2~stretch)

Some packages could not be installed. That may mean that
You have requested an impossible situation or if you have the
Unstable distribution still use some required packages
have not been created or have not yet left Incoming.
The following information may help you to resolve the situation:

The following packages have unmet dependencies:
winehq-stable: Depends on: wine-stable (= 4.0.2 ~ stretch)

Could not find out where the problem is. Could someone help me to find the issue.

I do exactly this: https://wiki.winehq.org/Debian

User avatar
dimesio
Moderator
Moderator
Posts: 12657
Joined: Tue Mar 25, 2008 10:30 pm

Re: Could not install wine stable on debian 9

Post by dimesio » Tue Sep 03, 2019 6:16 am

The way to solve dependency issues is to work your way backwards. Try installing wine-stable, see what apt complains about, and try installing that. Repeat until you get to whatever is blocking the install.

tobasium
Newbie
Newbie
Posts: 4
Joined: Mon Sep 02, 2019 4:44 pm

Re: Could not install wine stable on debian 9

Post by tobasium » Tue Sep 03, 2019 7:04 am

Hello,

i could not fix the issue here are some Problems I found:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
libxml2 : Beschädigt: libxml2:i386 (!= 2.9.9+dfsg-1+0~20190828.2+debian9~1.gbp28a022) aber 2.9.4+dfsg1-2.2+deb9u2 soll installiert werden
libxml2:i386 : Beschädigt: libxml2 (!= 2.9.4+dfsg1-2.2+deb9u2) aber 2.9.9+dfsg-1+0~20190828.2+debian9~1.gbp28a022 soll installiert werden

did not know how to fix the issue.

The Problem is since the last update of wine before all was good

tobasium
Newbie
Newbie
Posts: 4
Joined: Mon Sep 02, 2019 4:44 pm

Re: Could not install wine stable on debian 9

Post by tobasium » Tue Sep 03, 2019 7:58 am

Hello Team,

i don't know what to do at the moment i get this problem. Somebody can help me?ß

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
libxml2 : Beschädigt: libxml2:i386 (!= 2.9.9+dfsg-1+0~20190828.2+debian9~1.gbp28a022) aber 2.9.4+dfsg1-2.2+deb9u2 soll installiert werden
libxml2:i386 : Beschädigt: libxml2 (!= 2.9.4+dfsg1-2.2+deb9u2) aber 2.9.9+dfsg-1+0~20190828.2+debian9~1.gbp28a022 soll installiert werden
N: Datei »mariadb.list.old_1« in Verzeichnis »/etc/apt/sources.list.d/« wird ignoriert, da sie eine ungültige Dateinamen-Erweiterung hat.
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.

User avatar
dimesio
Moderator
Moderator
Posts: 12657
Joined: Tue Mar 25, 2008 10:30 pm

Re: Could not install wine stable on debian 9

Post by dimesio » Wed Sep 04, 2019 7:34 am

Running your console output through Google translate:

Code: Select all

The following packages have unmet dependencies:
libxml2: Corrupted: libxml2: i386 (! = 2.9.9 + dfsg-1 + 0 ~ 20190828.2 + debian9 ~ 1.gbp28a022) but 2.9.4 + dfsg1-2.2 + deb9u2 should be installed
libxml2: i386: Corrupted: libxml2 (! = 2.9.4 + dfsg1-2.2 + deb9u2) but 2.9.9 + dfsg-1 + 0 ~ 20190828.2 + debian9 ~ 1.gbp28a022 is supposed to be installed
Apt requires the i386 version of a package be exactly the same version as the amd64 package. You have a mismatch between the two for libxml2. You need to change either the i386 version or the amd64 version to match the other package.

tobasium
Newbie
Newbie
Posts: 4
Joined: Mon Sep 02, 2019 4:44 pm

Re: Could not install wine stable on debian 9

Post by tobasium » Wed Sep 04, 2019 9:12 am

Hi,

I don't know how to change the version. Somebody can help?

jkfloris
Level 6
Level 6
Posts: 619
Joined: Thu Aug 14, 2014 10:10 am

Re: Could not install wine stable on debian 9

Post by jkfloris » Wed Sep 04, 2019 9:32 am

The official Debian version of libxml2 is 2.9.4, so this version should be in your repository. You could install this version with:

Code: Select all

sudo apt install libxml2=2.9.4+dfsg1-2.2+deb9u2 libxml2:i386=2.9.4+dfsg1-2.2+deb9u2

Post Reply