Install last Winehq develop on Linux Mint 19.2_x64 Cinnamom

Questions about Wine on Linux
Post Reply
Codesound
Level 2
Level 2
Posts: 15
Joined: Sun Sep 01, 2019 7:03 am

Install last Winehq develop on Linux Mint 19.2_x64 Cinnamom

Post by Codesound » Sun Sep 01, 2019 11:44 am

Hi,

I would like to install the latest Develop version of WineHQ but I don't understand how to make it...

These are the steps that I follow to install wineHQ stable version:

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt install --install-recommends winehq-stable

what are the steps to install latest develop version(4.15)?

thanks for now... :wink:

R

dundir
Level 1
Level 1
Posts: 8
Joined: Sat Jul 20, 2019 2:47 am

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by dundir » Sun Sep 01, 2019 10:56 pm

The current development build is not packaged.

You would need to build it and I'm currently doing the same but haven't yet completed the project (I'm about a week into it at this point).

Building the project from scratch is very difficult if you haven't had much experience working with compilers, linking, or both autotools and cmake build systems, or pkg-config.

There are at least two main dependencies which are not packaged by ubuntu distros in the currently required version (vkd3d and osmesa).

vkd3d will need libvulkan, spir-v and vulkan headers. libvulkan will need at least 1.1.113, current libvulkan package available is v1.1.70.
libvkd3d will also require both the spir-v and vulkan headers.

I just finished building and packaging libvulkan 1.1.121 for personal use so if you have trouble with that I can help.

If you'd like to compare notes/tips/tricks or just have questions I'm more frequently on reddit (same username), so you can direct message me there.

jkfloris
Level 6
Level 6
Posts: 619
Joined: Thu Aug 14, 2014 10:10 am

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by jkfloris » Mon Sep 02, 2019 4:21 am

what are the steps to install latest develop version(4.15)?
Replace the last step with:

Code: Select all

sudo apt install --install-recommends winehq-devel

Codesound
Level 2
Level 2
Posts: 15
Joined: Sun Sep 01, 2019 7:03 am

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by Codesound » Mon Sep 02, 2019 11:09 am

Hi,

thanks for your response.... :shock:

I believe that I remain on last stable version of wine because in the last command that I write in the terminal:
Replace the last step with:

Code: Select all

sudo apt install --install-recommends winehq-devel
the terminal gives me this error output:

Code: Select all

kernel@kernel:~$ sudo apt install --install-recommends winehq-devel
[sudo] password for kernel:           
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 winehq-devel : Depends: wine-devel (= 4.15~bionic)
E: Unable to correct problems, you have held broken packages.
thanks for now guys..... :(

User avatar
dimesio
Moderator
Moderator
Posts: 12657
Joined: Tue Mar 25, 2008 10:30 pm

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by dimesio » Mon Sep 02, 2019 4:35 pm


Codesound
Level 2
Level 2
Posts: 15
Joined: Sun Sep 01, 2019 7:03 am

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by Codesound » Thu Sep 05, 2019 3:01 pm

Hi,

I tryed some times to install wine-develop but with no results.... I don't understand how to install it. I read the posts you gave me and I tried to make a new list of operations to follow from a reset situation:

DOWNLOAD THE RELEASE KEY:
viewtopic.php?f=8&t=32192
Navigate to the directory you downloaded it to and install it with
sudo apt-key add Release.key
Add the repository:
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
Update:
sudo apt update
Install unmet dependence: faudio
sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport
Install wine:
sudo apt install --install-recommends winehq-devel

what I wrong? THANKS!

jkfloris
Level 6
Level 6
Posts: 619
Joined: Thu Aug 14, 2014 10:10 am

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by jkfloris » Fri Sep 06, 2019 12:11 pm

what I wrong? THANKS!
What is the output of

Code: Select all

sudo apt install --install-recommends winehq-devel
Did you run

Code: Select all

sudo apt update
after you add the ppa?

Codesound
Level 2
Level 2
Posts: 15
Joined: Sun Sep 01, 2019 7:03 am

Re: Install last Winehq develop on Linux Mint 19.2_x64 Cinna

Post by Codesound » Fri Sep 06, 2019 2:52 pm

Hi,

I'm stupid.... :roll:

this is the command list that I used:

Code: Select all

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt upgrade
sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport
sudo apt update
sudo apt upgrade
sudo apt install --install-recommends winehq-devel
All works fine!

THANKS again for all your precious support!!!!!

R

Post Reply