Newsleecher (2019) at startup splashscreen hidden

Questions about Wine on Linux
Post Reply
maximilian1st
Newbie
Newbie
Posts: 4
Joined: Tue Jun 04, 2019 6:04 am

Newsleecher (2019) at startup splashscreen hidden

Post by maximilian1st » Sat Aug 17, 2019 12:35 pm

Hi all,
I try launching NewsLeecher after installing it on an Ubuntu 18.04.3 with Wine 4.14 devel but the initial splash screen remains hidden and the console has these messages:

~$ wine .wine/drive_c/Program\ Files\ \(x86\)/NewsLeecher/NewsLeecher.exe
0009:fixme:thread:GetThreadUILanguage : stub, returning default language.
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x34d7f4, (nil) 0x34d81c
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x34d7f4 (nil) 0x34d81c) returning a dummy value (current locale)
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x34d7f4, 0x169a680 0x34d81c
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x34d7f4 0x169a680 0x34d81c) returning a dummy value (current locale)
0009:fixme:wtsapi:WTSRegisterSessionNotification Stub 0001007E 0x00000000
0009:fixme:uxtheme:BufferedPaintInit Stub ()
0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0009:fixme:shell:FileIconInit (true)
0009:fixme:shell:SHGetKnownFolderIDList unsupported flags: 0x00001000
0009:fixme:shell:SHGetKnownFolderIDList unsupported flags: 0x00001000
0009:fixme:shell:SHGetKnownFolderIDList unsupported flags: 0x00001000
0009:fixme:d2d:d2d_factory_init Ignoring factory type 0x1.
0009:fixme:dwmapi:DwmIsCompositionEnabled 0034F7E8
0009:err:seh:setup_exception_record stack overflow 1644 bytes in thread 0009 eip 7bca9543 esp 00250cc4 stack 0x250000-0x251000-0x350000
^[
^C002b:fixme:console:CONSOLE_DefaultHandler Terminating process 8 on event 0

Does someone read something that could be helpful? Should it be launched with more verbose output to help out? It used to work 2 years ago. Any help would be appreciated.

Thanks,
Max.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2818
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Newsleecher (2019) at startup splashscreen hidden

Post by Bob Wya » Sat Aug 17, 2019 3:46 pm

@maximilian1st

I presume you are testing the Newsleecher 8.0 Beta 1 release?

That's not a reliable way to start Windows applications with Wine.
You'd want something like:

Code: Select all

wine start 'C:\Program Files (x86)\NewsLeecher\NewsLeecher.exe'
See: Wine User's Guide: 3 Using Wine.

Maybe a Wine terminal log with:

Code: Select all

export WINEDEBUG=+timestamp,+tid,+loaddll,+module,+seh
would be more helpful?

Please see: WineHQ FAQ: 10.1.1 How can I get a debugging log (a.k.a. terminal output)?
- for the correct (/easier) way to get a Wine terminal log.

Also please, in future, use the forum Code tags:

Code: Select all

...
- when posting terminal commands and output inline.

Update
:
FYI I got the application running with:

Code: Select all

wine reg.exe ADD "HKEY_CURRENT_USER\Software\Wine\DllOverrides" "/v" "dxgi" "/t" "REG_SZ" "/d" ""
winetricks winxp
using a 64-bit WINEPREFIX, and Wine (or Wine Staging) 4.14

For some reason the application is trying to load DirectX 10 / 11 libraries (why on earth??)

Thanks
Bob

User avatar
DarkShadow44
Level 7
Level 7
Posts: 984
Joined: Tue Nov 22, 2016 5:39 pm

Re: Newsleecher (2019) at startup splashscreen hidden

Post by DarkShadow44 » Sat Aug 17, 2019 5:19 pm

Bob Wya wrote:For some reason the application is trying to load DirectX 10 / 11 libraries (why on earth??)
It's not too uncommon anymore for applications to use DirectX to render their UI, sadly.

Do we have a bugreport for that issue already?

User avatar
Bob Wya
Level 12
Level 12
Posts: 2818
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Newsleecher (2019) at startup splashscreen hidden

Post by Bob Wya » Sun Aug 18, 2019 9:14 am

DarkShadow44 wrote:...
Do we have a bugreport for that issue yet?
Your wish is my command: Bug 47638 - Newsleecher 8.0 Beta 1 - will not start with win7+dxgi enabled (workaround as winxp).
8)

Bob

maximilian1st
Newbie
Newbie
Posts: 4
Joined: Tue Jun 04, 2019 6:04 am

Re: Newsleecher (2019) at startup splashscreen hidden

Post by maximilian1st » Wed Aug 21, 2019 2:04 am

Hi,

thank you very much for your help, using your magic command lines I can start Newsleecher 8 beta 1, version 5 final and 7 final. I used all of them for a while and can confirm that all functions work as they did in wine 1.6 and 1.7. I will have a look at the app db and see if I can add some test results for the current stable wine.

I hope you can sort out this bug so that the app will work with no "trick" in the future.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2818
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Newsleecher (2019) at startup splashscreen hidden

Post by Bob Wya » Wed Aug 21, 2019 5:11 pm

maximilian1st wrote:Hi,

thank you very much for your help, using your magic command lines I can start Newsleecher 8 beta 1, version 5 final and 7 final. I used all of them for a while and can confirm that all functions work as they did in wine 1.6 and 1.7. I will have a look at the app db and see if I can add some test results for the current stable wine.

I hope you can sort out this bug so that the app will work with no "trick" in the future.
No worries. 8)

The bug, I raised, is the mechanism to document the path to finding a fix for the application. So it works OTTB. Any Wine developer can pick up this work.

Bob

maximilian1st
Newbie
Newbie
Posts: 4
Joined: Tue Jun 04, 2019 6:04 am

Re: Newsleecher (2019) at startup splashscreen hidden

Post by maximilian1st » Tue Feb 04, 2020 3:44 pm

Thank you for your input, it worked like a charm until wine 5.0 was released as a stable version. It does not start anymore and shows a crash window unfortunately. This is the normal log I get when starting the app:

Code: Select all

002b:fixme:wtsapi:WTSRegisterSessionNotification Stub 00010078 0x00000000
002b:err:module:import_dll Library dxgi.dll (which is needed by L"C:\\windows\\system32\\d3d10_1.dll") not found
002b:err:module:import_dll Library dxgi.dll (which is needed by L"C:\\windows\\system32\\D3D11.DLL") not found
002b:err:module:import_dll Library D3D11.DLL (which is needed by L"C:\\windows\\system32\\d3d10_1.dll") not found
002b:err:module:import_dll Library d3d10_1.dll (which is needed by L"C:\\windows\\system32\\d2d1.dll") not found
002b:fixme:wtsapi:WTSUnRegisterSessionNotification Stub 00010078
wine: Unhandled page fault on read access to 01758D28 at address 00408E26 (thread 002b), starting debugger...
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
002d:fixme:dbghelp:elf_search_auxv can't find symbol in module
The extended log, recorded in a file using the following command line as expressed above is about 3.5MB and I'm not sure I should post it here.

Code: Select all

export WINEDEBUG=+timestamp,+tid,+loaddll,+module,+seh
In the meantime I will google my way to installing and keeping an older version of wine 4.20.

I'll gladly help if I can.

User avatar
Bob Wya
Level 12
Level 12
Posts: 2818
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Newsleecher (2019) at startup splashscreen hidden

Post by Bob Wya » Wed Feb 05, 2020 5:17 am

@maximilian1st

That's odd... My Newsleecher 64-bit WINEPREFIX with Newsleecher 8.0 Beta 1 still works OK, with Wine 5.1
I still need to use Windows XP and dxgi disabled.

I/ we can't really comment further, on your issues, without access to the "full" terminal log...
You could attach that to my existing bug report, I guess.

Bob

maximilian1st
Newbie
Newbie
Posts: 4
Joined: Tue Jun 04, 2019 6:04 am

Re: Newsleecher (2019) at startup splashscreen hidden

Post by maximilian1st » Mon Feb 10, 2020 3:11 pm

Hi Bob,

thank you for the info that it works for you and it probably would here too but I got into a dependency problem with wine and deleted it completely and it won't install anymore even after trying many of the solutions found online. I am fed up hahahaha. Really. I spent way too much time trying to get it to work. I guess I will just wait for ubuntu 20.04 and hope it will just install out of the box.

Keep on coding ;-)
Max.

Post Reply