Can't get wine to work

Questions about Wine on Linux
Post Reply
SolusUmbra
Newbie
Newbie
Posts: 4
Joined: Wed Aug 07, 2019 10:39 am

Can't get wine to work

Post by SolusUmbra » Wed Aug 07, 2019 10:42 am

I've tried installing wine on Linux Mint Cinnamon 19.1 and I keep getting errors when trying to run winecfg

Code: Select all

0009:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0010:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0010:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0010:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0010:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0010:err:ole:get_local_server_stream Failed: 80004002
0013:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
I'm not sure what to do as I'm pretty new to Linux. Thanks

jkfloris
Level 6
Level 6
Posts: 704
Joined: Thu Aug 14, 2014 10:10 am

Re: Can't get wine to work

Post by jkfloris » Thu Aug 08, 2019 8:30 am

How did you install Wine?
Do you get the same error if you create a clean Wineprefix?

Code: Select all

WINEPREFIX=~/Wine-test winecfg

SolusUmbra
Newbie
Newbie
Posts: 4
Joined: Wed Aug 07, 2019 10:39 am

Re: Can't get wine to work

Post by SolusUmbra » Thu Aug 08, 2019 9:40 am

Yes I’ve removed wine (as best I can) several times and tried reinstalling from terminal and the package manager but still get the same errors. I do still get this don’t know if it also needs to be removed or not.

Code: Select all

$ dpkg -l | grep wine
rc wine-desktop-files 4.0.5 all Microsoft Windows Compatibility Layer

User avatar
Bob Wya
Level 12
Level 12
Posts: 2778
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Can't get wine to work

Post by Bob Wya » Thu Aug 08, 2019 10:01 am

SolusUmbra wrote:...
I'm not sure what to do as I'm pretty new to Linux. Thanks
You seem to have forgotten to state the version of Wine, you are running!! :shock:

Code: Select all

wine --version
The less information you give...
The less likely you are to get any help... :cry:

Bob

SolusUmbra
Newbie
Newbie
Posts: 4
Joined: Wed Aug 07, 2019 10:39 am

Re: Can't get wine to work

Post by SolusUmbra » Thu Aug 08, 2019 10:46 am

Bob Wya wrote:
SolusUmbra wrote:...
I'm not sure what to do as I'm pretty new to Linux. Thanks
You seem to have forgotten to state the version of Wine, you are running!! :shock:

Code: Select all

wine --version
The less information you give...
The less likely you are to get any help... :cry:

Bob

Thank you for the note, wine is 4.0

jkfloris
Level 6
Level 6
Posts: 704
Joined: Thu Aug 14, 2014 10:10 am

Re: Can't get wine to work

Post by jkfloris » Fri Aug 09, 2019 11:27 am

@SolusUmbra
I do still get this don’t know if it also needs to be removed or not
You don't have to remove that package, but is that the only output of dpkg -l | grep wine?
There should be more packages.

Did you tried to remove the default Wineprefix and run winecfg again?

Code: Select all

rm -rf $HOME/.wine
winecfg

SolusUmbra
Newbie
Newbie
Posts: 4
Joined: Wed Aug 07, 2019 10:39 am

Re: Can't get wine to work

Post by SolusUmbra » Fri Aug 09, 2019 1:22 pm

When I had posted on the Linux site they had told me to completely remove wine before trying to reinstall so I’m in the process of trying that for the 5th time and haven’t reinstalled yet which most likely why that one program is the only one listed. My mom (who’s computer I’m trying to get set up) is gone until Sunday so I can’t try out anything until she gets back (driving me nuts). Please keep the information and ideas coming so I can try out everything I can.

Post Reply