FAudio Package problem while installing Wine

Questions about Wine on Linux
Post Reply
linuine
Newbie
Newbie
Posts: 1
Joined: Mon Aug 05, 2019 6:26 pm

FAudio Package problem while installing Wine

Post by linuine » Mon Aug 05, 2019 6:44 pm

Hi everyone :)
I am a Linux Mint 19.2 Cinnamon user
I've newly installed the system and i face a problem while installing wine
I added the 19.X repository and everything went great but at installing the staging version of wine

Code: Select all

 sudo apt install --install-recommends winehq-staging 
the output was:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-staging : Depends: wine-staging (= 4.13~bionic)
E: Unable to correct problems, you have held broken packages.
i tried to see the missing packages using

Code: Select all

apt-get install wine-staging-i386
and that was the output:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libfaudio0:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.
I downloaded the package but then after execution it appeared that more packages are in need to be installed

Code: Select all

The following packages have unmet dependencies:
 libfaudio0:i386 : Depends: libavcodec58:i386 (>= 7:4.0) but it is not installable
                   Depends: libavutil56:i386 (>= 7:4.0) but it is not installable
                   Depends: libsdl2-2.0-0:i386 (>= 2.0.9) but it is not going to be installed
                   Depends: libstb0:i386 (>= 0.0~git20180212.15.e6afb9c) but it is not installable
and with every package of this 4 I download it appears more packages need to be installed and they are not installable (can't use apt to install them)
so if there any repository need to be added or is there something wrong I am doing please notify me
thanks in advance :D

User avatar
dimesio
Moderator
Moderator
Posts: 12677
Joined: Tue Mar 25, 2008 10:30 pm

Re: FAudio Package problem while installing Wine

Post by dimesio » Tue Aug 06, 2019 6:35 am

linuine wrote:Hi everyone :)
I added the 19.X repository and everything went great but at installing the staging version of wine
Exactly which repository did you add? Mint 19.x is based on Ubuntu 18.04 (bionic), so that's the repository you should have added.

Code: Select all

The following packages have unmet dependencies:
 libfaudio0:i386 : Depends: libavcodec58:i386 (>= 7:4.0) but it is not installable
                   Depends: libavutil56:i386 (>= 7:4.0) but it is not installable
                   Depends: libsdl2-2.0-0:i386 (>= 2.0.9) but it is not going to be installed
                   Depends: libstb0:i386 (>= 0.0~git20180212.15.e6afb9c) but it is not installable
Those versions of libavcodec, libavutil, and libsdl2 are newer than what bionic provides, and bionic does not provide libstb at all. The fact that you are seeing those suggests either that you did add the wrong repository for Mint, or that you are using FAudio packages from an unofficial PPA, built against newer libraries, rather than the OBS. If the former, remove the incorrect repository from your /etc/apt/sources.list and start over. If the latter, that's not supported here.

Post Reply