Wine 4.0.1 Regression? I can't use the CUEcards properly

Questions about Wine on Linux
Post Reply
squiffy
Level 1
Level 1
Posts: 7
Joined: Tue Oct 03, 2017 9:52 am

Wine 4.0.1 Regression? I can't use the CUEcards properly

Post by squiffy » Sun Jul 28, 2019 8:50 am

Hi,

I have been using CUEcards since 2012 under Linux/Wine. So far I had no problems. I installed two DLL via Winetricks and CUEcards ran fine. Since the update to Linux Mint 19.1 and Wine 4.0.1 the program crashes reproducibly when I switch between a folder and a flashcard in the internal file browser. This is also true for CUEcards 2000 (freeware) and, not to the same extent, also for the CCReader, which is also free

(This is a copied post from the thread Wine 3.0.5 install)
jkfloris wrote:If there is a regression between two Wine versions that is a bug and should be know by the Wine developers.
Okay. I've never done this before, but I'll try it. Do I have to set up a new account? My forum account does not work for the Wine HQ Bugzilla forum.
jkfloris wrote: @squiffy
Is this the program that you mean?
Both versions seems to run fine with wine 4-12.1
If you are still experiencing problems, create a new forum post.
Yes, that's the program. Also the reader, which is also free. It doesn't crash so easily but it also causes problems. I have been using the programs under Wine since 2012 and they have always worked. You had to install two DLLs over Winetricks and then it ran without problems. The program still works, but if you switch back and forth between folders and flashcards it crashes reproducibly.
Can you tell me how to install wine 4-12.1 on my system? 4.12.1 is a development version. Do I have to uninstall 4.0.1 first? Sorry for the questions, but I've never had to do anything like this before.

jkfloris
Level 6
Level 6
Posts: 692
Joined: Thu Aug 14, 2014 10:10 am

Re: Wine 4.0.1 Regression? I can't use the CUEcards properly

Post by jkfloris » Sun Jul 28, 2019 11:17 am

You could install Wine 4.12.1 with:

Code: Select all

sudo apt install --install-recommends wine-devel wine-devel-amd64 wine-devel-i386:i386
If you get a dependency error, you are probably missing the libfaudio packages.
You could download the deb packages from the OBS server:
64 bit package
32 bit package
And install them with:

Code: Select all

sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb libfaudio0_19.07-0~bionic_i386.deb
If everything goes well you could run wine 4.12.1 with:

Code: Select all

/opt/wine-devel/bin/wine program.exe

squiffy
Level 1
Level 1
Posts: 7
Joined: Tue Oct 03, 2017 9:52 am

Re: Wine 4.0.1 Regression? I can't use the CUEcards properly

Post by squiffy » Sun Jul 28, 2019 12:07 pm

jkfloris wrote:You could install Wine 4.12.1 with:
[...]
If everything goes well you could run wine 4.12.1 with:

Code: Select all

/opt/wine-devel/bin/wine program.exe
Thank you very much. I'll try that out.

squiffy
Level 1
Level 1
Posts: 7
Joined: Tue Oct 03, 2017 9:52 am

Re: Wine 4.0.1 Regression? I can't use the CUEcards properly

Post by squiffy » Sun Jul 28, 2019 1:56 pm

jkfloris wrote:You could install Wine 4.12.1 with...
Great! That worked. Under Wine 4.12.1 CUEcards runs again without problems. Many thanks for your help.

Post Reply