Dependency is not installable - winetricks:i386

Questions about Wine on Linux
Post Reply
beninja
Newbie
Newbie
Posts: 1
Joined: Sat Jul 27, 2019 11:18 am

Dependency is not installable - winetricks:i386

Post by beninja » Sat Jul 27, 2019 11:35 am

I have Debian 10 and downloaded the latest stable Wine.

When trying to install, I get the below:


Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
star-wars-galactic-battlegrounds:i386 : Depends: winetricks:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.


Running

Code: Select all

sudo apt-get -f install
does not help.

I am following this page https://wiki.dotslashplay.it/en/games/s ... tlegrounds and it's when I run step 4 this is occurring.

For Step 4), the terminal requests I run:

Code: Select all

Install "Star Wars: Galactic Battlegrounds" by running the following commands as root:
apt install /home/john/star-wars-galactic-battlegrounds_1.1-gog2.0.0.4+20190224.1_i386.deb /home/john/star-wars-galactic-battlegrounds-l10n-en_1.1-gog2.0.0.4+20190224.1_all.deb /home/john/star-wars-galactic-battlegrounds-data_1.1-gog2.0.0.4+20190224.1_all.deb
Running all together I get the above message. When I run individually, the first (with i186 in the name) fails, second and third look like they have worked.

It looks like winetricks:i386 is no longer available, but is needed. Does anyone know how to solve this? Thanks in advance.


Post Reply