WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 3 posts ] 



 
Author Message
 Post Posted: Wed Jul 17, 2019 9:11 pm 
Offline
Level 1
Level 1

Joined: Mon Jul 15, 2019 7:13 am
Posts: 6
Hi, everyone.
I am running wine 4.0 on ubuntu 14.04 and I have installed libgnutls.
But when I run some *.exe files with wine, I always get the error that "gnutls_initialize failed to load libgnutls, no support for encryption".
I have searched on the forum and found the following post
viewtopic.php?f=8&t=30962
viewtopic.php?f=8&t=25612
which indicate that I need the right version of libgnutls.
But how can I find the libgnutls version that wine 4.0 was complied with?


Top 
 Post Posted: Thu Jul 18, 2019 4:54 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 12642
The WineHQ 4.0 packages for 14.04 were compiled with libgnutls28. If you're using someone else's package, ask them.


Top 
 Post Posted: Fri Jul 19, 2019 6:44 am 
Offline
Level 1
Level 1

Joined: Mon Jul 15, 2019 7:13 am
Posts: 6
dimesio wrote:
The WineHQ 4.0 packages for 14.04 were compiled with libgnutls28. If you're using someone else's package, ask them.


Thank you!
Since the wine 4.0 performs bad on ubuntu 14.04, I have updated to 18.04 and the libgnutls error disappeared.
But another error comes with the log saying:
ERROR: ld.so: object 'libachk.so' from /etc/ld.so.preload cannot be preloaded (wrong ELF class: ELFCLASS64): ignored

How can I fix this error?


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 3 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 13 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: