libgnutls Version that wine was compiled with

Questions about Wine on Linux
Post Reply
qiaoyu9102
Level 1
Level 1
Posts: 6
Joined: Mon Jul 15, 2019 7:13 am

libgnutls Version that wine was compiled with

Post by qiaoyu9102 » Wed Jul 17, 2019 9:11 pm

Hi, everyone.
I am running wine 4.0 on ubuntu 14.04 and I have installed libgnutls.
But when I run some *.exe files with wine, I always get the error that "gnutls_initialize failed to load libgnutls, no support for encryption".
I have searched on the forum and found the following post
viewtopic.php?f=8&t=30962
viewtopic.php?f=8&t=25612
which indicate that I need the right version of libgnutls.
But how can I find the libgnutls version that wine 4.0 was complied with?

User avatar
dimesio
Moderator
Moderator
Posts: 12677
Joined: Tue Mar 25, 2008 10:30 pm

Re: libgnutls Version that wine was compiled with

Post by dimesio » Thu Jul 18, 2019 4:54 pm

The WineHQ 4.0 packages for 14.04 were compiled with libgnutls28. If you're using someone else's package, ask them.

qiaoyu9102
Level 1
Level 1
Posts: 6
Joined: Mon Jul 15, 2019 7:13 am

Re: libgnutls Version that wine was compiled with

Post by qiaoyu9102 » Fri Jul 19, 2019 6:44 am

dimesio wrote:The WineHQ 4.0 packages for 14.04 were compiled with libgnutls28. If you're using someone else's package, ask them.
Thank you!
Since the wine 4.0 performs bad on ubuntu 14.04, I have updated to 18.04 and the libgnutls error disappeared.
But another error comes with the log saying:
ERROR: ld.so: object 'libachk.so' from /etc/ld.so.preload cannot be preloaded (wrong ELF class: ELFCLASS64): ignored

How can I fix this error?

Post Reply