Ubuntu 18.04. winehq-stable broken dependencies

Questions about Wine on Linux
Post Reply
User avatar
strannick_ru
Newbie
Newbie
Posts: 3
Joined: Wed Jul 03, 2019 1:55 pm
Location: Russia

Ubuntu 18.04. winehq-stable broken dependencies

Post by strannick_ru » Wed Jul 03, 2019 2:07 pm

Hello.
I was trying to install winehq-stable.
So, I show you, what I doing step by step:

Code: Select all

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'


sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 4.0.1~bionic)
E: Unable to correct problems, you have held broken packages.


sudo apt install --install-recommends wine-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-i386 (= 4.0.1~bionic)
E: Unable to correct problems, you have held broken packages.


sudo apt install --install-recommends wine-stable-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable-i386:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                         Recommends: libcups2:i386 but it is not going to be installed
                         Recommends: libgnutls30:i386 but it is not going to be installed or
                                     libgnutls28:i386 but it is not installable or
                                     libgnutls26:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.
So, I was trying to find libldap-2.4-2:i386 (>= 2.4.7), but if you see here → https://reposcope.com/package/libldap-2.4-2
libldap-2.4-2 2.4.47 is latest version.

I think it is a mistake in dependencies.
Or, please, tell me, where I can find libldap-2.4-2:i386 (>= 2.4.7) ?

User avatar
dimesio
Moderator
Moderator
Posts: 12689
Joined: Tue Mar 25, 2008 10:30 pm

Re: Ubuntu 18.04. winehq-stable broken dependencies

Post by dimesio » Thu Jul 04, 2019 6:34 am

strannick_ru wrote:So, I was trying to find libldap-2.4-2:i386 (>= 2.4.7), but if you see here → https://reposcope.com/package/libldap-2.4-2
libldap-2.4-2 2.4.47 is latest version.

I think it is a mistake in dependencies.
Or, please, tell me, where I can find libldap-2.4-2:i386 (>= 2.4.7) ?
First, the version of libldap available in the 18.04 repository is 2.4.45, not 2.4.47. Second, ">=" means "greater than or equal to"; 2.4.45 is greater than 2.4.7, so it should satisfy that dependency. However, apt requires that the i386 version of a package be exactly the same version as the AMD64 version. So the question is, what version of 64 bit libldap do you have installed? If it's not the same as the one in the main 18.04 repository, that's your problem.

User avatar
strannick_ru
Newbie
Newbie
Posts: 3
Joined: Wed Jul 03, 2019 1:55 pm
Location: Russia

Re: Ubuntu 18.04. winehq-stable broken dependencies

Post by strannick_ru » Sat Jul 06, 2019 2:46 pm

You're right.

But I have next question.
Look here, please:

Code: Select all

# apt install wine32
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 3.0-1ubuntu1) but it is not going to be installed
               Recommends: wine-stable:i386 (= 3.0-1ubuntu1)
E: Unable to correct problems, you have held broken packages.


# apt install libwine:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine:i386 : Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                Recommends: libcups2:i386 (>= 1.4.0) but it is not going to be installed
                Recommends: libgnutls30:i386 (>= 3.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


# apt install libldap-2.4-2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libldap-2.4-2:i386 : Depends: libgnutls30:i386 (>= 3.5.6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


# apt install libgnutls30:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgnutls30:i386 : Depends: libc6:i386 (>= 2.28) but 2.27-3ubuntu1 is to be installed
                    Depends: libp11-kit0:i386 (>= 0.23.11) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Version of libc6:i386 available in the 18.04 repository is 2.27
But wine32 need a 2.28

I don't know how to fix it.

User avatar
dimesio
Moderator
Moderator
Posts: 12689
Joined: Tue Mar 25, 2008 10:30 pm

Re: Ubuntu 18.04. winehq-stable broken dependencies

Post by dimesio » Sat Jul 06, 2019 4:09 pm

According to https://packages.ubuntu.com/bionic/libgnutls30, the libgnutls30 that is in the Ubuntu repository depends on libc6 >= 2.25, not 2.28 as apt is complaining. As to why apt is insisting on 2.28, I don't know. I suggest you take a look at what repositories you have installed; one possibility is that you have mistakenly added a repository for a newer version of Ubuntu; that can definitely mess up dependencies. Also look for third party PPAs, as they can mess up dependencies as well.

Wine is compiled against the libs in Ubuntu's standard, universe, and update repositories, and except for FAudio, which we provide, those repositories have all of Wine's direct dependencies, and should have the dependencies of those dependencies as well. If they don't, it should be reported to Ubuntu.

User avatar
strannick_ru
Newbie
Newbie
Posts: 3
Joined: Wed Jul 03, 2019 1:55 pm
Location: Russia

Re: Ubuntu 18.04. winehq-stable broken dependencies

Post by strannick_ru » Sun Jul 07, 2019 1:08 pm

You are right, problem was with ppa:starlabs/ppa
After purge it all works like a charm.

Thank you!

Post Reply