Alt key trouble: Ubuntu 16.04, Wine 4.11-Staging, WoW

Questions about Wine on Linux
Post Reply
Paul60
Newbie
Newbie
Posts: 1
Joined: Tue Jul 02, 2019 3:49 pm

Alt key trouble: Ubuntu 16.04, Wine 4.11-Staging, WoW

Post by Paul60 » Tue Jul 02, 2019 4:16 pm

I recently upgraded my OS and Wine at the same time. While playing World of Warcraft, I discovered that the Alt key does not work. Note that it does work normally outside of the game. In fact, Alt+Tab works in the game and outside. But Alt key-binds do not work in the game.

If I change from wine 4.11-Staging to 4.10-Staging, the Alt key works fine. But changing back to 4.1-Staging breaks it again. As an example, I have an action tied to the Alt-=. If I press Alt-=, nothing happens, not even the action for the = or Shift-= keys. I also noticed that I can change key-binds that use the Alt key, so the program does "see" that key sequence. But it doesn't do the action.

Any hints on how to debug this, or tie it to a known bug?

Machine environment: Dell Precision 7520 running Ubuntu 16.04 (4.4.0-154-generic). World of Warcraft 8.2.

el Arm
Newbie
Newbie
Posts: 1
Joined: Mon Nov 11, 2019 5:29 pm

Re: Alt key trouble: Ubuntu 16.04, Wine 4.11-Staging, WoW

Post by el Arm » Mon Nov 11, 2019 5:47 pm

I've got exactly the same problem through to staging 4.15 (and I think the latest 4.19 but can't recall). Alt was bringing up the HUD, like the super key. Even after removing this shortcut in unity it still doesn't work in World of Warcraft. For me wine 4.9 and 4.10 will not start the game, so I'm back at 4.8.

In terms of debugging could use the WINEDEBUG env var, e.g.

Code: Select all

env WINEDEBUG=trace+message wine64 "d:/Games/World of Warcraft/_retail_/Wow.exe"
That might produce keyboard events, then compare good and bad output. For me, I'm just sticking with 4.8 for now.

Post Reply