WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 5 posts ] 



 
Author Message
 Post Posted: Tue Jun 11, 2019 12:18 pm 
Offline
Newbie
Newbie

Joined: Tue Jun 11, 2019 12:03 pm
Posts: 2
Hi,

I am trying to install Wine on Linux 19.04, via this site. I follow all the steps all seems good until 'add the repository', of Ubuntu 19.04, and I get:

The following packages have unmet dependencies.
winehq-stable : Depends: wine-stable (= 4.0.1~disco)
E: Unable to correct problems, you have held broken packages.

I have no idea what it's getting at. I have attached an image of the terminal, for more information.

Any help would be appreciated.

Many thanks,

Victor


Attachments:
File comment: Error in Terminal
Screenshot from 2019-06-11 18-14-17.jpg
Screenshot from 2019-06-11 18-14-17.jpg [ 158.2 KiB | Viewed 260 times ]
Top 
 Post Posted: Wed Jun 12, 2019 2:11 am 
Offline
Level 4
Level 4

Joined: Fri Dec 01, 2017 5:26 pm
Posts: 168
There should be no huge reason to use the WineHQ package of wine-stable for Disco. They are both 4.0.1, and i imagine it COULD be some package conflicts between Ubuntu "wine-stable" and "wineHQ wine-stable" perhaps?


Top 
 Post Posted: Thu Jun 13, 2019 12:27 pm 
Offline
Newbie
Newbie

Joined: Tue Jun 11, 2019 12:03 pm
Posts: 2
Thanks for the response. Should I try and uninstalling Wine and start fresh?


Top 
 Post Posted: Sat Jun 15, 2019 11:26 am 
Offline
Level 6
Level 6

Joined: Thu Aug 14, 2014 10:10 am
Posts: 512
According to your screenshot(1), you are mixing two different Ubuntu versions (bionic and disco) this is not supported.
Do you have other repo's enabled?
Code:
grep -R '^deb' /etc/apt/sources.list*


(1) Please, copy and paste the text on the forum instead of a screenshot.


Top 
 Post Posted: Mon Jul 08, 2019 7:51 am 
Offline
Newbie
Newbie

Joined: Mon Jul 08, 2019 7:35 am
Posts: 1
I had the same issue and it turned out I had some amd64 packages in a different version than i386 was supposed to be installed and apparently they have to match exactly. I tracked them down by trying to install each blocked dependency until the leaf where I was either still blocked or apt wanted to remove half of my system. Flag --simulate was helpful. Also trying different package managers (apt, aptitude) as they can show different output. Then just dpkg -l | grep package and compare the version with apt show package:i386. After finding a culprit pin it to the Ubuntu repo in /etc/apt/preferences.d/wine like this:
Code:
Package: libgd3:amd64
Pin: origin archive.ubuntu.com
Pin-Priority: 1001

Package: libssl1.1:amd64
Pin: origin archive.ubuntu.com
Pin-Priority: 1001

and apt update; apt upgrade

In my case 2 libraries were installed from ppa:ondrej/php. After pinning them to Ubuntu they "downgraded" to the same versions their i386 alternatives were at and I was able to install Wine.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 5 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: Bing [Bot] and 18 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: