WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 9 posts ] 



 
Author Message
 Post Posted: Mon Jun 03, 2019 2:09 pm 
Offline
Level 1
Level 1

Joined: Mon Jun 03, 2019 2:02 pm
Posts: 5
I'm trying to run this TyranoBuilder-based game, but everytime I load it with wine, it gets stuck!

Here is a picture of the game (files):
https://prnt.sc/nx5ft6
https://prnt.sc/nx5gn8

Here's the command and what outputs:
https://pastebin.com/mPzaNMUw


Top 
 Post Posted: Tue Jun 04, 2019 1:43 am 
Offline
Level 3
Level 3

Joined: Sun Jan 17, 2016 4:36 pm
Posts: 95
Location: Eindhoven de gekste!
Hi, that`s probably bug https://bugs.winehq.org/show_bug.cgi?id=44985

Things you might try:

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 WINEDLLOVERRIDES=libglesv2.dll=d wine TeachingFeeling.exe

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --disable-gpu

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --no-sandbox

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --single-process

Or any combination of the above, use trial and error! Could you let us know if it works?


Top 
 Post Posted: Tue Jun 04, 2019 10:49 pm 
Offline
Level 1
Level 1

Joined: Mon Jun 03, 2019 2:02 pm
Posts: 5
qwertymnb wrote:
Hi, that`s probably bug https://bugs.winehq.org/show_bug.cgi?id=44985

Things you might try:

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 WINEDLLOVERRIDES=libglesv2.dll=d wine TeachingFeeling.exe

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --disable-gpu

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --no-sandbox

WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --single-process

Or any combination of the above, use trial and error! Could you let us know if it works?


Here's what I got:

Doesn't Work:
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 WINEDLLOVERRIDES=libglesv2.dll=d wine TeachingFeeling.exe
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --disable-gpu
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --no-sandbox
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe --single-process
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 wine TeachingFeeling.exe // default command
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 WINEDLLOVERRIDES=libglesv2.dll=d wine TeachingFeeling.exe --disable-gpu
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 WINEDLLOVERRIDES=libglesv2.dll=d wine TeachingFeeling.exe --disable-gpu --no-sandbox
WINEPREFIX=~/_prefix32_wine WINEARCH=win32 WINEDLLOVERRIDES=libglesv2.dll=d wine TeachingFeeling.exe --disable-gpu --no-sandbox --single-process

Does Work:

Nothing so far.

I'm assuming that running it on 32bit shouldn't affect anything- but none of those solutions work right now :/


Top 
 Post Posted: Wed Jun 05, 2019 9:48 am 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 464
Could you copy the "Life With A Slave - Teaching Feeling" directory inside the _prefix32_wine Wineprefix and try the dll override option again?


Top 
 Post Posted: Wed Jun 05, 2019 11:52 am 
Offline
Level 1
Level 1

Joined: Mon Jun 03, 2019 2:02 pm
Posts: 5
jkfloris wrote:
Could you copy the "Life With A Slave - Teaching Feeling" directory inside the _prefix32_wine Wineprefix and try the dll override option again?


https://prnt.sc/ny11pk
Just tried that, and with no luck. Assuming I did it right, but I'm not sure.


Top 
 Post Posted: Wed Jun 05, 2019 3:40 pm 
Offline
Level 5
Level 5

Joined: Thu Aug 14, 2014 10:10 am
Posts: 464
One part of your screenshot shows a directory inside the wineprefix
Code:
~/_prefix32_wine/drive_c/Program Files/Life With A Slave - Teaching Feeling

But in the terminal you are outside the prefix
Code:
~/Desktop/Games/Life With A Slave - Teaching Feeling


Could you try:
Code:
cd "~/_prefix32_wine/drive_c/Program Files/Life With A Slave - Teaching Feeling"
WINEDLLOVERRIDES=libglesv2.dll=d WINEPREFIX=~/_prefix32_wine wine TeachingFeeling.exe


Top 
 Post Posted: Wed Jun 05, 2019 6:44 pm 
Offline
Level 1
Level 1

Joined: Mon Jun 03, 2019 2:02 pm
Posts: 5
jkfloris wrote:
One part of your screenshot shows a directory inside the wineprefix
Code:
~/_prefix32_wine/drive_c/Program Files/Life With A Slave - Teaching Feeling

But in the terminal you are outside the prefix
Code:
~/Desktop/Games/Life With A Slave - Teaching Feeling


Could you try:
Code:
cd "~/_prefix32_wine/drive_c/Program Files/Life With A Slave - Teaching Feeling"
WINEDLLOVERRIDES=libglesv2.dll=d WINEPREFIX=~/_prefix32_wine wine TeachingFeeling.exe


Ah, I see. Well, I just tried that, and no luck there, either.
Here is the URL for the output from that in case it helps at all.


Top 
 Post Posted: Thu Jun 06, 2019 1:27 am 
Offline
Level 3
Level 3

Joined: Sun Jan 17, 2016 4:36 pm
Posts: 95
Location: Eindhoven de gekste!
If nothing works then might not be related to bug https://bugs.winehq.org/show_bug.cgi?id=44985

Last thing I to try/question: did you already do something like ``winetricks arial`` or ``winetricks corefonts``?


Top 
 Post Posted: Thu Jun 06, 2019 12:23 pm 
Offline
Level 1
Level 1

Joined: Mon Jun 03, 2019 2:02 pm
Posts: 5
Problem fixed! Here's what I did:

$ WINEPREFIX=~/prefix_name WINEARCH=win32 winetricks
> select the default wineprefix
> install a font
> select every font you can find
$ cp -r "/location/to/game/" "/prefix_name/drive_c/Program Files/"
$ cd "/prefix_name/drive_c/Program Files/game"
$ WINEPREFIX=~/prefix_name WINEARCH=win32 wine game.exe
Profit.

Thank you all so much for the help- it turns out all you need is the fonts. haha.


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 9 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 8 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: