wine-mono 4.8.3 fails to be installed

Questions about Wine on Linux
Post Reply
tosh
Newbie
Newbie
Posts: 4
Joined: Sun May 05, 2019 9:44 pm

wine-mono 4.8.3 fails to be installed

Post by tosh » Sun May 05, 2019 10:13 pm

Hello,

I am trying to install wine-mono 4.8.3 on a Debian 8 based system. When upgrading wine-devel to the latest 4.7, I was prompted to install the latest wine-mono package but after rather a long while I noticed the system had slowed down considerably. Finally, it became completely unresponsive and the installer got stuck.

Later, I tried again to manually install wine-mono 4.8.3 and started the msi installer but soon noticed the memory and swap was rapidly used up until the system got stuck and the installation failed again.

I had no problem with wine-devel 4.6 and wine-mono 4.8.1 before upgrading to wine-devel 4.7 and wine-mono 4.8.3 and actually still have no problem with wine-devel 4.7, though apparently the installation of wine-mono 4.8.3 failed. I would appreciate it if you could help me with this.

Best regards.

spoon0042
Level 4
Level 4
Posts: 173
Joined: Thu Dec 24, 2009 11:00 am

Re: wine-mono 4.8.3 fails to be installed

Post by spoon0042 » Mon May 06, 2019 3:35 pm

I can confirm that something seems to be screwed, at least when updating an existing wineprefix. Creating a new one seems to be ok though.

This is the console output I get:

Code: Select all

user@host:~$ /opt/wine-staging/bin/wineboot -u
000b:fixme:winediag:start_process Wine Staging 4.7 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
002d:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
002f:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0031:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
...
01eb:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
01ed:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
01ef:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
Maximum number of clients reached01f1:err:user:load_desktop_driver failed to load L"C:\\windows\\system32\\winex11.drv"
01f1:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
Maximum number of clients reached01f3:err:user:load_desktop_driver failed to load L"C:\\windows\\system32\\winex11.drv"
01f3:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
Maximum number of clients reached01f5:err:user:load_desktop_driver failed to load L"C:\\windows\\system32\\winex11.drv"
...
*hit ctrl+c here*
...
0315:fixme:console:CONSOLE_DefaultHandler Terminating process 8a on event 0
0313:fixme:console:CONSOLE_DefaultHandler Terminating process 84 on event 0
0314:fixme:console:CONSOLE_DefaultHandler Terminating process 96 on event 0

tosh
Newbie
Newbie
Posts: 4
Joined: Sun May 05, 2019 9:44 pm

Re: wine-mono 4.8.3 fails to be installed

Post by tosh » Tue May 07, 2019 10:22 am

Thanks, spoon0042.

Now I remember I got a similar output when starting the msi installer from the terminal. And then I wonder what would be the next step to get it fixed?

spoon0042
Level 4
Level 4
Posts: 173
Joined: Thu Dec 24, 2009 11:00 am

Re: wine-mono 4.8.3 fails to be installed

Post by spoon0042 » Tue May 07, 2019 4:50 pm

The most helpful thing to do would be to figure out reproducible steps to trigger the problem. I attempted to do this by creating a wineprefix using 4.6 then reinstalling 4.7 but that didn't trigger the issue and I haven't tried anything further. Even if you can't it may be worth filing a bug report to get the attention of someone who can better help with it.

spoon0042
Level 4
Level 4
Posts: 173
Joined: Thu Dec 24, 2009 11:00 am

Re: wine-mono 4.8.3 fails to be installed

Post by spoon0042 » Tue May 07, 2019 8:49 pm

I did a bit more poking around and went ahead and filed a bug report: https://bugs.winehq.org/show_bug.cgi?id=47141

tosh
Newbie
Newbie
Posts: 4
Joined: Sun May 05, 2019 9:44 pm

Re: wine-mono 4.8.3 fails to be installed

Post by tosh » Wed May 08, 2019 8:48 am

Thanks again, spoon0042.

Since you have kindly taken the trouble of filing a bug report and I have no more detailed information about the problem, I will wait and see what will come out of it.

tosh
Newbie
Newbie
Posts: 4
Joined: Sun May 05, 2019 9:44 pm

Re: wine-mono 4.8.3 fails to be installed

Post by tosh » Sun May 12, 2019 1:00 am

When upgrading wine-devel 4.7 to 4.8, I had the same problem again, though this time I was not prompted to install wine-mono. I had removed the cached wine-mono installers in ~/.cache/wine and elsewhere but forgot to remove the contents of Temporary Internet Files. So I guess wine detected another cached installer there and automatically started installation when updating the existing wineprefix.

Since the installation failed again and I could think of nothing else to fix the problem, I followed what spoon0042 had already suggested. Having created a new wineprefix and starting a new wine process, I was prompted to download and install the new wine-mono package and it was successfully installed.

Though I could not make sure whether something is wrong with wine or with wine-mono, everything goes well with the new wineprefix so far. I am currently on a Debian 8 amd64 based system but incidentally noticed there was no similar problem with another Ubuntu 16 i386 based system. The latter system had wine 4.7 and wine-mono 4.8.3 installed successfully on the wineprefix which was more than several months old. I wonder whether it has something to do with the difference of architectures (i386 and amd64) or simply there is something wrong with the wineprefix.

Post Reply