Missing 64-bit wineserver

Questions about Wine on Linux
Cybermax
Level 4
Level 4
Posts: 189
Joined: Fri Dec 01, 2017 5:26 pm

Re: Missing 64-bit wineserver

Post by Cybermax » Fri May 10, 2019 9:17 am

Bob Wya wrote:
UlfZibis wrote:...
Any hints are welcome !!!
The moral of the story is don't use half-baked, "pseudo-derivative" distributions...
It will always end in tears... :cry:

Bob
Mjeeehhh.. dunno... Ubuntu is kinda pseudo-derivative of Debian, so i guess its "Debian stable" ie. Debian Stretch with horribly outdated packages :)

But learning how package pinning and schtuff works would not be horribly wrong :wink:

User avatar
Bob Wya
Level 12
Level 12
Posts: 2768
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Missing 64-bit wineserver

Post by Bob Wya » Fri May 10, 2019 11:05 am

Cybermax wrote:...
Mjeeehhh.. dunno... Ubuntu is kinda pseudo-derivative of Debian, so i guess its "Debian stable" ie. Debian Stretch with horribly outdated packages :)

But learning how package pinning and schtuff works would not be horribly wrong :wink:
Not really...

Canonical rebuild all the Debian source packages and cherry-pick from testing, etc...
So it really is it's own distribution. They have their own mirrors and in-house built, binary packages.

Linux-Mint on the other hand...
Pull the vast majority of their binary packages directly from the Canonical servers.
Then they "develop" a mere handful, of their own packages.
The packages, they develop. are served up from their own servers, under a different (conflicting) release codename...

Boy, what a trainwreck and certainly not a true "Linux Distribution"...
At best Linux Mint (mainline edition) is just another wannabe Ubuntu respin.

Bob

UlfZibis
Level 3
Level 3
Posts: 50
Joined: Thu Sep 18, 2014 6:41 pm

Re: Missing 64-bit wineserver

Post by UlfZibis » Sun May 12, 2019 1:32 pm

I think I now have found a solution:

Code: Select all

$ cat /etc/apt/preferences.d/nemo_mint.pref
Package: *
Pin: release o=linuxmint
Pin-Priority: -1

Package: nemo-owncloud nemo-python
Pin: release o=Ubuntu
Pin-Priority: -1

Package: cinnamon-desktop-data cinnamon-l10n libcinnamon-desktop4 libnemo-extension1 libxapp1 nemo nemo-data nemo-fileroller xapps-common 
Pin: release o=linuxmint
Pin-Priority: 500

Package: cjs gir1.2-cinnamondesktop-3.0 gir1.2-nemo-3.0 gir1.2-xreader nemo-audio-tab nemo-compare nemo-dbg nemo-dropbox nemo-emblems nemo-filename-repairer nemo-gtkhash nemo-image-converter nemo-media-columns nemo-pastebin nemo-preview nemo-seahorse nemo-share nemo-terminal python-nemo
Pin: release o=linuxmint
Pin-Priority: 500
I think this should last to install nemo from Mint Tara as favoured and in case update:

Code: Select all

$ apt policy nemo*
nemo-image-converter:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
nemo-owncloud:
  Installiert:           (keine)
  Installationskandidat: (keine)
  Versionstabelle:
     2.4.1+dfsg-1 -1
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
nemo-keyboard:
  Installiert:           (keine)
  Installationskandidat: 0.99.0+git20130524+73edacd-0ubuntu2
  Versionstabelle:
     0.99.0+git20130524+73edacd-0ubuntu2 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
nemo-dropbox:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
nemo-folder-color-switcher:
  Installiert:           (keine)
  Installationskandidat: (keine)
  Versionstabelle:
nemo-terminal:
  Installiert:           (keine)
  Installationskandidat: 3.8.2
  Versionstabelle:
     3.8.2 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
nemo-compare:
  Installiert:           3.8.0+tara
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
 *** 3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
        100 /var/lib/dpkg/status
nemo-pastebin:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
nemo-seahorse:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
nemo-share:
  Installiert:           3.8.0+tara
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
 *** 3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
        100 /var/lib/dpkg/status
nemo-data:
  Installiert:           3.8.6+tara
  Installationskandidat: 3.8.6+tara
  Versionstabelle:
 *** 3.8.6+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
        100 /var/lib/dpkg/status
     3.6.5-1 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
nemo:
  Installiert:           3.8.6+tara
  Installationskandidat: 3.8.6+tara
  Versionstabelle:
 *** 3.8.6+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
        100 /var/lib/dpkg/status
     3.6.5-1 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
nemo-media-columns:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
nemo-fileroller:
  Installiert:           3.8.0+tara
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
 *** 3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
        100 /var/lib/dpkg/status
     3.6.0-1 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
nemo-dbg:
  Installiert:           (keine)
  Installationskandidat: 3.8.6+tara
  Versionstabelle:
     3.8.6+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
nemo-python:
  Installiert:           (keine)
  Installationskandidat: (keine)
  Versionstabelle:
     3.6.0-1 -1
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
nemo-preview:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
nemo-audio-tab:
  Installiert:           3.8.0+tara
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
 *** 3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
        100 /var/lib/dpkg/status
nemo-emblems:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
         -1 http://packages.linuxmint.com tara/backport i386 Packages
nemo-gtkhash:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
     1.1.1-2 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
nemo-filename-repairer:
  Installiert:           (keine)
  Installationskandidat: 3.8.0+tara
  Versionstabelle:
     3.8.0+tara 500
         -1 http://packages.linuxmint.com tara/backport amd64 Packages
Also with WinHQ there should be no problems any more:

Code: Select all

$ apt policy wine-stable
wine-stable:
  Installiert:           4.0~bionic
  Installationskandidat: 4.0~bionic
  Versionstabelle:
 *** 4.0~bionic 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
         -1 http://packages.linuxmint.com tara/import amd64 Packages
        100 /var/lib/dpkg/status
     3.0.5~bionic 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     3.0.4~bionic 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     3.0.3~bionic 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     3.0.2~bionic 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     3.0.1~bionic 500
        500 https://dl.winehq.org/wine-builds/ubuntu bionic/main amd64 Packages
     3.0-1ubuntu1 500
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
If one has additional comments, please don't hesitate to post them :-)

Post Reply