WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 2 [ 29 posts ] Go to page 1, 2  Next



 
Author Message
 Post Posted: Wed Apr 24, 2019 4:38 pm 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
If I run it I do not get anything:
Code:
wine DOA6.exe
000b:fixme:winediag:start_process Wine Staging 4.0-rc6 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.


I followed the wine FAQ https://wiki.winehq.org/FAQ#How_do_I_ge ... g_trace.3F.
Code:
WINEDEBUG=+relay,+seh,+tid wine your_program.exe >> /tmp/output.txt 2>&1

I attach the trace that is pretty big.

I tried also with proton (4.2-3 and 3.16-9 Beta) it started but is pretty slow.
Furthermore it freeze after trying to load the tutorial, the spinning triangle and the sound stop, so is totally unplayable.


Attachments:
File comment: trace
DOA6-output.7z [153.79 KiB]
Downloaded 6 times
Top 
 Post Posted: Wed Apr 24, 2019 4:58 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
@scorpion

That log file is useless. Way too much noise - with the +relay flag.
You've gone to the trouble of creating this log - but then omitted to supply any system information what-so-ever... :roll:

What's the output from:
Code:
glxinfo | egrep '^[[:alpha:]]'


The current Wine Staging release is 4.6 - 4.0-rc6 is an obsolete 4.0 pre-release candidate.

You'll need to use the game with dxvk - if you want to get anything more than an playable slide show.
That would require setting up 100% up-to-date Linux Vulkan support - assuming your (unspecified) graphics card supports this.

Wine's builtin DirectX 11 support is abysmal - it leverages Linux's OpenGL support and is extremely inefficient in it's usage of these libraries (which already carry a large overhead vs Vulkan).

Bob


Top 
 Post Posted: Thu Apr 25, 2019 3:59 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
Code:
glxinfo | egrep '^[[:alpha:]]'
name of display: :1
display: :1  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX version: 1.4
GLX extensions:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1060 3GB/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 410.104
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 410.104
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 410.104
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Info on my system and graphics:
Code:
inxi -S -G
System:
  Host: debian-desktop Kernel: 5.0.0-3.1-liquorix-amd64 x86_64 bits: 64
  Desktop: Gnome 3.22.3 Distro: Debian GNU/Linux 9 (stretch)
Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] driver: nvidia v: 410.104
  Display: x11 server: X.Org 1.19.2 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1360x768~60Hz
  OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 410.104

And I updated wine now:
Code:
wine DOA6.exe
000b:fixme:winediag:start_process Wine Staging 4.6 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0026:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0026:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)


I am using dxvk from experimental (debian package), how can I check that I am using it?
I ran the ./setup_dxvk.sh.


Top 
 Post Posted: Thu Apr 25, 2019 4:41 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
I am using dxvk from experimental (debian package), how can I check that I am using it?
I ran the ./setup_dxvk.sh uninstall.


So your hardware is fine. I've a 3 Gb Geforce GTX 970M - and it has enough VRAM to run most games (although it's on the low side).
You'll want to update your Nvidia driver to 418.56 (or the current Vulkan beta driver - 418.52.05 - if you can get that with Debian).

If you run your game with:
Code:
export DXVK_HUD="full"

- in your shell env - you'll get the full (everything + the kitchen sink!) overlay HUD of DXVK information - if it is working / active.
The red frametime spikes (in the scrolling frametime graph) are a classic sign that you'll need to do some performance tuning.

Bob


Top 
 Post Posted: Thu Apr 25, 2019 7:27 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
I am not sure to how use it:
Code:
export DXVK_HUD="full" wine DOA6.exe
bash: export: `DOA6.exe': not a valid identifier


Should I use also some debug flags?


Top 
 Post Posted: Thu Apr 25, 2019 7:37 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
I am not sure to how use it:
Code:
export DXVK_HUD="full" wine DOA6.exe
bash: export: `DOA6.exe': not a valid identifier


Should I use also some debug flags?


:mrgreen:
Close, but it's either:
Code:
export DXVK_HUD="full"
wine DOA6.exe

or
Code:
env DXVK_HUD="full" wine DOA6.exe


In the former case the DXVK_HUD env variable will persist for the remainder of the currrent shell session.
In the latter case the DXVK_HUD env variable will only persist for the single command.

Bob


Top 
 Post Posted: Thu Apr 25, 2019 10:43 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
Code:
env DXVK_HUD="full" wine DOA6.exe
000b:fixme:winediag:start_process Wine Staging 4.6 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.

So no dxvk?

I installed again dxvk:
Code:
cd /usr/lib/dxvk/wine64-development/
./setup_dxvk.sh install
WINEPREFIX is not set, continue? (y/N)
y
[1/5] dxgi:
    [1/2] Creating override...
    [2/2] Creating link to dxgi.dll.so...
[2/5] d3d10:
    [1/2] Creating override...
    [2/2] Creating link to d3d10.dll.so...
[3/5] d3d10_1:
    [1/2] Creating override...
    [2/2] Creating link to d3d10_1.dll.so...
[4/5] d3d10core:
    [1/2] Creating override...
    [2/2] Creating link to d3d10core.dll.so...
[5/5] d3d11:
    [1/2] Creating override...
    [2/2] Creating link to d3d11.dll.so...

Do I need to set the WINEPREFIX?


Top 
 Post Posted: Thu Apr 25, 2019 12:34 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
@scorpion

What's the output from:
Code:
vulkaninfo | egrep '^[[:alpha:]]' | head -n 21

(from the native Linux vulkan-tools package).

You'll need to ensure you have the multilib, native Linux libvulkan1 package installed.

Ta
Bob


Top 
 Post Posted: Thu Apr 25, 2019 2:16 pm 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
I had to install vulkan-utils.
Code:
vulkaninfo | egrep '^[[:alpha:]]' | head -n 21
VULKAN INFO
Vulkan API Version: 1.0.39
INFO: [Loader Message] Code 0 : Searching the following paths for manifest files: /etc/xdg/vulkan/explicit_layer.d:/etc/vulkan/explicit_layer.d:/usr/share/gnome/vulkan/explicit_layer.d:/usr/local/share//vulkan/explicit_layer.d:/usr/share//vulkan/explicit_layer.d
INFO: [Loader Message] Code 0 : Searching the following path for manifest files: /root/.local/share/vulkan/explicit_layer.d
INFO: [Loader Message] Code 0 : Searching the following paths for manifest files: /etc/xdg/vulkan/implicit_layer.d:/etc/vulkan/implicit_layer.d:/usr/share/gnome/vulkan/implicit_layer.d:/usr/local/share//vulkan/implicit_layer.d:/usr/share//vulkan/implicit_layer.d
INFO: [Loader Message] Code 0 : Searching the following path for manifest files: /root/.local/share/vulkan/implicit_layer.d
INFO: [Loader Message] Code 0 : Found manifest file /usr/share//vulkan/explicit_layer.d/VkLayer_object_tracker.json, version "1.1.0"
INFO: [Loader Message] Code 0 : Found manifest file /usr/share//vulkan/explicit_layer.d/VkLayer_threading.json, version "1.1.0"
INFO: [Loader Message] Code 0 : Found manifest file /usr/share//vulkan/explicit_layer.d/VkLayer_parameter_validation.json, version "1.1.0"
INFO: [Loader Message] Code 0 : Found manifest file /usr/share//vulkan/explicit_layer.d/VkLayer_standard_validation.json, version "1.1.1"
INFO: [Loader Message] Code 0 : Encountered meta-layer VK_LAYER_LUNARG_standard_validation
INFO: [Loader Message] Code 0 : Found manifest file /usr/share//vulkan/explicit_layer.d/VkLayer_unique_objects.json, version "1.1.0"
INFO: [Loader Message] Code 0 : Found manifest file /usr/share//vulkan/explicit_layer.d/VkLayer_core_validation.json, version "1.1.0"
INFO: [Loader Message] Code 0 : Found manifest file /root/.local/share/vulkan/implicit_layer.d/steamfossilize_x86_64.json, version "1.0.0"
INFO: [Loader Message] Code 0 : Found manifest file /root/.local/share/vulkan/implicit_layer.d/steamoverlay_i386.json, version "1.0.0"
INFO: [Loader Message] Code 0 : Found manifest file /root/.local/share/vulkan/implicit_layer.d/steamoverlay_x86_64.json, version "1.0.0"
INFO: [Loader Message] Code 0 : Found manifest file /root/.local/share/vulkan/implicit_layer.d/steamfossilize_i386.json, version "1.0.0"
INFO: [Loader Message] Code 0 : Meta-layer VK_LAYER_LUNARG_standard_validation component layer VK_LAYER_GOOGLE_threading adding instance extension VK_EXT_debug_report
INFO: [Loader Message] Code 0 : Meta-layer VK_LAYER_LUNARG_standard_validation component layer VK_LAYER_LUNARG_parameter_validation adding instance extension VK_EXT_debug_report
INFO: [Loader Message] Code 0 : Meta-layer VK_LAYER_LUNARG_standard_validation component layer VK_LAYER_LUNARG_parameter_validation adding device extension VK_EXT_debug_marker
INFO: [Loader Message] Code 0 : Meta-layer VK_LAYER_LUNARG_standard_validation component layer VK_LAYER_LUNARG_object_tracker adding instance extension VK_EXT_debug_report


Top 
 Post Posted: Thu Apr 25, 2019 2:34 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
I had to install vulkan-utils.
Code:
vulkaninfo | egrep '^[[:alpha:]]' | head -n 21
VULKAN INFO
Vulkan API Version: 1.0.39


Ouch... That's positively archaic... :shock: :o
You'll have to update that... As recent a Vulkan version as possible (plz).

On my system:
Code:
VULKANINFO
Vulkan Instance Version: 1.1.106
...


FYI I have added winetricks verbs for all the recent pre-built dxvk versions.
These will install to current WINEPREFIX only.
Personally I find these a lot easier to use, when installing/updating dxvk on my system...

Obviously you'd need to update your (probably very out-dated) winetricks script as well! :lol:

Bob


Top 
 Post Posted: Thu Apr 25, 2019 3:26 pm 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
I updated vulkan-utils from the backports:
Code:
ulkaninfo | egrep '^[[:alpha:]]' | head -n 21
VULKAN INFO
Vulkan Instance Version: 1.1.70
Instance Extensions:
Instance Extensions   count = 15
Layers: count = 10
VK_LAYER_LUNARG_object_tracker (LunarG Validation Layer) Vulkan version 1.1.70, layer version 1
VK_LAYER_GOOGLE_threading (Google Validation Layer) Vulkan version 1.1.70, layer version 1
VK_LAYER_LUNARG_parameter_validation (LunarG Validation Layer) Vulkan version 1.1.70, layer version 1
VK_LAYER_LUNARG_standard_validation (LunarG Standard Validation) Vulkan version 1.1.70, layer version 1
VK_LAYER_GOOGLE_unique_objects (Google Validation Layer) Vulkan version 1.1.70, layer version 1
VK_LAYER_LUNARG_core_validation (LunarG Validation Layer) Vulkan version 1.1.70, layer version 1
VK_LAYER_VALVE_steam_fossilize_64 (Steam Pipeline Caching Layer) Vulkan version 1.1.73, layer version 1
VK_LAYER_VALVE_steam_overlay_32 (Steam Overlay Layer) Vulkan version 1.1.73, layer version 1
VK_LAYER_VALVE_steam_overlay_64 (Steam Overlay Layer) Vulkan version 1.1.73, layer version 1
VK_LAYER_VALVE_steam_fossilize_32 (Steam Pipeline Caching Layer) Vulkan version 1.1.73, layer version 1
Presentable Surfaces:
GPU id       : 0 (GeForce GTX 1060 3GB)
Surface type : VK_KHR_xcb_surface
Formats:      count = 2
Present Modes:      count = 3
VkSurfaceCapabilitiesKHR:

I already updated winetricks using the sid package:
Code:
winetricks -V
20181203 - sha256sum: 2eb7f32797cfe0cfd884dac3bf5c972f93f9a05ef1a871bc4e0d8728bd1a4431

But the game does not start:
Code:
env DXVK_HUD="full" wine DOA6.exe
000b:fixme:winediag:start_process Wine Staging 4.6 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
0026:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0026:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)


Top 
 Post Posted: Thu Apr 25, 2019 3:56 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
I updated vulkan-utils from the backports:
Code:
ulkaninfo | egrep '^[[:alpha:]]' | head -n 21
VULKAN INFO
Vulkan Instance Version: 1.1.70
...

I already updated winetricks using the sid package:
Code:
winetricks -V
20181203 - sha256sum: 2eb7f32797cfe0cfd884dac3bf5c972f93f9a05ef1a871bc4e0d8728bd1a4431

...


You need a newer Vulkan version.
I've literally shown my installed Vulkan version, which is months newer than 1.1.70...

Your winetricks version is not up-to-date as well.
See my updated winetricks readme branch: github: bobwya / winetricks: winetricks / README.md

IMHO stable Debian is not a great choice for a Linux gaming distribution. :roll:

Bob


Top 
 Post Posted: Thu Apr 25, 2019 4:37 pm 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
I followed the github instruction for debian I do not want to install it manually.

Do I really need a newer Vulkan version? Where can I check?


Top 
 Post Posted: Fri Apr 26, 2019 3:16 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
I followed the github instruction for debian I do not want to install it manually.

Do I really need a newer Vulkan version? Where can I check?


I'll check, with Philip Rebohle, what the currently recommended minimum Vulkan version is.
But I don't think you'll like the answer! I'll get back to you to with this, probably later on today.

IMHO OT etc... :mrgreen:
Fedora, Ubuntu, Solus, Gentoo, Arch, OpenSUSE can be tuned quite easily for a good Linux gaming experience.
Debian Stable packaing is simply put, too outdated. But I'd would recommend at least hunting around for a good third party repository (it's a popular distribution, so that shouldn't be too hard).
Debian Testing would probably a good candidate.

The release cadiance of Vulkan is too rapid for such a slow moving distribution.
Vulkan is still a very immature graphics static.

My personal experience, with mainly with Arch and Gentoo, has been very solid, for a good Linux gaming experience under Vulkan, both native Linux with and Wine/dxvk titles.

Bob


Top 
 Post Posted: Fri Apr 26, 2019 10:52 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
What are the interested packages?
Now I have a new resolution: 3840x2160~60Hz.


Top 
 Post Posted: Fri Apr 26, 2019 12:04 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
@scorpion

Philip responded with (on discord):
Quote:
I keep saying the vulkan version reported by the driver doesn't matter, bugs and extension support matter just point them to the driver section on my wiki

Referencing this: Github: doitsujin / dxvk : Driver support.

Unfortunately the dxvk Wiki is very vague about the minimum Vulkan layer version required...
Which is why, I reiterate just stay on the current Vulkan release.

Personally I rev my Gentoo Vulkan packages every world update I make (which equates to roughly every 2 weeks).
New Vulkan releases are very frequent.

Bob


Top 
 Post Posted: Sat Apr 27, 2019 2:35 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
This is from the log of proton 4.2:
Code:
======================
Proton: 1555612643 proton-4.2-3b
SteamGameId: 838380
Command: ['/user/Games/steam/steamapps/common/Dead or Alive 6/DOA6.exe']
======================
ERROR: ld.so: object '/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/user/.steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/user/.steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: ld.so: object '/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
3247.342:0008:0009:trace:module:load_builtin_callback loaded ntdll.dll 0x110b98 0x7bc10000
3247.342:0008:0009:trace:module:load_builtin_dll Trying built-in L"kernel32.dll"
3247.343:0008:0009:trace:module:load_dll looking for L"ntdll.dll" in L""
3247.343:0008:0009:trace:module:load_dll Found L"C:\\windows\\system32\\ntdll.dll" for L"ntdll.dll" at 0x7bc10000, count=2
3247.343:0008:0009:trace:module:load_builtin_callback loaded KERNEL32.dll 0x110ca8 0x7b420000
3247.343:0008:0009:trace:module:LdrGetDllHandle L"kernel32" -> 0x7b420000 (load path (null))
ERROR: ld.so: object '/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
[...]
err:   D3D11: CreateGeometryShaderWithStreamOutput:
  Transform feedback not supported by device
[...]
err:   D3D11: CreateGeometryShaderWithStreamOutput:
  Transform feedback not supported by device
ERROR: ld.so: object '/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
[...]
3247.382:000a:000b:err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
ERROR: ld.so: object '/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
[...]
ERROR: ld.so: object '/user/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
[...]
3249.464:0028:0029:err:ole:CoGetClassObject class {e018945b-aa86-4008-9bd4-6777a1e40c11} not registered
3249.464:0028:0029:err:ole:CoGetClassObject no class object {e018945b-aa86-4008-9bd4-6777a1e40c11} could be created for context 0x1
[...]


Top 
 Post Posted: Sat Apr 27, 2019 7:00 am 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
This is from the log of proton 4.2:
Code:
err:   D3D11: CreateGeometryShaderWithStreamOutput:
  Transform feedback not supported by device
[...]
err:   D3D11: CreateGeometryShaderWithStreamOutput:
  Transform feedback not supported by device



You need at a minimum Vulkan version 1.1.88 to support Transform Feedback calls.
My winetricks dxvk verbs even state this (as a warning message), when you are installing one of the newer dxvk versions...

I've already stated you need to install a more up-to-date version of Vulkan.
Am I not being clear enough in my choice of language?? :shock:

Bob


Top 
 Post Posted: Thu May 02, 2019 12:11 pm 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
I installed vulkan from testing:
Code:
vulkaninfo | egrep '^[[:alpha:]]' | head -n 21
VULKANINFO
Vulkan Instance Version: 1.1.97
Instance Extensions:
Instance Extensions   count = 16
Layers: count = 10
VK_LAYER_GOOGLE_threading (Google Validation Layer) Vulkan version 1.1.97, layer version 1
VK_LAYER_GOOGLE_unique_objects (Google Validation Layer) Vulkan version 1.1.97, layer version 1
VK_LAYER_LUNARG_core_validation (LunarG Validation Layer) Vulkan version 1.1.97, layer version 1
VK_LAYER_LUNARG_object_tracker (LunarG Validation Layer) Vulkan version 1.1.97, layer version 1
VK_LAYER_LUNARG_parameter_validation (LunarG Validation Layer) Vulkan version 1.1.97, layer version 1
VK_LAYER_LUNARG_standard_validation (LunarG Standard Validation) Vulkan version 1.1.97, layer version 1
VK_LAYER_VALVE_steam_fossilize_32 (Steam Pipeline Caching Layer) Vulkan version 1.1.73, layer version 1
VK_LAYER_VALVE_steam_fossilize_64 (Steam Pipeline Caching Layer) Vulkan version 1.1.73, layer version 1
VK_LAYER_VALVE_steam_overlay_32 (Steam Overlay Layer) Vulkan version 1.1.73, layer version 1
VK_LAYER_VALVE_steam_overlay_64 (Steam Overlay Layer) Vulkan version 1.1.73, layer version 1
Presentable Surfaces:
GPU id       : 0 (GeForce GTX 1060 3GB)
Surface type : VK_KHR_xcb_surface
Formats:      count = 2
Present Modes:      count = 3
VkSurfaceCapabilitiesKHR:

What are the steam value? I do not why they are still the 1.1.73 version.

Are the 410 nvidia-drivers fine?
I always have that D3D11 error.

Can you play it well on gentoo? The core fighters is free.


Top 
 Post Posted: Thu May 02, 2019 1:31 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
@scorpion

Referencing again: Github: doitsujin / dxvk : Driver support.
(see my previous comment)

The latest Nvidia driver is: 430.09
The optimal (Vulkan beta) Nvidia driver, for DXVK support, is: 418.52.05

Bob


Top 
 Post Posted: Thu May 02, 2019 2:42 pm 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
In the dxvk page I can see:
Quote:
Recommended driver version: 415.22 or later


Now I installed from sid vulkan and nvidia-drivers:
Code:
vulkaninfo | egrep '^[[:alpha:]]' | head -n 21
VULKANINFO
Vulkan Instance Version: 1.1.97

driver: nvidia v: 418.56

For my gpu the latest driver are the 418.

In the log I can see:
Code:
2383.661:000c:000d:warn:module:load_dll Failed to load module L"C:\\windows\\system32\\winemenubuilder.exe"; status=c0000135
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
2383.661:000c:000d:trace:module:LdrShutdownProcess ()
2383.662:000a:000b:err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
ERROR: ld.so: object '/root/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

2476.259:002a:007b:trace:seh:call_vectored_handlers calling handler at 0x6a433b40 code=406d1388 flags=0
2476.259:002a:007b:trace:seh:call_vectored_handlers handler at 0x6a433b40 returned ffffffff
err:   D3D11: CreateGeometryShaderWithStreamOutput: Rasterized stream not supported

2385.961:002a:002b:err:ole:CoGetClassObject class {e018945b-aa86-4008-9bd4-6777a1e40c11} not registered
2385.961:002a:002b:err:ole:CoGetClassObject no class object {e018945b-aa86-4008-9bd4-6777a1e40c11} could be created for context 0x1


Top 
 Post Posted: Thu May 02, 2019 2:55 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
...
For my gpu the latest driver are the 418.

In the log I can see:
Code:
2383.661:000c:000d:warn:module:load_dll Failed to load module L"C:\\windows\\system32\\winemenubuilder.exe"; status=c0000135
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
2383.661:000c:000d:trace:module:LdrShutdownProcess ()
2383.662:000a:000b:err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
ERROR: ld.so: object '/root/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

2476.259:002a:007b:trace:seh:call_vectored_handlers calling handler at 0x6a433b40 code=406d1388 flags=0
2476.259:002a:007b:trace:seh:call_vectored_handlers handler at 0x6a433b40 returned ffffffff
err:   D3D11: CreateGeometryShaderWithStreamOutput: Rasterized stream not supported

2385.961:002a:002b:err:ole:CoGetClassObject class {e018945b-aa86-4008-9bd4-6777a1e40c11} not registered
2385.961:002a:002b:err:ole:CoGetClassObject no class object {e018945b-aa86-4008-9bd4-6777a1e40c11} could be created for context 0x1


@scorpion

Ah, so we're getting "somewhere"...

Looks like:

Github : doitsujin/dxvk Issues : Question about new transform feedback support: Metro LL still gets "Rasterized stream not supported".. #698 ;

might be relevant to your problem then...

Bob


Top 
 Post Posted: Fri May 03, 2019 7:05 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
doitsujin said that "err: D3D11: CreateGeometryShaderWithStreamOutput: Rasterized stream not supported" is not important https://github.com/doitsujin/dxvk/issues/698.

So now I do not know what to do or what is the problem.


Top 
 Post Posted: Sat May 04, 2019 3:38 am 
Offline
Level 2
Level 2

Joined: Sun Dec 02, 2018 12:18 pm
Posts: 38
@Bob Wya Can you play it on Gentoo?


Top 
 Post Posted: Sat May 04, 2019 2:54 pm 
Offline
Level 12
Level 12
User avatar

Joined: Sat Oct 16, 2010 7:40 pm
Posts: 2560
Location: Cambridge
scorpion wrote:
@Bob Wya Can you play it on Gentoo?


I had a shot with Proton (aka Steam Play) and Wine Staging 4.7 - using the free version of DEAD OR ALIVE 6...
I can only get to the menu screen and then the game crashes or freezes (music still playing)...
DXVK does launch OK - because I can see the DXVK HUD.
It appears to be an issue in Wine itself.

I was following some recommendations from: Github: ValveSoftware / Proton Issues: Dead or Alive 6 (838380) - Story mode requires DXVA2 and Media Foundation #2420.
So obviously I've missed something - since folks are getting further into the game than I am...
Obviously I'd advise you to subscribe to that (Github) topic.

I'll maybe try it one of the other Linux distributions I have installed - tomorrow hopefully! 8)

Bob


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 2 [ 29 posts ] Go to page 1, 2  Next




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 17 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: